seduction
 Language:
Welcome, Guest. Please login or register.
Did you miss your activation email?
2020/10/29, 20:34:02


Help

Author [EN] [PL] [ES] [PT] [IT] [DE] [FR] [NL] [TR] [SR] [AR] [RU] Topic: [Tipp] scanimage -L findet scanner nicht  (Read 311 times)

0 Members and 1 Guest are viewing this topic.

Offline Geier0815

  • User
  • Posts: 496
[Tipp] scanimage -L findet scanner nicht
« on: 2020/10/15, 14:04:44 »
Moin Moin,

nachdem ich ziemlich lange gesucht habe warum mein Canon N670U nicht mehr funktioniert obwohl sane-find-scanner ihn angezeigt hat, hier die Auflösung:

Das Verzeichnis /var/lock/sane fehlt, wurde nicht angelegt nach einem Update. Bugreport #971584 enthält die Lösung dieses Verzeichnis mit User:Gruppe saned:scanner anzulegen. Ob das jetzt nur Scanner betrifft die das plustek-backend verwenden ist mir nicht ganz klar.

Vielleicht hilft es jemand...
Wenn Windows die Lösung ist...
kann ich dann bitte das Problem zurück haben?

Offline Geier0815

  • User
  • Posts: 496
Re: [Tipp] scanimage -L findet scanner nicht
« Reply #1 on: 2020/10/15, 14:55:32 »
Etwas zu früh gefreut. Das Verzeichnis wird beim reboot gelöscht.
Des weiteren klappt der Zugriff als normaler User nicht, selbst wenn man entsprechend diesem Post in einem Bugreport vorgeht (auf diesen wurde vom debian-wiki aus verlinkt).
Wenigstens kann ich temporär als root scannen.
Wenn Windows die Lösung ist...
kann ich dann bitte das Problem zurück haben?

Offline ajavibp

  • User
  • Posts: 102
    • The website of the association where I collaborate.
Re: [Tipp] scanimage -L findet scanner nicht
« Reply #2 on: 2020/10/15, 18:34:42 »
I had the same problem (and the same scanner). Please, If you can solve it, notify.I make my user the owner of the '/var/lock/sane' folder so I can use it without root. It's a rough patch, but it works for now.

Offline hendrikL

  • User
  • Posts: 442
Re: [Tipp] scanimage -L findet scanner nicht
« Reply #3 on: 2020/10/15, 19:06:08 »
mh, if group scanner is the owner rw (read write) as described in the link above and you are also in the group scanner (check with groups as $user) it should work without to be root. It should!

Offline axt

  • User
  • Posts: 443
    • axebase.net
Re: [Tipp] scanimage -L findet scanner nicht
« Reply #4 on: 2020/10/15, 22:35:32 »
Quote from: Geier0815
Wenigstens kann ich temporär als root scannen.

Aber genau das sagt doch Rechteproblem.

Füge in "/lib/udev/rules.d/40-libsane.rules" (oder wie das File aktuell unter Debian heißt) an das Ende der Geräteliste vor der Zeile "# The following rule will disable" ein:

Code: [Select]
# Canon scanners
ATTRS{idVendor}=="04a9", ENV{libsane_matched}="yes"

Speichere und reboote oder starte den Service neu!


Offline Geier0815

  • User
  • Posts: 496
Re: [Tipp] scanimage -L findet scanner nicht
« Reply #5 on: 2020/10/16, 07:57:30 »
Ok, das mit den Userrechten hat sich geklärt. Man sollte schon 775 vergeben und nicht wie ich 755. Nach knapp 4 Stunden suchen gestern, war meine Aufmerksamkeit auch nicht mehr das was sie hätte sein sollen.
Trotzdem bleibt das Problem das das Verzeichnis nach einem reboot wieder weg ist.
Wenn Windows die Lösung ist...
kann ich dann bitte das Problem zurück haben?