seduction
 Language:
Welcome, Guest. Please login or register.
Did you miss your activation email?
2020/11/24, 19:13:40


Help

Author [EN] [PL] [ES] [PT] [IT] [DE] [FR] [NL] [TR] [SR] [AR] [RU] Topic: Many kdepim suite packages upgrade fail  (Read 333 times)

0 Members and 1 Guest are viewing this topic.

Offline sunrat

  • User
  • Posts: 376
Many kdepim suite packages upgrade fail
« on: 2020/10/23, 23:33:17 »
d-u today fails with many version mismatches of kdepim related packages. The list is long but here are the first few:
Code: [Select]
# apt full-upgrade
Reading package lists... Done
Building dependency tree       
Reading state information... Done
You might want to run 'apt --fix-broken install' to correct these.
The following packages have unmet dependencies:
 accountwizard : Depends: libkf5akonadicore5-20.08
                 Depends: libkf5akonadicore5abi2 (>= 4:20.08.2) but 4:20.04.1-4 is installed
                 Depends: libkf5akonadiwidgets5-20.08
                 Depends: libkf5akonadiwidgets5abi1 (>= 4:20.08.2) but 4:20.04.1-4 is installed
                 Depends: libkf5identitymanagement5 (>= 20.08.2) but 20.04.1-2 is installed
                 Depends: libkf5identitymanagement5-20.08
                 Depends: libkf5krosscore5 (>= 5.71.0~) but 5.70.0-1 is installed
                 Depends: libkf5ldap5-20.08
                 Depends: libkf5ldap5abi1 (>= 20.08.2) but 20.04.1-2 is installed
                 Depends: libkf5libkdepim5 (>= 4:20.08.2) but 4:20.04.1-2 is installed
                 Depends: libkf5libkdepim5-20.08
                 Depends: libkf5libkleo5 (>= 4:20.08.2) but 4:20.04.1-2 is installed
                 Depends: libkf5libkleo5-20.08
                 Depends: libkf5mailtransport5 (>= 20.08.2) but 20.04.1-2 is installed
                 Depends: libkf5mailtransport5-20.08
                 Depends: libkf5mime5-20.08
                 Depends: libkf5mime5abi1 (>= 20.08.2) but 20.04.1-1 is installed
                 Depends: libkf5newstuffcore5 (>= 5.71.0~) but 5.70.0-1 is installed
                 Depends: libkf5pimcommon5-20.08
                 Depends: libkf5pimcommon5abi2 (>= 4:20.08.2) but 4:20.04.1-2 is installed
 akonadi-server : Depends: libkf5akonadiprivate5-20.08
                  Depends: libkf5akonadiprivate5abi2 (>= 4:20.08.2) but 4:20.04.1-4 is installed
                  Depends: libkf5akonadiwidgets5-20.08
                  Depends: libkf5akonadiwidgets5abi1 (>= 4:20.08.2) but 4:20.04.1-4 is installed
 akonadiconsole : Depends: libkf5akonadixml5-20.04 but it is not installable
                  Depends: libkf5calendarsupport5-20.04 but it is not installable
 kaddressbook : Depends: libkf5akonadicontact5 (>= 4:20.08.2) but 4:20.04.1-2 is installed
...

Offline dpanter

  • User
  • Posts: 10
Re: Many kdepim suite packages upgrade fail
« Reply #1 on: 2020/10/24, 00:43:54 »
The KDEPIM 20.08 and Frameworks 5.74.0 transition had to be done at the same time, that's why it's a bit messy. Should be completed shortly.

Worth noting, KDEPIM 20.08 removed 4 libraries:
* libkf5libkdepimakonadi5
* libkf5followupreminder5
* libkf5kdepimdbusinterfaces5
* libkf5followupreminder5
<< insert signature here >>

Offline sunrat

  • User
  • Posts: 376
Re: Many kdepim suite packages upgrade fail
« Reply #2 on: 2020/10/24, 02:25:27 »
The KDEPIM 20.08 and Frameworks 5.74.0 transition had to be done at the same time, that's why it's a bit messy.
Thanks for that info. I figured it must be something like that. Waiting...  :)

Offline H-Cl

  • User
  • Posts: 126
Re: Many kdepim suite packages upgrade fail
« Reply #3 on: 2020/10/24, 06:04:59 »
2 days ago I had to "apt --fix-broken install" twice on my laptop. Yesterday the update of my desktop went fine, so I think this is fixed.
Dignus est intrare (Acidix Hydrochloridix)

Offline sunrat

  • User
  • Posts: 376
Re: Many kdepim suite packages upgrade fail
« Reply #4 on: 2020/10/24, 07:21:57 »
Yesterday is when it first didn't succeed here and still doesn't now.

Offline Pip

  • User
  • Posts: 73
Re: Many kdepim suite packages upgrade fail
« Reply #5 on: 2020/10/24, 09:24:24 »
Worth noting, KDEPIM 20.08 removed 4 libraries:
* libkf5libkdepimakonadi5
* libkf5followupreminder5
* libkf5kdepimdbusinterfaces5
* libkf5followupreminder5
The fourth library removed is libkf5sendlater5.
I wasn't sure whether they were ok to remove, so I tried it out on a spare system, where it errored out. With --fix-broken I got the dependency issues. However, when I turned off Kontact and akonadi, it went through.
I'm still not comfortable doing it on my main system, though.

Offline sunrat

  • User
  • Posts: 376
Re: Many kdepim suite packages upgrade fail
« Reply #6 on: 2020/10/24, 13:06:54 »
I don't use kdepim or akonadi so tried aptitude to see what it would propose.
Code: [Select]
The following actions will resolve these dependencies:

     Remove the following packages:               
1)     libkf5libkdepimakonadi5 [4:20.04.1-2 (now)]
2)     libkf5sendlater5 [4:20.04.1-2 (now)]       
3)     libkpmcore9 [4.1.0-2 (now)]               

     Install the following packages:             
4)     libkpmcore10 [4.2.0-2 (unstable)]

Completed successfully. libkpmcore10 is KDE Partition Manager lib.