seduction
 Language:
Welcome, Guest. Please login or register.
Did you miss your activation email?
2020/11/24, 18:59:20


Help

Author [EN] [PL] [ES] [PT] [IT] [DE] [FR] [NL] [TR] [SR] [AR] [RU] Topic: Warning: packages will be removed (Warning period over)  (Read 742 times)

0 Members and 1 Guest are viewing this topic.

Offline Pip

  • User
  • Posts: 73
Haven't investigate at all yet, but it certainly made me pause.

The following packages will be REMOVED:
  gvfs-backends kio-extras libreoffice libreoffice-librelogo libreoffice-lightproof-en
  libreoffice-script-provider-python libsmbclient python3-ldb python3-samba python3-smbc python3-uno
  samba-common-bin samba-dsdb-modules samba-libs smbclient virtualbox virtualbox-qt vlc-plugin-samba
  winbind
« Last Edit: Yesterday at 11:27:36 by Pip »

Offline Carnophage

  • User
  • Posts: 21
    • http://carnophage.wordpress.com
Re: Warning: packages will be removed
« Reply #1 on: 2020/11/19, 16:00:01 »
https://release.debian.org/transitions/html/python3.9-default.html

Default python3 migration Python3.8->Python3.9

Offline GoinEasy9

  • User
  • Posts: 473
Re: Warning: packages will be removed
« Reply #2 on: 2020/11/21, 05:07:00 »

I don't want to lose LibreOffice ... it's probably worth waiting until it's resolved. I don't see a replacement yet.

Linux Counter number 348347

Offline Pip

  • User
  • Posts: 73
Re: Warning: packages will be removed
« Reply #3 on: 2020/11/21, 06:38:52 »
Definitely worth waiting: the count of the endangered packages has gone down:
The following packages will be REMOVED:
  libreoffice libreoffice-librelogo libreoffice-lightproof-en libreoffice-script-provider-python
  python3-samba python3-uno samba-common-bin winbind


Offline Camelot

  • User
  • Posts: 51
Re: Warning: packages will be removed
« Reply #4 on: 2020/11/21, 10:28:13 »
You don’t have to wait when you use apt upgrade.

Code: [Select]
The following packages have been kept back:
  hplip libhpmud0 libldb2 libpython3-stdlib libsane-hpaio libsmbclient
  libtalloc2 libtdb1 libwbclient0 printer-driver-hpcups printer-driver-hpijs
  python3 python3-ldb python3-minimal python3-samba python3-talloc python3-tdb
  samba-common samba-common-bin samba-dsdb-modules samba-libs winbind

Offline dibl

  • siduction community member
  • Global Moderator
  • User
  • *****
  • Posts: 2.054
    • Land of the Buckeye
Re: Warning: packages will be removed
« Reply #5 on: 2020/11/21, 10:49:02 »
When I saw the gvfs-backends and the samba-related packages being removed, I let them go because I don't use samba.  Today, I see that all of that is now installable again:

Code: [Select]
don@dibl-HP350:~$ sudo apt -s install gvfs-backends
Reading package lists... Done
Building dependency tree       
Reading state information... Done
The following additional packages will be installed:
  gnome-keyring gnome-keyring-pkcs11 libgdata-common libgdata22 libgoa-1.0-0b
  libgoa-1.0-common libldb2 libpam-gnome-keyring libsmbclient libwbclient0 p11-kit
  p11-kit-modules python3-ldb python3-talloc samba-libs
Suggested packages:
  samba-common
The following NEW packages will be installed:
  gnome-keyring gnome-keyring-pkcs11 gvfs-backends libgdata-common libgdata22
  libgoa-1.0-0b libgoa-1.0-common libldb2 libpam-gnome-keyring libsmbclient p11-kit
  p11-kit-modules python3-ldb python3-talloc samba-libs
The following packages will be upgraded:
  libwbclient0
1 upgraded, 15 newly installed, 0 to remove and 11 not upgraded.

Here, there were no LibreOffice removals, and LibreOffice is working as expected.
Asus ROG STRIX X299-E, Core i7-7740X, Nvidia GTX-1060, dual monitors, SSD 860 EVO, 2@WD1003FZEX in BTRFS

Offline unklarer

  • User
  • Posts: 534
Re: Warning: packages will be removed
« Reply #6 on: 2020/11/21, 11:19:14 »
I can confirm that kio-extras could be installed again this morning.  ;)

Offline Penyelam

  • User
  • Posts: 158
Re: Warning: packages will be removed
« Reply #7 on: Yesterday at 11:08:35 »
Did a DU recently, openoffice was upgraded.

Offline Pip

  • User
  • Posts: 73
Re: Warning: packages will be removed
« Reply #8 on: Yesterday at 11:24:36 »
Yep, no more warnings for removal for me either.

Offline axt

  • User
  • Posts: 454
    • axebase.net
Re: Warning: packages will be removed (Warning period over)
« Reply #9 on: Yesterday at 13:21:46 »
Quote from: Penyelam
openoffice was upgraded.

Not really. ;-)