seduction
 Language:
Welcome, Guest. Please login or register.
Did you miss your activation email?
2021/01/27, 02:58:06


Help

Author [EN] [PL] [ES] [PT] [IT] [DE] [FR] [NL] [TR] [SR] [AR] [RU] Topic: elpa-company  (Read 362 times)

0 Members and 1 Guest are viewing this topic.

Offline finotti

  • User
  • Posts: 181
elpa-company
« on: 2020/12/07, 15:14:05 »
Today I had a problem when DU-ing my system.  The package "elpa-company" was pulled (it was not installed before), I assume for some dependency.  But it failed to install.  "apt -f install" and "dpkg --reconfigure -a" also did not fix the problem.  The errors I was getting were:

Code: [Select]
Setting up elpa-company (0.9.13-1) ...
Install emacsen-common for emacs
emacsen-common: Handling install of emacsen flavor emacs
Install elpa-company for emacs
install/company-0.9.13: Handling install of emacsen flavor emacs
install/company-0.9.13: byte-compiling for emacs

In toplevel form:
async-tests.el:22:1:Error: Cannot open load file: No such file or directory, company-tests

In toplevel form:
bbdb-tests.el:22:1:Error: Cannot open load file: No such file or directory, company-tests

In toplevel form:
capf-tests.el:27:1:Error: Cannot open load file: No such file or directory, company-tests

In toplevel form:
clang-tests.el:22:1:Error: Cannot open load file: No such file or directory, company-tests

In toplevel form:
cmake-tests.el:22:1:Error: Cannot open load file: No such file or directory, company-tests

In end of data:
company-tng.el:198:1:Warning: the function ‘eglot--snippet-expansion-fn’ is
    not known to be defined.

In toplevel form:
core-tests.el:22:1:Error: Cannot open load file: No such file or directory, company-tests

In toplevel form:
elisp-tests.el:24:1:Error: Cannot open load file: No such file or directory, company-tests

In toplevel form:
files-tests.el:22:1:Error: Cannot open load file: No such file or directory, company-tests

In toplevel form:
frontends-tests.el:22:1:Error: Cannot open load file: No such file or directory, company-tests

In toplevel form:
template-tests.el:22:1:Error: Cannot open load file: No such file or directory, company-tests

In toplevel form:
transformers-tests.el:22:1:Error: Cannot open load file: No such file or directory, company-tests
ERROR: install script from elpa-company package failed
dpkg: error processing package elpa-company (--configure):
 installed elpa-company package post-installation script subprocess returned error exit status 1
dpkg: dependency problems prevent configuration of elpa-graphviz-dot-mode:
 elpa-graphviz-dot-mode depends on elpa-company; however:
  Package elpa-company is not configured yet.

dpkg: error processing package elpa-graphviz-dot-mode (--configure):
 dependency problems - leaving unconfigured
Errors were encountered while processing:
 elpa-company
 elpa-graphviz-dot-mode

I found this old bug: https://bugs.debian.org/cgi-bin/bugreport.cgi?bug=920219

Although for a different version of the package, it seems to be the same bug.  The work around was to move my (user's) .emacs.d temporarily, "apt -f install" (which finished without problem), and move .emacs.d back.