seduction
 Language:
Welcome, Guest. Please login or register.
Did you miss your activation email?
2021/01/27, 00:45:11


Help

Author [EN] [PL] [ES] [PT] [IT] [DE] [FR] [NL] [TR] [SR] [AR] [RU] Topic: Plasma 5.20 Hangs  (Read 789 times)

0 Members and 1 Guest are viewing this topic.

Offline finotti

  • User
  • Posts: 181
Plasma 5.20 Hangs
« on: 2020/12/24, 14:41:33 »
I've updated Plasma in three systems, one desktop running aptosid and two laptops running siduction.  The desktop and one of the laptops are working perfectly, but one of the laptops (running up to date siduction) hangs in the splash screen.

I've tried older kernels, removing the .kde directory, new user, and nothing worked.  SDDM shows up fine and I can log in fluxbox, but plasma always hangs in the splash screen.

I cannot copy and paste right now (as my son is using it in Windows) but here is some older info about the system:

Code: [Select]
# inxi -v3
System:    Host: l5580 Kernel: 5.8.10-towo.1-siduction-amd64 x86_64 bits: 64 compiler: N/A
           Desktop: KDE Plasma 5.17.5 Distro: siduction 18.2.0 Patience - kde - (201803072323)
           base: Debian GNU/Linux bullseye/sid
Machine:   Type: Laptop System: Dell product: Latitude 5580 v: N/A serial: C306PN2
           Mobo: Dell model: 0DN786 v: A00 serial: /C306PN2/CNCMK0074D014B/ UEFI: Dell v: 1.16.0
           date: 07/03/2019
Battery:   ID-1: BAT0 charge: 65.1 Wh condition: 65.1/68.0 Wh (96%) model: SMP DELL GD1JP65 status: Full
CPU:       Info: Quad Core model: Intel Core i7-7820HQ bits: 64 type: MT MCP arch: Kaby Lake rev: 9
           L2 cache: 8192 KiB
           flags: avx avx2 lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx bogomips: 46398
           Speed: 3736 MHz min/max: 800/3900 MHz Core speeds (MHz): 1: 2873 2: 3585 3: 2710 4: 2738
           5: 3733 6: 2555 7: 2627 8: 2979
Graphics:  Device-1: Intel HD Graphics 630 vendor: Dell driver: i915 v: kernel bus ID: 00:02.0
           Device-2: NVIDIA GM107 [GeForce 940MX] vendor: Dell driver: N/A bus ID: 01:00.0
           Device-3: Realtek Integrated Webcam_HD type: USB driver: uvcvideo bus ID: 1-11:3
           Display: x11 server: X.Org 1.20.9 driver: modesetting unloaded: fbdev,vesa
           resolution: 1920x1080~60Hz
           OpenGL: renderer: Mesa Intel HD Graphics 630 (KBL GT2) v: 4.6 Mesa 20.1.8 direct render: Yes
Network:   Device-1: Intel Ethernet I219-LM vendor: Dell driver: e1000e v: 3.2.6-k port: f040
           bus ID: 00:1f.6
           IF: enp0s31f6 state: down mac: d4:81:d7:bc:94:0c
           Device-2: Qualcomm Atheros QCA6174 802.11ac Wireless Network Adapter vendor: Dell
           driver: ath10k_pci v: kernel port: e000 bus ID: 02:00.0
           IF: wlp2s0 state: up mac: 5c:ea:1d:7c:fe:63
           Device-3: Qualcomm Atheros type: USB driver: btusb bus ID: 1-6:2
Drives:    Local Storage: total: 357.98 GiB used: 172.74 GiB (48.3%)
Info:      Processes: 304 Uptime: 19m Memory: 15.52 GiB used: 3.37 GiB (21.7%) Init: systemd runlevel: 5
           Compilers: gcc: 10.2.0 Packages: 5300 Shell: Bash v: 5.0.18 inxi: 3.1.06

Any suggestions?

Offline finotti

  • User
  • Posts: 181
Re: Plasma 5.20 Hangs
« Reply #1 on: 2020/12/24, 14:54:40 »
OK, quick login in fluxbox.  Current info:

Code: [Select]
$ inxi -v3
System:    Host: l5580 Kernel: 5.9.15-towo.1-siduction-amd64 x86_64 bits: 64 compiler: gcc v: 10.2.1 Desktop: Fluxbox 1.3.5
           Distro: siduction 18.2.0 Patience - kde - (201803072323) base: Debian GNU/Linux bullseye/sid
Machine:   Type: Laptop System: Dell product: Latitude 5580 v: N/A serial: <superuser required>
           Mobo: Dell model: 0DN786 v: A00 serial: <superuser required> UEFI: Dell v: 1.17.1 date: 01/07/2020
Battery:   ID-1: BAT0 charge: 66.6 Wh condition: 66.6/68.0 Wh (98%) model: SMP DELL GD1JP65 status: Full
CPU:       Info: Quad Core model: Intel Core i7-7820HQ bits: 64 type: MT MCP arch: Kaby Lake rev: 9 L2 cache: 8 MiB
           flags: avx avx2 lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx bogomips: 46398
           Speed: 3700 MHz min/max: 800/3900 MHz Core speeds (MHz): 1: 3700 2: 3644 3: 3664 4: 3701 5: 3744 6: 3677 7: 3749
           8: 3657
Graphics:  Device-1: Intel HD Graphics 630 vendor: Dell driver: i915 v: kernel bus ID: 00:02.0
           Device-2: NVIDIA GM107 [GeForce 940MX] vendor: Dell driver: N/A bus ID: 01:00.0
           Device-3: Realtek Integrated Webcam_HD type: USB driver: uvcvideo bus ID: 1-11:4
           Display: x11 server: X.Org 1.20.10 driver: modesetting unloaded: fbdev,vesa resolution: 1: 1920x1080~60Hz
           2: 1920x1080~60Hz
           OpenGL: renderer: Mesa Intel HD Graphics 630 (KBL GT2) v: 4.6 Mesa 20.2.6 direct render: Yes
Network:   Device-1: Intel Ethernet I219-LM vendor: Dell driver: e1000e v: kernel port: f040 bus ID: 00:1f.6
           IF: enp0s31f6 state: up speed: 100 Mbps duplex: full mac: d4:81:d7:bc:94:0c
           Device-2: Qualcomm Atheros QCA6174 802.11ac Wireless Network Adapter vendor: Dell driver: ath10k_pci v: kernel
           port: e000 bus ID: 02:00.0
           IF: wlp2s0 state: down mac: 66:27:84:fe:ee:3e
           Device-3: Qualcomm Atheros type: USB driver: btusb bus ID: 1-6:3
Drives:    Local Storage: total: 1.03 TiB used: 78.36 GiB (7.5%)
Info:      Processes: 259 Uptime: 3m Memory: 31.25 GiB used: 2.18 GiB (7.0%) Init: systemd runlevel: 5 Compilers: gcc: 10.2.1
           Packages: 5435 Shell: Bash v: 5.1.0 inxi: 3.2.01

Code: [Select]
# journalctl -S today -p err
-- Journal begins at Sat 2020-10-24 09:09:15 EDT, ends at Thu 2020-12-24 08:49:12 EST. --
Dec 24 00:28:14 l5580 kernel: e1000e 0000:00:1f.6 0000:00:1f.6 (uninitialized): Failed to initialize MSI interrupts.  Falling back to legacy interrupts.
-- Boot 00e83ad4460f4f96b90969d5da75682f --
Dec 24 00:31:21 l5580 kernel: e1000e 0000:00:1f.6 0000:00:1f.6 (uninitialized): Failed to initialize MSI interrupts.  Falling back to legacy interrupts.
-- Boot faea1204b327427fa194bcc22b499e15 --
Dec 24 00:32:44 l5580 kernel: e1000e 0000:00:1f.6 0000:00:1f.6 (uninitialized): Failed to initialize MSI interrupts.  Falling back to legacy interrupts.
Dec 24 00:32:45 l5580 kernel: snd_hda_intel 0000:01:00.1: no codecs found!
Dec 24 00:32:45 l5580 bluetoothd[590]: profiles/sap/server.c:sap_server_register() Sap driver initialization failed.
Dec 24 00:32:45 l5580 bluetoothd[590]: sap-server: Operation not permitted (1)
Dec 24 00:32:49 l5580 avahi-daemon[589]: avahi_normalize_name() failed.
Dec 24 00:32:49 l5580 avahi-daemon[589]: avahi_key_new() failed.
Dec 24 00:32:50 l5580 avahi-daemon[589]: avahi_normalize_name() failed.
Dec 24 00:32:50 l5580 avahi-daemon[589]: avahi_key_new() failed.
Dec 24 00:32:50 l5580 avahi-daemon[589]: avahi_normalize_name() failed.
Dec 24 00:32:50 l5580 avahi-daemon[589]: avahi_key_new() failed.
-- Boot 7d43757eec2a45acbf8058caa237c264 --
Dec 24 00:44:57 l5580 kernel: e1000e 0000:00:1f.6 0000:00:1f.6 (uninitialized): Failed to initialize MSI interrupts.  Falling back to legacy interrupts.
Dec 24 00:44:58 l5580 kernel: snd_hda_intel 0000:01:00.1: no codecs found!
-- Boot 8f9639b3be6e41afaaec8dd7caa77ebe --
Dec 24 00:47:49 l5580 kernel: e1000e 0000:00:1f.6 0000:00:1f.6 (uninitialized): Failed to initialize MSI interrupts.  Falling back to legacy interrupts.
Dec 24 00:47:49 l5580 systemd-fsck[427]: Please pass 'fsck.mode=force' on the kernel command line rather than creating /forcefsck on the root file system.
Dec 24 00:47:49 l5580 kernel: snd_hda_intel 0000:01:00.1: no codecs found!
Dec 24 05:34:52 l5580 kernel: ath10k_pci 0000:02:00.0: firmware: failed to load ath10k/pre-cal-pci-0000:02:00.0.bin (-2)
Dec 24 05:34:52 l5580 kernel: firmware_class: See https://wiki.debian.org/Firmware for information about missing firmware
Dec 24 05:34:52 l5580 kernel: ath10k_pci 0000:02:00.0: firmware: failed to load ath10k/cal-pci-0000:02:00.0.bin (-2)
-- Boot 7d43757eec2a45acbf8058caa237c264 --
Dec 24 05:34:52 l5580 bluetoothd[561]: profiles/sap/server.c:sap_server_register() Sap driver initialization failed.
Dec 24 05:34:52 l5580 bluetoothd[561]: sap-server: Operation not permitted (1)
-- Boot 8f9639b3be6e41afaaec8dd7caa77ebe --
Dec 24 05:34:52 l5580 bluetoothd[563]: profiles/sap/server.c:sap_server_register() Sap driver initialization failed.
Dec 24 05:34:52 l5580 bluetoothd[563]: sap-server: Operation not permitted (1)
Dec 24 05:34:56 l5580 avahi-daemon[562]: avahi_normalize_name() failed.
Dec 24 05:34:56 l5580 avahi-daemon[562]: avahi_key_new() failed.
Dec 24 05:34:56 l5580 avahi-daemon[562]: avahi_normalize_name() failed.
Dec 24 05:34:56 l5580 avahi-daemon[562]: avahi_key_new() failed.
Dec 24 05:34:56 l5580 avahi-daemon[562]: avahi_normalize_name() failed.
Dec 24 05:34:56 l5580 avahi-daemon[562]: avahi_key_new() failed.
-- Boot faea1204b327427fa194bcc22b499e15 --
Dec 24 05:36:14 l5580 bluetoothd[50906]: profiles/sap/server.c:sap_server_register() Sap driver initialization failed.
Dec 24 05:36:14 l5580 bluetoothd[50906]: sap-server: Operation not permitted (1)
-- Boot 7d43757eec2a45acbf8058caa237c264 --
Dec 24 05:36:28 l5580 kernel: watchdog: watchdog0: watchdog did not stop!
-- Boot faea1204b327427fa194bcc22b499e15 --
Dec 24 05:37:40 l5580 sddm-helper[77280]: gkr-pam: unable to locate daemon control file
-- Boot 8ac819bdf51140b193ed59375f671239 --
Dec 24 05:50:51 l5580 kernel: e1000e 0000:00:1f.6 0000:00:1f.6 (uninitialized): Failed to initialize MSI interrupts.  Falling back to legacy interrupts.
-- Boot 2322a39eb8914d0faf3a5aa4a6a5a9c4 --
Dec 24 05:52:19 l5580 kernel: e1000e 0000:00:1f.6 0000:00:1f.6 (uninitialized): Failed to initialize MSI interrupts.  Falling back to legacy interrupts.
-- Boot bf6aa4e55385434895ac5895cd01b03f --
Dec 24 05:55:57 l5580 kernel: e1000e 0000:00:1f.6 0000:00:1f.6 (uninitialized): Failed to initialize MSI interrupts.  Falling back to legacy interrupts.
-- Boot 57aab0c7ee1d4e21b54fcec0170c5409 --
Dec 24 05:57:02 l5580 kernel: e1000e 0000:00:1f.6 0000:00:1f.6 (uninitialized): Failed to initialize MSI interrupts.  Falling back to legacy interrupts.
-- Boot 9c2f64ad2e2d4d5c9aac6bb49ab23186 --
Dec 24 05:58:05 l5580 kernel: e1000e 0000:00:1f.6 0000:00:1f.6 (uninitialized): Failed to initialize MSI interrupts.  Falling back to legacy interrupts.
-- Boot d216890aa0e844e0b3d8a8654425af54 --
Dec 24 05:58:59 l5580 kernel: e1000e 0000:00:1f.6 0000:00:1f.6 (uninitialized): Failed to initialize MSI interrupts.  Falling back to legacy interrupts.
-- Boot 7527aa853e4e4ef181be73bae3cf08d0 --
Dec 24 06:00:12 l5580 kernel: e1000e 0000:00:1f.6 0000:00:1f.6 (uninitialized): Failed to initialize MSI interrupts.  Falling back to legacy interrupts.
Dec 24 06:00:13 l5580 kernel: snd_hda_intel 0000:01:00.1: no codecs found!
Dec 24 06:00:14 l5580 bluetoothd[585]: profiles/sap/server.c:sap_server_register() Sap driver initialization failed.
Dec 24 06:00:14 l5580 bluetoothd[585]: sap-server: Operation not permitted (1)
Dec 24 06:00:17 l5580 avahi-daemon[583]: avahi_normalize_name() failed.
Dec 24 06:00:17 l5580 avahi-daemon[583]: avahi_key_new() failed.
Dec 24 06:00:18 l5580 avahi-daemon[583]: avahi_normalize_name() failed.
Dec 24 06:00:18 l5580 avahi-daemon[583]: avahi_key_new() failed.
Dec 24 06:00:18 l5580 avahi-daemon[583]: avahi_normalize_name() failed.
Dec 24 06:00:18 l5580 avahi-daemon[583]: avahi_key_new() failed.
-- Boot f0729d93b8f94ca693f2413972cc3344 --
Dec 24 06:02:44 l5580 kernel: e1000e 0000:00:1f.6 0000:00:1f.6 (uninitialized): Failed to initialize MSI interrupts.  Falling back to legacy interrupts.
-- Boot afa9aeb5738244dfa870a05eff35b911 --
Dec 24 06:03:43 l5580 kernel: e1000e 0000:00:1f.6 0000:00:1f.6 (uninitialized): Failed to initialize MSI interrupts.  Falling back to legacy interrupts.
Dec 24 06:03:44 l5580 kernel: snd_hda_intel 0000:01:00.1: no codecs found!
Dec 24 06:03:45 l5580 bluetoothd[582]: profiles/sap/server.c:sap_server_register() Sap driver initialization failed.
Dec 24 06:03:45 l5580 bluetoothd[582]: sap-server: Operation not permitted (1)
Dec 24 06:03:48 l5580 avahi-daemon[581]: avahi_normalize_name() failed.
Dec 24 06:03:48 l5580 avahi-daemon[581]: avahi_key_new() failed.
Dec 24 06:03:49 l5580 avahi-daemon[581]: avahi_normalize_name() failed.
Dec 24 06:03:49 l5580 avahi-daemon[581]: avahi_key_new() failed.
Dec 24 06:03:49 l5580 avahi-daemon[581]: avahi_normalize_name() failed.
Dec 24 06:03:49 l5580 avahi-daemon[581]: avahi_key_new() failed.
-- Boot 9fbb94ee87bf4d8eb9bca0ea3cc5397e --
Dec 24 06:08:06 l5580 kernel: e1000e 0000:00:1f.6 0000:00:1f.6 (uninitialized): Failed to initialize MSI interrupts.  Falling back to legacy interrupts.
Dec 24 06:08:06 l5580 kernel: snd_hda_intel 0000:01:00.1: no codecs found!
Dec 24 06:08:07 l5580 bluetoothd[592]: profiles/sap/server.c:sap_server_register() Sap driver initialization failed.
Dec 24 06:08:07 l5580 bluetoothd[592]: sap-server: Operation not permitted (1)
Dec 24 06:08:11 l5580 avahi-daemon[591]: avahi_normalize_name() failed.
Dec 24 06:08:11 l5580 avahi-daemon[591]: avahi_key_new() failed.
Dec 24 06:08:11 l5580 avahi-daemon[591]: avahi_normalize_name() failed.
Dec 24 06:08:11 l5580 avahi-daemon[591]: avahi_key_new() failed.
Dec 24 06:08:11 l5580 avahi-daemon[591]: avahi_normalize_name() failed.
Dec 24 06:08:11 l5580 avahi-daemon[591]: avahi_key_new() failed.
Dec 24 06:10:45 l5580 sddm-helper[38755]: gkr-pam: unable to locate daemon control file
Dec 24 06:12:41 l5580 systemd[47647]: Failed to start Sound Service.
Dec 24 06:12:58 l5580 systemd[47647]: Failed to start KDE Global Shortcuts Server.
Dec 24 06:12:58 l5580 systemd[47647]: Failed to start KDE Global Shortcuts Server.
Dec 24 06:12:59 l5580 systemd[47647]: Failed to start KDE Global Shortcuts Server.
Dec 24 06:12:59 l5580 systemd[47647]: Failed to start KDE Global Shortcuts Server.
Dec 24 06:12:59 l5580 systemd[47647]: Failed to start KDE Global Shortcuts Server.
Dec 24 06:12:59 l5580 systemd[47647]: Failed to start KDE Global Shortcuts Server.
-- Boot 5991f365e49949589696c0f4c410d1ec --
Dec 24 08:43:10 l5580 kernel: e1000e 0000:00:1f.6 0000:00:1f.6 (uninitialized): Failed to initialize MSI interrupts.  Falling back to legacy interrupts.
-- Boot 88fef90cf88b4545922874e7d77ead44 --
Dec 24 08:45:26 l5580 kernel: e1000e 0000:00:1f.6 0000:00:1f.6 (uninitialized): Failed to initialize MSI interrupts.  Falling back to legacy interrupts.
Dec 24 08:45:27 l5580 kernel: snd_hda_intel 0000:01:00.1: no codecs found!
Dec 24 08:45:28 l5580 bluetoothd[591]: profiles/sap/server.c:sap_server_register() Sap driver initialization failed.
Dec 24 08:45:28 l5580 bluetoothd[591]: sap-server: Operation not permitted (1)
Dec 24 08:45:32 l5580 avahi-daemon[590]: avahi_normalize_name() failed.
Dec 24 08:45:32 l5580 avahi-daemon[590]: avahi_key_new() failed.
Dec 24 08:45:32 l5580 avahi-daemon[590]: avahi_normalize_name() failed.
Dec 24 08:45:32 l5580 avahi-daemon[590]: avahi_key_new() failed.
Dec 24 08:45:32 l5580 avahi-daemon[590]: avahi_normalize_name() failed.
Dec 24 08:45:32 l5580 avahi-daemon[590]: avahi_key_new() failed.
Dec 24 08:45:45 l5580 sddm-helper[6357]: gkr-pam: unable to locate daemon control file

Please let me know if I can provide any more relevant info.

Offline hendrikL

  • User
  • Posts: 470
Re: Plasma 5.20 Hangs
« Reply #2 on: 2020/12/24, 15:02:46 »
How long did you wait?

After updating I had to wait at the first login for some minutes till the desktop appears.
Now all is okay and the login is fast, normal as before.

Offline finotti

  • User
  • Posts: 181
Re: Plasma 5.20 Hangs
« Reply #3 on: 2020/12/24, 15:58:53 »
Thanks for the reply!

Yes, I tried waiting...  After a long while the splash screen disappears and I get a black screen with the mouse pointer, but no desktop and no command works.

Trying to switch to a VT I get a blank screen with no login option.  Now after waiting a while in the blank screen VT, I started getting the errors shown in the picture here: http://www.math.utk.edu/~finotti/error.jpg


Googling the error I found this: https://askubuntu.com/questions/905710/ext4-fs-error-after-ubuntu-17-04-upgrade  But the suggested kernel parameter change did not help.

I can use fluxbox for a while with no disk error, so it seems that plasma is triggering it.

Any suggestion would be greatly appreciated.

Offline finotti

  • User
  • Posts: 181
Re: Plasma 5.20 Hangs
« Reply #4 on: 2020/12/24, 16:56:00 »
I could capture a couple more sets of errors:

http://www.math.utk.edu/~finotti/error2.jpg
http://www.math.utk.edu/~finotti/error3.jpg

Again, despite the fact that it seems it is a disk problem, I can work without problem with fluxbox (and LXQt, which I just installed) and in Windows.  fsck also shows no errors.

Offline dibl

  • siduction community member
  • Global Moderator
  • User
  • *****
  • Posts: 2.070
    • Land of the Buckeye
Re: Plasma 5.20 Hangs
« Reply #5 on: 2020/12/24, 20:41:54 »
@finotti, on the "hangs on splash", check my post under the Updates forum.
Asus ROG STRIX X299-E, Core i7-7740X, Nvidia GTX-1060, dual monitors, SSD 860 EVO, 2@WD1003FZEX in BTRFS

Offline finotti

  • User
  • Posts: 181
Re: Plasma 5.20 Hangs
« Reply #6 on: 2020/12/24, 23:41:13 »
Thanks for the reply, dibl!

I had seen your post before, but I never used the preining repo's, so I assumed it was a different problem.  I will double check the library versions (when I can hog the laptop again), but it is unlikely that that is the problem.

Offline dibl

  • siduction community member
  • Global Moderator
  • User
  • *****
  • Posts: 2.070
    • Land of the Buckeye
Re: Plasma 5.20 Hangs
« Reply #7 on: 2020/12/25, 00:39:28 »
Check your libkwaylandserver5 package version.
Asus ROG STRIX X299-E, Core i7-7740X, Nvidia GTX-1060, dual monitors, SSD 860 EVO, 2@WD1003FZEX in BTRFS

Offline finotti

  • User
  • Posts: 181
Re: Plasma 5.20 Hangs
« Reply #8 on: 2020/12/25, 13:46:08 »
Check your libkwaylandserver5 package version.

It seems to be the correct one...

Code: [Select]
# apt policy libkwaylandserver5
libkwaylandserver5:
  Installed: 5.20.4-2
  Candidate: 5.20.4-2
  Version table:
 *** 5.20.4-2 500
        500 http://httpredir.debian.org/debian unstable/main amd64 Packages
        100 /var/lib/dpkg/status

If it helps here is the .xsession-errors file:
Code: [Select]
Xsession: X session started for test2 at Thu 24 Dec 2020 10:06:43 AM EST
WARNING: tempfile is deprecated; consider using mktemp instead.
dbus-update-activation-environment: setting DBUS_SESSION_BUS_ADDRESS=unix:path=/run/user/1002/bus
dbus-update-activation-environment: setting DISPLAY=:0
dbus-update-activation-environment: setting XAUTHORITY=/home/test2/.Xauthority
localuser:test2 being added to access control list
dbus-update-activation-environment: setting GTK_MODULES=gail:atk-bridge
dbus-update-activation-environment: setting QT_ACCESSIBILITY=1
dbus-update-activation-environment: setting SHELL=/bin/bash
dbus-update-activation-environment: setting QT_ACCESSIBILITY=1
dbus-update-activation-environment: setting KMIX_PULSEAUDIO_DISABLE=1
dbus-update-activation-environment: setting XDG_CONFIG_DIRS=/usr/share/kxstudio/menu:/etc/xdg
dbus-update-activation-environment: setting XDG_SESSION_PATH=/org/freedesktop/DisplayManager/Session3
dbus-update-activation-environment: setting GTK_IM_MODULE=ibus
dbus-update-activation-environment: setting LC_ADDRESS=en_US.UTF-8
dbus-update-activation-environment: setting LC_NAME=en_US.UTF-8
dbus-update-activation-environment: setting HISTTIMEFORMAT=%d/%m/%y %T
dbus-update-activation-environment: setting XMODIFIERS=@im=ibus
dbus-update-activation-environment: setting DESKTOP_SESSION=lxqt
dbus-update-activation-environment: setting LC_MONETARY=en_US.UTF-8
dbus-update-activation-environment: setting GTK_MODULES=gail:atk-bridge
dbus-update-activation-environment: setting PWD=/home/test2
dbus-update-activation-environment: setting XDG_SESSION_DESKTOP=
dbus-update-activation-environment: setting LOGNAME=test2
dbus-update-activation-environment: setting XDG_SESSION_TYPE=x11
dbus-update-activation-environment: setting DSSI_PATH=/home/test2/.dssi:/usr/lib/dssi:/usr/local/lib/dssi
dbus-update-activation-environment: setting GPG_AGENT_INFO=/run/user/1002/gnupg/S.gpg-agent:0:1
dbus-update-activation-environment: setting XAUTHORITY=/home/test2/.Xauthority
dbus-update-activation-environment: setting HOME=/home/test2
dbus-update-activation-environment: setting IM_CONFIG_PHASE=1
dbus-update-activation-environment: setting LC_PAPER=en_US.UTF-8
dbus-update-activation-environment: setting LANG=en_US.UTF-8
dbus-update-activation-environment: setting VST_PATH=/home/test2/.vst:/usr/lib/vst:/usr/local/lib/vst
dbus-update-activation-environment: setting LS_COLORS=
dbus-update-activation-environment: setting XDG_CURRENT_DESKTOP=
dbus-update-activation-environment: setting SUIL_MODULE_DIR=/opt/kxstudio/lib/suil-0
dbus-update-activation-environment: setting XDG_SEAT_PATH=/org/freedesktop/DisplayManager/Seat0
dbus-update-activation-environment: setting CLUTTER_IM_MODULE=ibus
dbus-update-activation-environment: setting XDG_SESSION_CLASS=user
dbus-update-activation-environment: setting LC_IDENTIFICATION=en_US.UTF-8
dbus-update-activation-environment: setting USER=test2
dbus-update-activation-environment: setting PAM_KWALLET5_LOGIN=/run/user/1002/kwallet5.socket
dbus-update-activation-environment: setting DISPLAY=:0
dbus-update-activation-environment: setting SHLVL=1
dbus-update-activation-environment: setting LC_TELEPHONE=en_US.UTF-8
dbus-update-activation-environment: setting QT_IM_MODULE=ibus
dbus-update-activation-environment: setting SYSTEMD_PAGER=less
dbus-update-activation-environment: setting LC_MEASUREMENT=en_US.UTF-8
dbus-update-activation-environment: setting XDG_RUNTIME_DIR=/run/user/1002
dbus-update-activation-environment: setting LC_TIME=en_US.UTF-8
dbus-update-activation-environment: setting GCC_COLORS=error=01;31:warning=01;35:note=01;36:caret=01;32:locus=01:quote=01
dbus-update-activation-environment: setting PATH=/usr/local/bin:/usr/bin:/bin:/usr/local/games:/usr/games
dbus-update-activation-environment: setting DBUS_SESSION_BUS_ADDRESS=unix:path=/run/user/1002/bus
dbus-update-activation-environment: setting LV2_PATH=/home/test2/.lv2:/usr/lib/lv2:/usr/local/lib/lv2
dbus-update-activation-environment: setting LC_NUMERIC=en_US.UTF-8
dbus-update-activation-environment: setting LADSPA_PATH=/home/test2/.ladspa:/usr/lib/ladspa:/usr/local/lib/ladspa
dbus-update-activation-environment: setting CADENCE_AUTO_STARTED=true
dbus-update-activation-environment: setting _=/usr/bin/dbus-update-activation-environment
PulseAudio is already running, bridge it...
Done
JACK Started Successfully
[: 1: Syntax error: Unterminated quoted string
Xlib XKB extension major= 1  minor= 0
X server XKB extension major= 1  minor= 0
/usr/bin/xbindkeys_autostart: line 24: CONF: unbound variable
(0x7fff3c610550) Debug: New PolkitAgentListener  0x5638f1ccc620
(0x7fff3c610550) Debug: Adding new listener  PolkitQt1::Agent::Listener(0x7fff3c610560) for  0x5638f1ccc620
(0x7ffdd9603490) Warning: "Section \"mainmenu\" not found in /home/test2/.config/lxqt/panel.conf."
(0x7ffdd9603490) Warning: "Section \"showdesktop\" not found in /home/test2/.config/lxqt/panel.conf."
(0x7ffdd9603490) Warning: "Section \"desktopswitch\" not found in /home/test2/.config/lxqt/panel.conf."
isPrimaryInstance
(0x7ffdd9603490) Warning: "Section \"taskbar\" not found in /home/test2/.config/lxqt/panel.conf."
no cached wallpaper. generate a new one!
[Notice] Started
size of original image QSize(1920, 1080)
(0x7ffdd9603490) Warning: "Section \"tray\" not found in /home/test2/.config/lxqt/panel.conf."
(0x7ffdd9603490) Warning: "Section \"statusnotifier\" not found in /home/test2/.config/lxqt/panel.conf."
(0x7ffdd9603490) Warning: "Section \"mount\" not found in /home/test2/.config/lxqt/panel.conf."
(0x7ffdd9603490) Warning: "Section \"volume\" not found in /home/test2/.config/lxqt/panel.conf."
(0x7ffdd9603490) Warning: "Section \"worldclock\" not found in /home/test2/.config/lxqt/panel.conf."
(0x7ffdd9603490) Debug: WinIdChange 1600006 handle QWidgetWindow(0x56101edb18e0, name="LXQtPanel panel1Window") QScreen(0x56101eacd0f0, name="eDP-1")
(0x7ffcd55c0c90) Debug: systemd: "CanHibernate" = "yes"
(0x7ffcd55c0c90) Debug: systemd: "CanSuspend" = "yes"
(0x7fffdd596e40) Debug: systemd: "CanReboot" = "yes"
(0x7fffdd596e40) Debug: systemd: "CanPowerOff" = "yes"
[Notice] X11 error: type: 0, serial: 27, error_code: 10 'BadAccess (attempt to access private resource denied)', request_code: 33 (GrabKey), minor_code: 0, resourceid: 1978
[Notice] X11 error: type: 0, serial: 29, error_code: 10 'BadAccess (attempt to access private resource denied)', request_code: 33 (GrabKey), minor_code: 0, resourceid: 1978
[Notice] X11 error: type: 0, serial: 31, error_code: 10 'BadAccess (attempt to access private resource denied)', request_code: 33 (GrabKey), minor_code: 0, resourceid: 1978
[Notice] X11 error: type: 0, serial: 33, error_code: 10 'BadAccess (attempt to access private resource denied)', request_code: 33 (GrabKey), minor_code: 0, resourceid: 1978
[Warning] Cannot grab shortcut 'Alt+F2'
[Notice] X11 error: type: 0, serial: 39, error_code: 10 'BadAccess (attempt to access private resource denied)', request_code: 33 (GrabKey), minor_code: 0, resourceid: 1978
[Notice] X11 error: type: 0, serial: 41, error_code: 10 'BadAccess (attempt to access private resource denied)', request_code: 33 (GrabKey), minor_code: 0, resourceid: 1978
[Notice] X11 error: type: 0, serial: 43, error_code: 10 'BadAccess (attempt to access private resource denied)', request_code: 33 (GrabKey), minor_code: 0, resourceid: 1978
[Notice] X11 error: type: 0, serial: 45, error_code: 10 'BadAccess (attempt to access private resource denied)', request_code: 33 (GrabKey), minor_code: 0, resourceid: 1978
[Warning] Cannot grab shortcut 'Alt+F2'
wallpaper cached saved to  "/home/test2/.cache/pcmanfm-qt/lxqt/wallpaper.cache"
operation finished: 0x0
delete MountOperation
(0x7ffdd9603490) Debug: execAction "/usr/share/applications/qterminal.desktop"
QDir::exists: Empty or null file name
QDir::exists: Empty or null file name
(0x7ffdd9603490) Debug: execAction "/usr/share/applications/lxqt-leave.desktop"
(0x7fffdd596e40) Debug: systemd: "CanPowerOff" = "yes"
(0x7fffb3795b10) Debug: systemd: "CanSuspend" = "yes"
(0x7fffdd596e40) Debug: systemd: "CanReboot" = "yes"
(0x7fffb3795b10) Debug: systemd: "CanHibernate" = "yes"
(0x7ffdd9603490) Debug: execAction "/usr/share/applications/pcmanfm-qt.desktop"
(0x7ffdd9603490) Debug: execAction "/usr/share/applications/qterminal.desktop"
QDir::exists: Empty or null file name
QDir::exists: Empty or null file name
(0x7ffdd9603490) Debug: execAction "/usr/share/applications/featherpad.desktop"
Translator is not loaded "qlipper_en_US" "/usr/share/qlipper/translations"
(0x7fff048fa550) Debug: BatteryChanged discharging: false chargeLevel: 100 actionTime: QTime(Invalid)
(0x7fff048fa550) Debug: Inhibit got: 28
(0x7fff048fa550) Debug: Starting idlenesswatcher
(0x7fff048fa550) Debug: action invoked: "0"
(0x7ffdd9603490) Debug: ()
(0x7ffdd9603490) Debug: Systray started
[/code]
« Last Edit: 2020/12/25, 13:59:50 by finotti »

Offline hendrikL

  • User
  • Posts: 470
Re: Plasma 5.20 Hangs
« Reply #9 on: 2020/12/25, 16:55:15 »
event calendar installed? if so, please update it.
or, test with a test user to open a plasma session.

Offline finotti

  • User
  • Posts: 181
Re: Plasma 5.20 Hangs
« Reply #10 on: 2020/12/25, 17:05:49 »
event calendar installed? if so, please update it.
or, test with a test user to open a plasma session.

Thanks for the reply!

I am not sure which package is "event calendar", but the system is up to date.  I also tried plasma with a fresh new user, and had the same problem....

Offline dibl

  • siduction community member
  • Global Moderator
  • User
  • *****
  • Posts: 2.070
    • Land of the Buckeye
Re: Plasma 5.20 Hangs
« Reply #11 on: 2020/12/25, 18:57:36 »
Is there plenty of free space available on the disk partition where /home is located?
Asus ROG STRIX X299-E, Core i7-7740X, Nvidia GTX-1060, dual monitors, SSD 860 EVO, 2@WD1003FZEX in BTRFS

Offline devil

  • Administrator
  • User
  • *****
  • Posts: 4.481
Re: Plasma 5.20 Hangs
« Reply #12 on: 2020/12/26, 08:10:04 »
Have you also looked at journalctl or dmesg for clues besides KDE?

Offline finotti

  • User
  • Posts: 181
Re: Plasma 5.20 Hangs
« Reply #13 on: 2020/12/26, 15:03:47 »
Thanks dibl and devil for the replies!

@dibl: I do have plenty of space available:

Code: [Select]
$ df -h
Filesystem      Size  Used Avail Use% Mounted on
udev             16G     0   16G   0% /dev
tmpfs           3.2G  1.8M  3.2G   1% /run
/dev/nvme0n1p2  140G   80G   53G  60% /
tmpfs            16G     0   16G   0% /dev/shm
tmpfs           5.0M  4.0K  5.0M   1% /run/lock
tmpfs            16G   76K   16G   1% /tmp
/dev/nvme0n1p1  649M   46M  604M   7% /boot/efi
tmpfs           3.2G  128K  3.2G   1% /run/user/1000

@devil: I have the result of journalct in my second post.  I did not see anything relevant.

I found a new way to reproduce the problem: running 'smartctl -l error /dev/nvme0n1'.

The current SSD is this one: https://www.crucial.com/ssd/p5/ct1000p5ssd8.  I have SMART enabled in the BIOS.

The following should (I believe) show enabled:
Code: [Select]
l5580[/home/finotti]# smartctl --info /dev/nvme0n1 | grep 'SMART support is:'
l5580[/home/finotti]# smartctl --info /dev/nvme0n1
smartctl 7.1 2019-12-30 r5022 [x86_64-linux-5.9.15-towo.1-siduction-amd64] (local build)
Copyright (C) 2002-19, Bruce Allen, Christian Franke, www.smartmontools.org

=== START OF INFORMATION SECTION ===
Model Number:                       CT1000P5SSD8
Serial Number:                      20352A46878A
Firmware Version:                   P4CR311
PCI Vendor/Subsystem ID:            0x1344
IEEE OUI Identifier:                0x00a075
Controller ID:                      0
Number of Namespaces:               1
Namespace 1 Size/Capacity:          1,000,204,886,016 [1.00 TB]
Namespace 1 Formatted LBA Size:     512
Namespace 1 IEEE EUI-64:            00a075 012a46878a
Local Time is:                      Sat Dec 26 08:46:10 2020 EST


Since it doesn't, I tried to enable it, but it still does not show:
Code: [Select]
l5580[/home/finotti]# smartctl --smart=on /dev/nvme0n1
smartctl 7.1 2019-12-30 r5022 [x86_64-linux-5.9.15-towo.1-siduction-amd64] (local build)
Copyright (C) 2002-19, Bruce Allen, Christian Franke, www.smartmontools.org

NVMe device successfully opened

Use 'smartctl -a' (or '-x') to print SMART (and more) information

l5580[/home/finotti]# smartctl --info /dev/nvme0n1 | grep 'SMART support is:'


I tried doing a short test:
Code: [Select]
l5580[/home/finotti]# smartctl -c /dev/nvme0n1
smartctl 7.1 2019-12-30 r5022 [x86_64-linux-5.9.15-towo.1-siduction-amd64] (local build)
Copyright (C) 2002-19, Bruce Allen, Christian Franke, www.smartmontools.org

=== START OF INFORMATION SECTION ===
Firmware Updates (0x14):            2 Slots, no Reset required
Optional Admin Commands (0x0017):   Security Format Frmw_DL Self_Test
Optional NVM Commands (0x0057):     Comp Wr_Unc DS_Mngmt Sav/Sel_Feat Timestmp
Maximum Data Transfer Size:         512 Pages
Warning  Comp. Temp. Threshold:     78 Celsius
Critical Comp. Temp. Threshold:     81 Celsius
Namespace 1 Features (0x08):        No_ID_Reuse

Supported Power States
St Op     Max   Active     Idle   RL RT WL WT  Ent_Lat  Ex_Lat
 0 +     8.25W       -        -    0  0  0  0        0       0
 1 +     3.00W       -        -    1  1  1  1        0       0
 2 +     1.90W       -        -    2  2  2  2        0       0
 3 -   0.0800W       -        -    3  3  3  3    10000    2500
 4 -   0.0050W       -        -    4  4  4  4    12000   35000

Supported LBA Sizes (NSID 0x1)
Id Fmt  Data  Metadt  Rel_Perf
 0 +     512       0         0

l5580[/home/finotti]# smartctl -t short /dev/nvme0n1
smartctl 7.1 2019-12-30 r5022 [x86_64-linux-5.9.15-towo.1-siduction-amd64] (local build)
Copyright (C) 2002-19, Bruce Allen, Christian Franke, www.smartmontools.org

NVMe device successfully opened

Use 'smartctl -a' (or '-x') to print SMART (and more) information

l5580[/home/finotti]# smartctl -H /dev/nvme0n1
smartctl 7.1 2019-12-30 r5022 [x86_64-linux-5.9.15-towo.1-siduction-amd64] (local build)
Copyright (C) 2002-19, Bruce Allen, Christian Franke, www.smartmontools.org

=== START OF SMART DATA SECTION ===
SMART overall-health self-assessment test result: PASSED

l5580[/home/finotti]# smartctl -H /dev/nvme0n1
smartctl 7.1 2019-12-30 r5022 [x86_64-linux-5.9.15-towo.1-siduction-amd64] (local build)
Copyright (C) 2002-19, Bruce Allen, Christian Franke, www.smartmontools.org

=== START OF SMART DATA SECTION ===
SMART overall-health self-assessment test result: PASSED

But again, asking for the error log freezes the system just like starting KDE.

I can work, without problems, using flexbox, with no disk errors.

I am not sure if SMART is working or not, since there seems to be conflicting info...   (It does not show enabled, but some commands run fine.)  I will try to do a long test later..

Offline devil

  • Administrator
  • User
  • *****
  • Posts: 4.481
Re: Plasma 5.20 Hangs
« Reply #14 on: 2020/12/26, 19:25:56 »
The use of smartmontools with NVMe is still experimental: https://www.smartmontools.org/wiki/NVMe_Support
« Last Edit: 2020/12/27, 10:05:31 by devil »