seduction
 Language:
Welcome, Guest. Please login or register.
Did you miss your activation email?
2021/04/18, 10:06:30


Help

Author [EN] [PL] [ES] [PT] [IT] [DE] [FR] [NL] [TR] [SR] [AR] [RU] Topic: apt sagt Pakete werden nicht mehr benötigt  (Read 178 times)

0 Members and 1 Guest are viewing this topic.

Offline NochEinNeuer

  • User
  • Posts: 153
apt sagt Pakete werden nicht mehr benötigt
« on: 2021/02/28, 05:48:35 »
Hallo,
seit einiger Zeit sagt mir apt das etliche Pakete nicht mehr benötigt würden:
Code: [Select]
Paketaktualisierung (Upgrade) wird berechnet… Fertig
Die folgenden Pakete wurden automatisch installiert und werden nicht mehr benötigt:
  libaopalliance-java libapache-poi-java libargs4j-java
  libatinject-jsr330-api-java libcdi-api-java libcodemodel-java
  libcommons-cli-java libcommons-codec-java libcommons-collections4-java
  libcommons-compress-java libcommons-io-java libcommons-lang3-java
  libcommons-math3-java libcurvesapi-java libdom4j-java libdtd-parser-java
  libfastinfoset-java libgeronimo-annotation-1.3-spec-java
  libgeronimo-interceptor-3.0-spec-java libguava-java libguice-java
  libhawtjni-runtime-java libhttpclient-java libhttpcore-java libicu4j-java
  libintellij-annotations-java libistack-commons-java libjansi-java
  libjansi-native-java libjaxb-api-java libjaxb-java libjaxen-java
  libjdom1-java libjetbrains-annotations-java libjsoup-java libjsr305-java
  libmaven-file-management-java libmaven-parent-java libmaven-resolver-java
  libmaven-shared-io-java libmaven-shared-utils-java libmaven3-core-java
  libplexus-archiver-java libplexus-cipher-java libplexus-classworlds-java
  libplexus-component-annotations-java libplexus-interpolation-java
  libplexus-io-java libplexus-sec-dispatcher-java libplexus-utils2-java
  libqqwing2v5 libreadline5 librelaxng-datatype-java librngom-java
  libsaxonhe-java libsisu-inject-java libsisu-plexus-java libslf4j-java
  libsnappy-java libsnappy-jni libstax-ex-java libstreambuffer-java
  libtxw2-java libwagon-http-java libwagon-provider-api-java libxerces2-java
  libxml-commons-external-java libxmlbeans-java libxom-java libxsom-java
  usbutils
Verwenden Sie »apt autoremove«, um sie zu entfernen.
Mir sagen diese ganzen Pakete auf anhieb nichts. Das einzige was ich vielleicht noch brauchen könnte wäre usbutils.
Kann ich die ganzen Pakete mit guten gewissen entfernen?
Vielen Dank für Eure Hilfe,Jürgen

Offline axt

  • User
  • Posts: 475
    • axebase.net
Re: apt sagt Pakete werden nicht mehr benötigt
« Reply #1 on: 2021/02/28, 09:13:15 »
Quote from: NochEinNeuer
Mir sagen diese ganzen Pakete auf anhieb nichts.
Es ist aber nicht so, daß Du das nicht herausfinden könntest.

Greifen wir mal ein Paket heraus, z.B. libreadline5 und suchen nach libreadline. Da stellen wir fest, für sid gibt es längst libreadline8 und libreadline5 eben nicht mehr. Ergo kann und sollte das mit seinen Abhängigkeiten weg.

Dann werden etliche spezielle java-Pakete gelistet. Das oder die Pakete, die Du mal installiert gehabt hast und die diese Pakete gebraucht haben, sind offenbar nicht mehr installiert. Also können diese auch 'runter.

Wenn Du unsicher bist, speichere diese Liste als ASCII, so kannst Du notfalls daraus wieder installieren!

Wenn Du meinst, einzelne Pakete doch brauchen zu müssen wie Dein Beispiel usbutils, installierst Du sie wieder.

Und eines ist Fakt: je länger Du Aufräumen hinauszögerst, desto unübersichtlicher und schwieriger wird es für Dich.
« Last Edit: 2021/02/28, 09:16:52 by axt »