seduction
 Language:
Welcome, Guest. Please login or register.
Did you miss your activation email?
2021/04/18, 11:01:53


Help

Author [EN] [PL] [ES] [PT] [IT] [DE] [FR] [NL] [TR] [SR] [AR] [RU] Topic: Boot problem with kernel 5.11.4  (Read 795 times)

0 Members and 1 Guest are viewing this topic.

Offline mdmarmer

  • User
  • Posts: 29
Boot problem with kernel 5.11.4
« on: 2021/03/09, 02:32:43 »
My system won't boot with 5.11.4 kernel, so I'm using 5.10.20
Here are some of the boot messages that appear:
failed to start port 0 (errno=-12)can't setup: -12init fail, -12irq 9: nobody cared (try booting with the "irqpoll" option)handlers:acpi_irqGave up waiting for root file system device. Common problems:boot args, check rootdelay =Alert UUID= does not exist. Dropping to a shell!
Attached is the output of inxi -Fxxx





Offline Pip

  • User
  • Posts: 91
Re: Boot problem with kernel 5.11.4
« Reply #1 on: 2021/03/09, 09:27:12 »
Do you have any build errors from the kernel installation? I get -

Code: [Select]
Error! Bad return status for module build on kernel: 5.11.4-towo.2-siduction-amd64 (x86_64)

for virtualbox and rtl8812au.

I can boot with the kernel, but my wi-fi is gone (unsurprisingly)

Offline dibl

  • siduction community member
  • Global Moderator
  • User
  • *****
  • Posts: 2.090
    • Land of the Buckeye
Re: Boot problem with kernel 5.11.4
« Reply #2 on: 2021/03/09, 12:43:20 »
All good here.
Code: [Select]
System:    Kernel: 5.11.4-towo.2-siduction-amd64 x86_64 bits: 64 Desktop: KDE Plasma 5.20.5
           Distro: siduction 18.3.0 Patience - kde - (201805132121)
Machine:   Type: Laptop System: Hewlett-Packard product: HP 350 G1 v: 0992100000400010000634101 serial: <filter>
           Mobo: Hewlett-Packard model: 21B7 v: KBC Version 46.0B serial: <filter> UEFI: Insyde v: F.12 date: 06/12/2014
Battery:   ID-1: BAT0 charge: 25.9 Wh condition: 28.1/28.1 Wh (100%)
CPU:       Info: Dual Core model: Intel Core i5-4210U bits: 64 type: MT MCP L2 cache: 3 MiB
           Speed: 943 MHz min/max: 800/2700 MHz Core speeds (MHz): 1: 943 2: 1399 3: 947 4: 993
Graphics:  Device-1: Intel Haswell-ULT Integrated Graphics driver: i915 v: kernel
           Device-2: Cheng Uei Precision Industry (Foxlink) Webcam type: USB driver: uvcvideo
           Display: x11 server: X.Org 1.20.10 driver: loaded: modesetting unloaded: fbdev,vesa resolution: 1366x768~60Hz
           OpenGL: renderer: Mesa DRI Intel HD Graphics 4400 (HSW GT2) v: 4.5 Mesa 20.3.4
Audio:     Device-1: Intel Haswell-ULT HD Audio driver: snd_hda_intel
           Device-2: Intel 8 Series HD Audio driver: snd_hda_intel
           Sound Server: ALSA v: k5.11.4-towo.2-siduction-amd64
Network:   Device-1: Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet driver: r8169
           IF: eno1 state: down mac: <filter>
           Device-2: Ralink RT3290 Wireless 802.11n 1T/1R PCIe driver: rt2800pci
           IF: wlo1 state: up mac: <filter>
Bluetooth: Device-1: Ralink RT3290 Bluetooth driver: N/A
Drives:    Local Storage: total: 465.76 GiB used: 11.04 GiB (2.4%)
           ID-1: /dev/sda vendor: Samsung model: SSD 840 EVO 500GB size: 465.76 GiB
Partition: ID-1: / size: 18.69 GiB used: 10.97 GiB (58.7%) fs: ext4 dev: /dev/sda2
           ID-2: /boot/efi size: 299.4 MiB used: 256 KiB (0.1%) fs: vfat dev: /dev/sda1
Swap:      ID-1: swap-1 type: partition size: 2 GiB used: 0 KiB (0.0%) dev: /dev/sda3
Sensors:   System Temperatures: cpu: 35.0 C mobo: 0.0 C
           Fan Speeds (RPM): N/A
Info:      Processes: 197 Uptime: 7m Memory: 3.76 GiB used: 1.85 GiB (49.1%) Shell: Bash inxi: 3.3.01
Asus ROG STRIX X299-E, Core i7-7740X, Nvidia GTX-1060, dual monitors, SSD 860 EVO, 2@WD2003FZEX in BTRFS

Offline mdmarmer

  • User
  • Posts: 29
Re: Boot problem with kernel 5.11.4
« Reply #3 on: 2021/03/09, 16:33:37 »
No build errors.  And the same kernel boots with no problem on a desktop system.  I have another laptop that is quite old. I may try on that one.

Offline towo

  • Global Moderator
  • User
  • *****
  • Posts: 2.455
Re: Boot problem with kernel 5.11.4
« Reply #4 on: 2021/03/09, 20:26:44 »
With no offence, your thread is useless. If you have a problem with the kernel, the minimum would be to provide the hardware info from that system. Me and no other people here have a crystalball, where we can look, what could be the problem.
Ich gehe nicht zum Karneval, ich verleihe nur manchmal mein Gesicht.

Offline Pip

  • User
  • Posts: 91
Re: Boot problem with kernel 5.11.4
« Reply #5 on: 2021/03/09, 20:39:21 »
Sorry, towo, I'm the only one who didn't provide such so I presume that's for me, though it's not my thread.
Code: [Select]
System:    Host: DesktopSiduction Kernel: 5.10.20-towo.1-siduction-amd64 x86_64 bits: 64 Desktop: KDE Plasma 5.20.5 
           Distro: siduction 18.1.0 Patience - kde - (201712310029) 
Machine:   Type: Desktop Mobo: ASUSTeK model: H170-PRO v: Rev X.0x serial: <superuser required> 
           UEFI: American Megatrends v: 3401 date: 03/16/2017 
CPU:       Info: Quad Core model: Intel Core i7-6700 bits: 64 type: MT MCP L2 cache: 8 MiB 
           Speed: 3700 MHz min/max: 800/4000 MHz Core speeds (MHz): 1: 3700 2: 3700 3: 3700 4: 3700 5: 3700 6: 3700 
           7: 3700 8: 3700 
Graphics:  Device-1: NVIDIA GK104 [GeForce GTX 770] driver: nvidia v: 460.56 
           Display: x11 server: X.Org 1.20.10 driver: loaded: nvidia unloaded: fbdev,modesetting,nouveau,vesa 
           resolution: 3840x2160~60Hz 
           OpenGL: renderer: GeForce GTX 770/PCIe/SSE2 v: 4.6.0 NVIDIA 460.56 
Audio:     Device-1: Intel 100 Series/C230 Series Family HD Audio driver: snd_hda_intel 
           Device-2: NVIDIA GK104 HDMI Audio driver: snd_hda_intel 
           Device-3: Realtek FULL HD 1080P Webcam type: USB driver: snd-usb-audio,uvcvideo 
           Sound Server: ALSA v: k5.10.20-towo.1-siduction-amd64 
Network:   Device-1: Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet driver: r8169 
           IF: enp4s0 state: down mac: 2c:4d:54:56:05:8d 
           Device-2: Realtek RTL8812AU 802.11a/b/g/n/ac 2T2R DB WLAN Adapter type: USB driver: rtl8812au 
           IF: wlx048d38d6bb03 state: up mac: 04:8d:38:d6:bb:03 
Drives:    Local Storage: total: 5.72 TiB used: 3.92 TiB (68.5%) 
           ID-1: /dev/nvme0n1 vendor: Toshiba model: N/A size: 238.47 GiB 
           ID-2: /dev/sda vendor: Patriot model: Torqx TRB 32GB SSD size: 28.13 GiB 
           ID-3: /dev/sdb vendor: Seagate model: ST4000LM016-1N2170 size: 3.64 TiB 
           ID-4: /dev/sdc vendor: Seagate model: ST2000LM003 HN-M201RAD size: 1.82 TiB 
Partition: ID-1: / size: 28.71 GiB used: 19.21 GiB (66.9%) fs: ext4 dev: /dev/nvme0n1p6 
           ID-2: /boot size: 1.89 GiB used: 299.4 MiB (15.5%) fs: ext4 dev: /dev/nvme0n1p5 
           ID-3: /home size: 128.38 GiB used: 100.97 GiB (78.6%) fs: ext4 dev: /dev/nvme0n1p10 
           ID-4: /var size: 15.32 GiB used: 3.91 GiB (25.5%) fs: ext4 dev: /dev/nvme0n1p8 
Swap:      ID-1: swap-1 type: partition size: 1.95 GiB used: 165.5 MiB (8.3%) dev: /dev/nvme0n1p7 
Sensors:   System Temperatures: cpu: 83.0 C mobo: 27.8 C gpu: nvidia temp: 46 C 
           Fan Speeds (RPM): N/A gpu: nvidia fan: 37% 
Info:      Processes: 328 Uptime: 11h 03m Memory: 15.56 GiB used: 4.08 GiB (26.2%) Shell: Bash inxi: 3.3.01
As I mentioned, the kernel per se seems to work fine for me, I just need to find out about the module builds.

Offline towo

  • Global Moderator
  • User
  • *****
  • Posts: 2.455
Re: Boot problem with kernel 5.11.4
« Reply #6 on: 2021/03/09, 21:01:44 »
For vbox is a easy fix,

add
Code: [Select]
#include <linux/ethtool.h>to
/usr/src/virtualbox-6.1.18/vboxnetflt/linux/VBoxNetFlt-linux.c

Start dkms build after that change.

rtl8812au is not my construction site but i would oracle, google may have a fix for that even.
And no, it was mdmarmer, who had not provided any hardware info for his problem.
Ich gehe nicht zum Karneval, ich verleihe nur manchmal mein Gesicht.

Offline Pip

  • User
  • Posts: 91
Re: Boot problem with kernel 5.11.4
« Reply #7 on: 2021/03/09, 21:07:21 »
Didn't the sys.txt attachment he provided have what you needed?
I think I needed to update my git download for 8812au, so I wasn't pushing it at the time since I was fairly sure I'd find out about it eventually. I'd just hoped the small issues I'd had might help mdmarmer find something relevant in his apt or build logs.
Thanks, as always, towo.

Offline Pip

  • User
  • Posts: 91
Re: Boot problem with kernel 5.11.4
« Reply #8 on: 2021/03/09, 21:15:02 »
I did already have the ethtool.h included, but only later in the file:
Code: [Select]
/**
 * We filter traffic from the host to the internal network
 * before it reaches the NIC driver.
 *
 * The current code uses a very ugly hack overriding hard_start_xmit
 * callback in the device structure, but it has been shown to give us a
 * performance boost of 60-100% though. Eventually we have to find some
 * less hacky way of getting this job done.
 */
#define VBOXNETFLT_WITH_HOST2WIRE_FILTER

#ifdef VBOXNETFLT_WITH_HOST2WIRE_FILTER

# include <linux/ethtool.h>
I'll poke around for a while to see what I can find out, but I'm in no hurry so please ignore for the moment. I'll start my own thread if it becomes a problem for me.

Offline towo

  • Global Moderator
  • User
  • *****
  • Posts: 2.455
Re: Boot problem with kernel 5.11.4
« Reply #9 on: 2021/03/09, 21:17:12 »
Ah, i didn't see the attachment in mdmarmer's post, because i'm not aware anyone would attach a inxi output instead of posting it direct in a tread.
Ich gehe nicht zum Karneval, ich verleihe nur manchmal mein Gesicht.

Offline mdmarmer

  • User
  • Posts: 29
Re: Boot problem with kernel 5.11.4
« Reply #10 on: 2021/03/10, 22:38:11 »
The problem is that the kernel is not finding the root (/) partition. Is  there a parameter that could help? Should I file a bug report? If I do file a bug report, where would I file it? Do I need to provide more information? If so, what?
Basically the system is a fairly new Lenovo laptop with a fairly new Intel i3 CPU, an SSD (dual boot with Windows 10) -- one partition for linux and a swapfile ... all the details are in that sys.txt file I attached to my first post.  I get the same results with the 5.11.5 ... Both of these kernels boot fine on my older desktop system.  I had no problems until 5.11.4 ...

Offline mdmarmer

  • User
  • Posts: 29
Re: Boot problem with kernel 5.11.4
« Reply #11 on: 2021/03/11, 00:46:30 »
I tried 5.11.0-5.1-liquorix-amd64 kernel on this laptop and it boots just fine and has no problems.  damentz  said that he "had to make a ton of changes recently on Liquorix to fix some boot issues."
I am using boot parameter pci=nocrs to get my touchpad working.