Welcome, Guest. Please login or register.
Did you miss your activation email?

Author Topic: d-u will kde-plasma pakete entfernen  (Read 1195 times)

Offline nepomux

  • Newbie
  • Posts: 2
    • http://www.klee4.de
d-u will kde-plasma pakete entfernen
« on: 2021/09/15, 11:20:13 »
Beim d-u sollen bei mir kde-plasma-desktop plasma-desktop plasma-widgets-addons plasma-workspace entfernt werden.
Was tun?
Grüße Claus

Online towo

  • Global Moderator
  • User
  • *****
  • Posts: 2.563
Re: d-u will kde-plasma pakete entfernen
« Reply #1 on: 2021/09/15, 11:21:56 »
Quote
Was tun?

Warten?
Uns relevante Infos geben?
Hier hat Niemand eine Glaskugel!
Ich gehe nicht zum Karneval, ich verleihe nur manchmal mein Gesicht.

Offline paco

  • User
  • Posts: 63
Re: d-u will kde-plasma pakete entfernen
« Reply #2 on: 2021/09/15, 12:12:23 »
OK, here we go:
Code: [Select]
d-u
(...)
Reading package lists... Done
Building dependency tree... Done
Reading state information... Done
27 packages can be upgraded. Run 'apt list --upgradable' to see them.
Paketlisten werden gelesen… Fertig
Abhängigkeitsbaum wird aufgebaut… Fertig
Statusinformationen werden eingelesen… Fertig
Paketaktualisierung (Upgrade) wird berechnet… Fertig
Die folgenden Pakete wurden automatisch installiert und werden nicht mehr benötigt:
  bluedevil breeze breeze-cursor-theme breeze-gtk-theme bup bup-doc drkonqi frameworkintegration ibus-data ieee-data kde-config-sddm kde-style-breeze
  kde-style-oxygen-qt5 khotkeys khotkeys-data kmenuedit kscreen ksysguard ksysguard-data ksysguardd kup-backup kwin-style-breeze kwrited libcolorcorrect5
  libgps28 libibus-1.0-5 libkf5holidays-data libkf5holidays5 libkf5screen-bin libkf5screen7 libkf5style5 libkf5sysguard-bin libkfontinst5 libkfontinstui5
  libkpmcore11 libksgrd9 libksignalplotter9 libnotificationmanager1 liboxygenstyle5-5 liboxygenstyleconfig5-5 libplasma-geolocation-interface5
  libpowerdevilcore2 libpowerdevilui5 libprocessui9 libqalculate20 libqalculate20-data libscim8v5 libtaskmanager6abi1 libweather-ion7 libxcb-dpms0
  libxcb-record0 libxres1 linux-headers-5.13.15-1-siduction-amd64 linux-image-5.13.15-1-siduction-amd64 milou oxygen-sounds par2 partitionmanager
  plasma-desktop-data plasma-disks plasma-integration plasma-workspace-data powerdevil powerdevil-data python3-fuse python3-pylibacl
  qml-module-org-kde-activities qml-module-org-kde-draganddrop qml-module-org-kde-kholidays qml-module-org-kde-kio qml-module-org-kde-kwindowsystem
  qml-module-org-kde-solid qml-module-qtwebkit systemsettings
Verwenden Sie »apt autoremove«, um sie zu entfernen.
Die folgenden Pakete werden ENTFERNT:
  kde-plasma-desktop kinfocenter plasma-desktop plasma-widgets-addons plasma-workspace sddm-theme-breeze sddm-theme-debian-breeze
Die folgenden Pakete werden aktualisiert (Upgrade):
  libcolorcorrect5 libegl1 libepoxy0 libgl1 libgles1 libgles2 libglvnd0 libglx0 libhdf4-0-alt libkfontinst5 libkfontinstui5 libkimageannotator-common
  libkimageannotator0 libkworkspace5-5 libnotificationmanager1 libopengl0 libplasma-geolocation-interface5 libsoundtouch1 libsrtp2-1 libtaskmanager6abi1
  libweather-ion7 libx11-6 libx11-data libx11-xcb1
24 aktualisiert, 0 neu installiert, 7 zu entfernen und 0 nicht aktualisiert.
Es müssen 3.081 kB an Archiven heruntergeladen werden.
Nach dieser Operation werden 29,1 MB Plattenplatz freigegeben.
Möchten Sie fortfahren? [J/n]
Ist seit gestern so und hier scheint wirklich Geduld angebracht!

Offline hschn

  • User
  • Posts: 106
Re: d-u will kde-plasma pakete entfernen
« Reply #3 on: 2021/09/15, 12:17:51 »
Hallo,
dies passierte bei mir manchmal mit den Paketen von preining.
Meine Lösung:

apt upgrade
apt install plasma-desktop

sehen, was passiert,
wenn keine pakete entfernt werden, durchlaufen lassen

danach lief meistens apt upgrade normal durch
Mögen hätt' ich schon wollen, aber dürfen habe ich mich nicht getraut (Karl Valentin)

Offline paco

  • User
  • Posts: 63
Re: d-u will kde-plasma pakete entfernen
« Reply #4 on: 2021/09/15, 12:24:57 »
No, nacktes farewell ohne preining etc.

Offline hschn

  • User
  • Posts: 106
Re: d-u will kde-plasma pakete entfernen
« Reply #5 on: 2021/09/15, 13:13:26 »
Trotzdem

Versuch macht kluch
Mögen hätt' ich schon wollen, aber dürfen habe ich mich nicht getraut (Karl Valentin)

Offline finotti

  • User
  • Posts: 200
Re: d-u will kde-plasma pakete entfernen
« Reply #6 on: 2021/09/15, 13:27:18 »
I am not sure if it is related or not, but in two of my systems the solution was "apt install libqalculate22 libqalculate22-data".  After that I was able to DU without losing any package.

(I was able to see the conflict with 'apt-get -o Debug::pkgProblemResolver=yes dist-upgrade'.)

This was weird, because in one of my systems this was done automatically, but in the other two I had to do it manually.

Offline edlin

  • User
  • Posts: 42
Re: d-u will kde-plasma pakete entfernen
« Reply #7 on: 2021/09/15, 13:43:11 »
"apt install libqalculate22 libqalculate22-data"
Das Paket libqalculate22-data gibt es wohl nicht. Ich habe libqalculate22 installiert, wobei libqalculate20-data durch libqalculate-data ersetzt wurde.
Danach lief DU problemlos durch.

Danke, edlin
-----
"apt install libqalculate22 libqalculate22-data".
I guess the package libqalculate22-data does not exist. I installed libqalculate22, replacing libqalculate20-data with libqalculate-data.
After that DU ran through without any problems.

Thanks, edlin
Der Kluge lernt aus allem und von jedem,
der Normale aus seinen Erfahrungen
und der Dumme weiß alles besser.

Sokrates

Offline paco

  • User
  • Posts: 63
Re: d-u will kde-plasma pakete entfernen
« Reply #8 on: 2021/09/15, 14:03:21 »
Perfekte Lösung, danke, auch für den vertieften Blick hinter apt!

Offline hendrikL

  • Global Moderator
  • User
  • *****
  • Gravatar
  • Posts: 547
Re: d-u will kde-plasma pakete entfernen
« Reply #9 on: 2021/09/15, 14:07:01 »
For the record, 'apt full-upgrade libqalculate22+' should do the trick ;)

Offline unklarer

  • User
  • Posts: 643
Re: d-u will kde-plasma pakete entfernen
« Reply #10 on: 2021/09/15, 14:10:57 »
Ich beziehe mich auf @paco's Beitrag.   :)
I am referring to @paco's post.

Meine Lösung heute morgen:
My solution this morning:
Code: [Select]
apt policy plasma-desktop plasma-widgets-addons plasma-workspace
plasma-desktop:
  Installiert:           4:5.21.5-2
  Installationskandidat: 4:5.21.5-2
  Versionstabelle:
 *** 4:5.21.5-2 500
        500 http://deb.debian.org/debian unstable/main amd64 Packages
        100 /var/lib/dpkg/status
plasma-widgets-addons:
  Installiert:           4:5.21.5-2
  Installationskandidat: 4:5.21.5-2
  Versionstabelle:
 *** 4:5.21.5-2 500
        500 http://deb.debian.org/debian unstable/main amd64 Packages
        100 /var/lib/dpkg/status
plasma-workspace:
  Installiert:           4:5.21.5-3
  Installationskandidat: 4:5.21.5-3+b1
  Versionstabelle:
     4:5.21.5-3+b1 500
        500 http://deb.debian.org/debian unstable/main amd64 Packages
 *** 4:5.21.5-3 100
        100 /var/lib/dpkg/status
Code: [Select]
apt install plasma-workspace
Paketlisten werden gelesen… Fertig
Abhängigkeitsbaum wird aufgebaut… Fertig
Statusinformationen werden eingelesen… Fertig
Die folgenden zusätzlichen Pakete werden installiert:
  libcolorcorrect5 libkfontinst5 libkfontinstui5 libkworkspace5-5 libnotificationmanager1 libplasma-geolocation-interface5 libqalculate-data libqalculate22 libtaskmanager6abi1
  libweather-ion7
Die folgenden Pakete werden ENTFERNT:
  libqalculate20 libqalculate20-data
Die folgenden NEUEN Pakete werden installiert:
  libqalculate-data libqalculate22
Die folgenden Pakete werden aktualisiert (Upgrade):
  libcolorcorrect5 libkfontinst5 libkfontinstui5 libkworkspace5-5 libnotificationmanager1 libplasma-geolocation-interface5 libtaskmanager6abi1 libweather-ion7 plasma-workspace
9 aktualisiert, 2 neu installiert, 2 zu entfernen und 155 nicht aktualisiert.
Es müssen 4.766 kB an Archiven heruntergeladen werden.
Nach dieser Operation werden 3.044 kB Plattenplatz zusätzlich benutzt.
Möchten Sie fortfahren? [J/n]
Code: [Select]
apt dist-upgrade --no-install-recommends
Paketlisten werden gelesen… Fertig
Abhängigkeitsbaum wird aufgebaut… Fertig
Statusinformationen werden eingelesen… Fertig
Paketaktualisierung (Upgrade) wird berechnet… Fertig
Die folgenden NEUEN Pakete werden installiert:
  libquazip5-1 linux-headers-5.14.4-1-siduction-amd64 linux-image-5.14.4-1-siduction-amd64
Die folgenden Pakete werden aktualisiert (Upgrade):
  accountwizard akonadi-contacts-data akonadi-mime-data dconf-cli dconf-gsettings-backend dconf-service gsettings-desktop-schemas gstreamer1.0-alsa gstreamer1.0-plugins-bad
  gstreamer1.0-plugins-base gstreamer1.0-plugins-good gstreamer1.0-plugins-ugly gstreamer1.0-pulseaudio gstreamer1.0-tools gstreamer1.0-x ibverbs-providers kaddressbook
  kaddressbook-data kdepim-addons kdepim-runtime keepassxc kf5-messagelib-data kmailtransport-akonadi knotes konsolekalendar kontact korganizer libc-bin libc-dev-bin libc-l10n
  libc6 libc6-dev libdav1d5 libdconf1 libedit2 libegl1 libepoxy0 libgcrypt20 libgl1 libgles2 libglvnd0 libglx0 libgstreamer-gl1.0-0 libgstreamer-plugins-bad1.0-0
  libgstreamer-plugins-base1.0-0 libgstreamer1.0-0 libibverbs1 libipt2 libkf5akonadicalendar-data libkf5akonadicalendar5abi1 libkf5akonadicontact5 libkf5akonadimime5
  libkf5akonadinotes5 libkf5akonadisearch-bin libkf5akonadisearch-data libkf5akonadisearch-plugins libkf5akonadisearchcore5 libkf5akonadisearchdebug5 libkf5akonadisearchpim5
  libkf5akonadisearchxapian5 libkf5alarmcalendar-data libkf5alarmcalendar5abi1 libkf5calendarsupport-data libkf5calendarsupport5abi1 libkf5calendarutils5 libkf5contacteditor5
  libkf5eventviews-data libkf5eventviews5abi1 libkf5gravatar-data libkf5gravatar5abi2 libkf5identitymanagement5 libkf5imap-data libkf5imap5 libkf5incidenceeditor-bin
  libkf5incidenceeditor-data libkf5incidenceeditor5abi1 libkf5kmanagesieve5 libkf5kontactinterface-data libkf5kontactinterface5 libkf5ksieve-data libkf5ksieve5 libkf5ksieveui5
  libkf5libkdepim-data libkf5libkdepim-plugins libkf5libkdepim5 libkf5libkleo-data libkf5libkleo5 libkf5mailcommon-data libkf5mailcommon5abi2 libkf5mailimporter5
  libkf5mailtransport-data libkf5mailtransport5 libkf5mailtransportakonadi5 libkf5mbox5 libkf5messagecomposer5abi1 libkf5messagecore5abi1 libkf5messagelist5abi1
  libkf5messageviewer5abi1 libkf5mime-data libkf5mime5abi1 libkf5mimetreeparser5abi1 libkf5pimcommon-data libkf5pimcommon-plugins libkf5pimcommon5abi2 libkf5pimcommonakonadi5abi1
  libkf5pimtextedit-data libkf5pimtextedit-plugins libkf5pimtextedit5abi2 libkf5templateparser5 libkf5tnef5 libkf5webengineviewer5abi1 libkimageannotator-common
  libkimageannotator0 libkpimaddressbookimportexport5 libkpimgapi-data libkpimgapicalendar5 libkpimgapicontacts5 libkpimgapicore5abi1 libkpimgapitasks5 libkpimimportwizard5
  libkpimitinerary-data libkpimitinerary5 libkpimpkpass5 libkpimsmtp5abi1 libopengl0 libraw20 librdmacm1 librsvg2-2 librsvg2-bin librsvg2-common librubberband2
  libsasl2-modules-kdexoauth2 libsoundtouch1 libsrtp2-1 libuv1 libuv1-dev libx11-6 libx11-data libx11-xcb1 libxencall1 libxendevicemodel1 libxenevtchn1 libxenforeignmemory1
  libxengnttab1 libxenhypfs1 libxenmisc4.14 libxenstore3.0 libxentoolcore1 libxentoollog1 libz3-4 linux-headers-siduction-amd64 linux-image-siduction-amd64 locales node-semver
  rsync
155 aktualisiert, 3 neu installiert, 0 zu entfernen und 0 nicht aktualisiert.
Es müssen 140 MB an Archiven heruntergeladen werden.
Nach dieser Operation werden 312 MB Plattenplatz zusätzlich benutzt.
Möchten Sie fortfahren? [J/n]

Offline dibl

  • siduction community member
  • Global Moderator
  • User
  • *****
  • Posts: 2.171
    • Land of the Buckeye
Re: d-u will kde-plasma pakete entfernen
« Reply #11 on: 2021/09/15, 18:34:38 »
For English speakers who use KDE/plasma desktop:

Code: [Select]
# apt update
Code: [Select]
# apt upgrade
Code: [Select]
# apt install --reinstall plasma-workspace
Two libqalculate2220 packages will be removed, and all the "held back" packages will be installed, and your system will be fully up to date.
« Last Edit: 2021/09/15, 20:27:11 by dibl »
System76 Oryx Pro, Intel Core i7-11800H, SSD 970 EVO Plus;  Asus ROG STRIX X299-E, Core i7-7740X, Nvidia GTX-1060, dual monitors, SSD 860 EVO

Offline edlin

  • User
  • Posts: 42
Re: d-u will kde-plasma pakete entfernen
« Reply #12 on: 2021/09/15, 19:08:18 »
I assume that libqalculate20 will be removed and replaced by libqalculate22. Or am I mistaken?

edlin

++++
Ich vermute mal, dass libqalculate20 entfernt und durch libqalculate22 ersetzt wird. Oder irre ich mich da?

edlin
Der Kluge lernt aus allem und von jedem,
der Normale aus seinen Erfahrungen
und der Dumme weiß alles besser.

Sokrates

Offline dibl

  • siduction community member
  • Global Moderator
  • User
  • *****
  • Posts: 2.171
    • Land of the Buckeye
Re: d-u will kde-plasma pakete entfernen
« Reply #13 on: 2021/09/15, 20:24:57 »
Quote from: edllin
I assume that libqalculate20 will be removed and replaced by libqalculate22.

Yes, you are correct -- I wrote that wrong. libqalculate22 is what is installed.
System76 Oryx Pro, Intel Core i7-11800H, SSD 970 EVO Plus;  Asus ROG STRIX X299-E, Core i7-7740X, Nvidia GTX-1060, dual monitors, SSD 860 EVO

Offline charlyheinz

  • User
  • Posts: 38
Re: d-u will kde-plasma pakete entfernen
« Reply #14 on: 2021/09/16, 15:00:46 »
@dibl

I've done it your way and it works really well. apt upgrade and also apt-get dist-upgrade are running through, after reinstalling plasma-workspace there is no problem here, although there are some packages to be removed. It is this https://forum.siduction.org/index.php?topic=8392.0 issue, where I could not login anymore. Do you remember  :-[

thanks a lot.