Welcome, Guest. Please login or register.
Did you miss your activation email?

Author Topic: gelöst: Qgis nicht aktualisierbar  (Read 375 times)

Offline HarzG

  • User
  • Posts: 130
gelöst: Qgis nicht aktualisierbar
« on: 2021/10/31, 10:31:16 »
Vor etwa 10 Tagen ging wohl etwas schief beim Aktualisieren von Qgis. Leider war ein Mix entstanden von den Versionen 3.16.11+dfsg-2 und 3.16.12+dfsg-1. Daher kamen die Meldungen:
Code: [Select]
Setting up qgis-providers (3.16.11+dfsg-2) ...
Segmentation fault
dpkg: error processing package qgis-providers (--configure):
 installed qgis-providers package post-installation script subprocess returned error exit status 139
dpkg: dependency problems prevent configuration of qgis:
 qgis depends on qgis-providers (= 3.16.11+dfsg-2); however:
  Package qgis-providers is not configured yet.

dpkg: error processing package qgis (--configure):
 dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of python3-qgis:
 python3-qgis depends on qgis-providers (= 3.16.11+dfsg-2); however:
  Package qgis-providers is not configured yet.

dpkg: error processing package python3-qgis (--configure):
 dependency problems - leaving unconfigured
Errors were encountered while processing:
 qgis-providers
 qgis
 python3-qgis
E: Sub-process /usr/bin/dpkg returned an error code (1)
Mit erst mal abwarten, ab und zu " apt install -f" zu probieren war das Problem nicht zu lösen. Letztendlich ging es dann so
Code: [Select]
apt remove --purge qgis*Da autoremove Reste meldete, habe diese Pakete auch noch entfernt
Code: [Select]
apt remove> grass-core grass-doc libarmadillo9 libassimp5 libcbor0 libcfitsio8 libdap25 libfcgi0ldbl libgdal26 libgdal27 libgeos-3.9.1 libgupnp-1.2-0 libkf5idletime5 liblaszip8 libpdal-base13 libpdal-util13 libpoppler82 libqca-qt5-2 libqca-qt5-2-plugins libqgis-3d3.16.11 libqgis-analysis3.16.11 libqgis-app3.16.11 libqgis-core3.16.11 libqgis-core3.16.12 libqgis-customwidgets libqgis-gui3.16.11 libqgis-gui3.16.12 libqgis-native3.16.11 libqgis-native3.16.12 libqgis-server3.16.11 libqgispython3.16.11 libqhull7deb1 libqt53danimation5 libqt53dcore5 libqt53dextras5 libqt53dinput5 libqt53dlogic5 libqt53dquickscene2d5 libqt53drender5 libqt5designercomponents5 libqt5keychain1 libqt5serialport5 libqwt-qt5-6 libsidplayfp5 libspatialindex6 python3-qgis-common qdoc-qt5 qhelpgenerator-qt5 qt3d-assimpsceneimport-plugin qt3d-defaultgeometryloader-plugin qt3d-gltfsceneio-plugin qt3d-scene2d-plugin qt5-assistant qtattributionsscanner-qt5 qttools5-dev-toolsDanach kam die Neuinstallation von Qgis wobei keine der alten Einstellungen mitgenommen wurden, aber die extra Plugins ohne Probleme mitgenommen wurden ins neue Qgis. Alles prima mit Qgis 3.16.12+dfsg-1.