Welcome, Guest. Please login or register.
Did you miss your activation email?

Author Topic: [EN] [SOLVED]OpenVPN / ProtonVPN does not work even if it seems to work  (Read 3243 times)

Offline uxman

  • Claus(i)
  • User
  • Posts: 16
First I hope its ok to report this problem in English too!

When I configure the VPN via a ready to use config file from the VPN provider and start the VPN via the network-manager applet in KDE, the applet report a successful activation of the VPN connection.

But when you cross check your IP, your traffic is not going through the VPN, instead still using your origin IP.

I also installed the ProtonVPN apk package, same behavior.

On the Siduction xfce build, its the same.

Here is my journalctl log:

Code: [Select]
OpenVPN 2.6_rc2 x86_64-pc-linux-gnu [SSL (OpenSSL)] [LZO] [LZ4] [EPOLL] [PKCS11] [MH/PKTINFO] [AEAD] [DCO]
library versions: OpenSSL 3.0.7 1 Nov 2022, LZO 2.10
WARNING: No server certificate verification method has been enabled.  See http://openvpn.net/howto.html#mitm for more info.
NOTE: the current --script-security setting may allow this configuration to call user-defined scripts
TCP/UDP: Preserving recently used remote address: [AF_INET]
UDPv4 link local: (not bound)
UDPv4 link remote: [AF_INET]
NOTE: UID/GID downgrade will be delayed because of --client, --pull, or --up-delay
[node-at-06.protonvpn.net] Peer Connection Initiated with [AF_INET]
NOTE: setsockopt TCP_NODELAY=1 failed
TUN/TAP device tun0 opened
usr/lib/NetworkManager/nm-openvpn-service-openvpn-helper --debug 0 20562 --bus-name org.freedesktop.NetworkManager.openvpn.Connection_5 --tun -- tun0 1500 0 init
<info>  [1674294845.6418] manager: (tun0): new Tun device (/org/freedesktop/NetworkManager/Devices/6)
org.kde.plasma.nm.kded: Unhandled VPN connection state change:  4
Withdrawing address record for on wlan0.
capng_change_id() failed applying capabilities: Operation not permitted (errno=1)
NOTE: previous error likely due to missing capability CAP_SETPCAP.
Unable to retain capabilities
GID set to nm-openvpn
UID set to nm-openvpn
Initialization Sequence Completed
avahi-daemon[829]: Registering new address record for on wlan0.IPv4.
[system] Activating via systemd: service name='org.freedesktop.nm_dispatcher' unit='dbus-org.freedesktop.nm-dispatcher.service' requested by ':1.8' (uid=0 pid=860 comm="/usr/sbin/NetworkManager --no-daemon")
<info>  [1674294845.6649] device (tun0): state change: unmanaged -> unavailable (reason 'connection-assumed', sys-iface-state: 'external')
<info>  [1674294845.6674] device (tun0): state change: unavailable -> disconnected (reason 'connection-assumed', sys-iface-state: 'external')
<info>  [1674294845.6695] device (tun0): Activation: starting connection 'tun0' (fba09e53-a09c-427b-ae77-9192babbeba2)
<info>  [1674294845.6698] device (tun0): state change: disconnected -> prepare (reason 'none', sys-iface-state: 'external')
<info>  [1674294845.6709] device (tun0): state change: prepare -> config (reason 'none', sys-iface-state: 'external')
<info>  [1674294845.6714] device (tun0): state change: config -> ip-config (reason 'none', sys-iface-state: 'external')
<info>  [1674294845.6724] device (tun0): state change: ip-config -> ip-check (reason 'none', sys-iface-state: 'external')
Starting Network Manager Script Dispatcher Service...
dbus-daemon[831]: [system] Successfully activated service 'org.freedesktop.nm_dispatcher'
Started Network Manager Script Dispatcher Service.
<info>  [1674294845.7034] policy: set 'ProtonVPN Austria' (tun0) as default for IPv4 routing and DNS
<info>  [1674294845.7188] device (tun0): state change: ip-check -> secondaries (reason 'none', sys-iface-state: 'external')
<info>  [1674294845.7191] device (tun0): state change: secondaries -> activated (reason 'none', sys-iface-state: 'external')
<info>  [1674294845.7196] device (tun0): Activation: successful, device activated.

Does somebody has further advice?

« Last Edit: 2023/01/28, 22:20:19 by uxman »

Offline dibl

  • siduction community member
  • Global Moderator
  • User
  • *****
  • Posts: 2.364
    • Land of the Buckeye
Perfectly fine -- thanks for posting it!
System76 Oryx Pro, Intel Core i7-11800H, SSD 970 EVO Plus;  Asus ROG STRIX X299-E, Core i7-7740X, Nvidia GTX-1060, dual monitors, SSD 860 EVO

Offline titan

  • User
  • Posts: 313
Does your VPN provider allow/provide .ovpn files, I just use  wireguard with sudo wg-quick up or down and path to required.ovpn file. I have several .ovpn files for the servers I use, although they also provide a single .ovpn file for the county you wish to use and it chooses the fastest.

You can also check your connection here https://ipleak.net/
« Last Edit: 2023/01/22, 17:03:47 by titan »

Offline uxman

  • Claus(i)
  • User
  • Posts: 16
Yes, Proton does provide "ready to use" *.ovpn configs to download and thats what I use!
It works on every other distribution, but not on siduction...

Offline uxman

  • Claus(i)
  • User
  • Posts: 16
Solved via updates, I suppose :)


Offline uxman

  • Claus(i)
  • User
  • Posts: 16
I dont understand why, it  did work in my workplace. but at home I have the same behavior as before :(
I start the VPN, it activates successfully but when checking the IP, I am not protected by the VPN...

[EDIT] I am pretty sure it was a cookie left from my "home LAN" what gave me the impression that the VPN did work at my workplace
« Last Edit: 2023/01/25, 11:14:33 by uxman »

Offline uxman

  • Claus(i)
  • User
  • Posts: 16
Its working and solved via updates! Thank you