Welcome, Guest. Please login or register.
Did you miss your activation email?

Author Topic: [EN] Problems with AMD Graphics and Kernel 6.8  (Read 1275 times)

Offline finotti

  • User
  • Posts: 277
[EN] Problems with AMD Graphics and Kernel 6.8
« on: 2024/05/16, 17:02:03 »
I have a AMD Navi 24 [Radeon RX 6300] card that does not work on any version 6.8.* kernel.  At first I thought it was due to the fact I was using multiple monitors and cards, but even a single monitor connected to the AMD card does not work.  It works without problems with versions 6.7* or earlier.

Here is some information about the system:

Code: [Select]
$ inxi -G
Graphics:
  Device-1: Intel Raptor Lake-S GT1 [UHD Graphics 770] driver: i915 v: kernel
  Device-2: AMD Navi 24 [Radeon RX 6300] driver: amdgpu v: kernel
  Device-3: Logitech C920 PRO HD Webcam driver: snd-usb-audio,uvcvideo
    type: USB
  Display: x11 server: X.Org v: 21.1.11 with: Xwayland v: 24.1.0 driver: X:
    loaded: modesetting unloaded: fbdev,vesa dri: iris gpu: amdgpu,i915
    resolution: 1: 1080x1920~60Hz 2: 2560x1440~60Hz 3: 1920x1200~60Hz
  API: EGL v: 1.5 drivers: iris,radeonsi,swrast
    platforms: gbm,x11,surfaceless,device
  API: OpenGL v: 4.6 compat-v: 4.5 vendor: intel mesa v: 24.0.7-1
    renderer: Mesa Intel Graphics (RPL-S)

Code: [Select]
$ lspci
00:00.0 Host bridge: Intel Corporation Device a700 (rev 01)
00:01.0 PCI bridge: Intel Corporation Raptor Lake PCI Express 5.0 Graphics Port (PEG010) (rev 01)
00:02.0 VGA compatible controller: Intel Corporation Raptor Lake-S GT1 [UHD Graphics 770] (rev 04)
00:04.0 Signal processing controller: Intel Corporation Raptor Lake Dynamic Platform and Thermal Framework Processor Participant (rev 01)
00:08.0 System peripheral: Intel Corporation GNA Scoring Accelerator module (rev 01)
00:14.0 USB controller: Intel Corporation Alder Lake-S PCH USB 3.2 Gen 2x2 XHCI Controller (rev 11)
00:14.2 RAM memory: Intel Corporation Alder Lake-S PCH Shared SRAM (rev 11)
00:15.0 Serial bus controller: Intel Corporation Alder Lake-S PCH Serial IO I2C Controller #0 (rev 11)
00:16.0 Communication controller: Intel Corporation Alder Lake-S PCH HECI Controller #1 (rev 11)
00:17.0 SATA controller: Intel Corporation Alder Lake-S PCH SATA Controller [AHCI Mode] (rev 11)
00:1b.0 PCI bridge: Intel Corporation Alder Lake-S PCH PCI Express Root Port #21 (rev 11)
00:1f.0 ISA bridge: Intel Corporation Device 7a83 (rev 11)
00:1f.3 Audio device: Intel Corporation Alder Lake-S HD Audio Controller (rev 11)
00:1f.4 SMBus: Intel Corporation Alder Lake-S PCH SMBus Controller (rev 11)
00:1f.5 Serial bus controller: Intel Corporation Alder Lake-S PCH SPI Controller (rev 11)
00:1f.6 Ethernet controller: Intel Corporation Ethernet Connection (17) I219-LM (rev 11)
01:00.0 PCI bridge: Advanced Micro Devices, Inc. [AMD/ATI] Navi 10 XL Upstream Port of PCI Express Switch
02:00.0 PCI bridge: Advanced Micro Devices, Inc. [AMD/ATI] Navi 10 XL Downstream Port of PCI Express Switch
03:00.0 VGA compatible controller: Advanced Micro Devices, Inc. [AMD/ATI] Navi 24 [Radeon RX 6300]
03:00.1 Audio device: Advanced Micro Devices, Inc. [AMD/ATI] Navi 21/23 HDMI/DP Audio Controller
04:00.0 Non-Volatile memory controller: SK hynix Platinum P41/PC801 NVMe Solid State Drive

Code: [Select]
$ inxi -v3
System:
  Host: dell7010 Kernel: 6.7.12-amd64 arch: x86_64 bits: 64 compiler: gcc
    v: 13.2.0
  Desktop: KDE Plasma v: 5.27.10 Distro: siduction 22.1.2 Masters_of_War -
    kde - (202303220911) base: Debian GNU/Linux trixie/sid
Machine:
  Type: Desktop System: Dell product: OptiPlex SFF Plus 7010 v: N/A
    serial: <superuser required>
  Mobo: Dell model: 0YGWFV v: A00 serial: <superuser required> UEFI: Dell
    v: 1.13.1 date: 03/11/2024
Battery:
  Device-1: hidpp_battery_0 model: Logitech Wireless Mouse MX Master 3
    charge: 100% (should be ignored) status: discharging
CPU:
  Info: 24-core model: 13th Gen Intel Core i9-13900 bits: 64 type: MCP
    smt: disabled arch: Raptor Lake rev: 1 cache: L1: 2.1 MiB L2: 32 MiB
    L3: 36 MiB
  Speed (MHz): avg: 947 high: 1495 min/max: 800/5300:5600:4200 cores: 1: 800
    2: 800 3: 1495 4: 1477 5: 800 6: 1487 7: 1323 8: 800 9: 839 10: 800 11: 800
    12: 800 13: 800 14: 800 15: 1333 16: 1180 17: 800 18: 800 19: 800 20: 800
    21: 800 22: 800 23: 800 24: 800 bogomips: 95846
  Flags: avx avx2 ht lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx
Graphics:
  Device-1: Intel Raptor Lake-S GT1 [UHD Graphics 770] vendor: Dell
    driver: i915 v: kernel arch: Gen-13 bus-ID: 00:02.0
  Device-2: AMD Navi 24 [Radeon RX 6300] vendor: Dell driver: amdgpu
    v: kernel arch: RDNA-2 bus-ID: 03:00.0
  Device-3: Logitech C920 PRO HD Webcam driver: snd-usb-audio,uvcvideo
    type: USB bus-ID: 1-10:6
  Display: x11 server: X.Org v: 21.1.11 with: Xwayland v: 24.1.0 driver: X:
    loaded: modesetting unloaded: fbdev,vesa dri: iris gpu: amdgpu,i915
    resolution: 1: 1080x1920~60Hz 2: 2560x1440~60Hz 3: 1920x1200~60Hz
  API: OpenGL v: 4.6 compat-v: 4.5 vendor: intel mesa v: 24.0.7-1 glx-v: 1.4
    direct-render: yes renderer: Mesa Intel Graphics (RPL-S)
Network:
  Device-1: Intel Ethernet I219-LM vendor: Dell driver: e1000e v: kernel
    port: N/A bus-ID: 00:1f.6
  IF: enp0s31f6 state: up speed: 100 Mbps duplex: full
    mac: cc:96:e5:1f:61:3b
  IF-ID-1: mpqemubr0 state: up speed: 10000 Mbps duplex: unknown
    mac: 52:54:00:9b:02:5c
  IF-ID-2: tap-1dfd44cc333 state: up speed: 10000 Mbps duplex: full
    mac: f6:6d:b4:f3:07:1a
Drives:
  Local Storage: total: 953.88 GiB used: 654.25 GiB (68.6%)
Info:
  Memory: total: 128 GiB note: est. available: 125.5 GiB
    used: 14.24 GiB (11.3%)
  Processes: 538 Uptime: 1h 18m Init: systemd target: graphical (5)
  Packages: 4493 Compilers: gcc: 13.2.0 Shell: Bash v: 5.2.21 inxi: 3.3.34

Here is an Xorg.0.log of an attempt: https://paste.debian.net/1317151/ where you can see

Code: [Select]
[    12.673] (EE) Screen(s) found, but none have a usable configuration.
[    12.673] (EE)
Fatal server error:
[    12.673] (EE) no screens found(EE)

I cannot even boot into a VT with the boot option '3', as I get only a blank screen.   And I see no relevant error with "journalctl -p err -b".

Any suggestions?


Offline finotti

  • User
  • Posts: 277
Re: Problems with AMD Graphics and Kernel 6.8
« Reply #1 on: 2024/06/04, 20:16:27 »
Although the problem remained with every 6.8 kernel (even the official Debian and Liquorix),  the card is working again with 6.9.3-1-siduction-amd64.  I hope it is the end of the problems...