seduction
 Language:
Welcome, Guest. Please login or register.
Did you miss your activation email?
2020/02/21, 02:36:10


Help

Author [EN] [PL] [ES] [PT] [IT] [DE] [FR] [NL] [TR] [SR] [AR] [RU] Topic: kdenext-repo-users only: KDE 4.10 is coming  (Read 16347 times)

0 Members and 1 Guest are viewing this topic.

Offline devil

  • Administrator
  • User
  • *****
  • Posts: 4.394
kdenext-repo-users only: KDE 4.10 is coming
« Reply #30 on: 2013/04/04, 15:56:58 »
As of now, KDE SC 4.10.2 is uploaded to our repository and can be dist-upgraded to. Thanks to santa for packaging it so fast for us.

greetz
devil

Offline piper

  • Global Moderator
  • User
  • *****
  • Posts: 1.728
  • we are the priests ... of the temples of syrinx
kdenext-repo-users only: KDE 4.10 is coming
« Reply #31 on: 2013/04/04, 16:32:56 »
Quote from: "michaa7"
It's german (as in Upgrade Warnings DE & EN).

In short it says: problem solved which was caused by outdated packages from (discouraged) multimedia repo. Solution: Uninstall affected packages manually, dist-upgrade, reinstall those packages.
This problem should not occur if you don't have activated deb-multimedia.


Hmm, I have (discouraged) multimedia repo enabled, I also build with it (siduction-12.2.0-ridersonthestorm-kde-amd64-201304031453.iso) as I use mythtv on 4 computers, no problems here with dist-upgrade or a build.
I either give too many fucks or no fucks at all, it's like I cannot find a middle ground for a moderate fuck distribution, it's like what the fuck

Free speech isn't just fucking saying what you want to say, it's also hearing what you don't want to fucking hear

Offline michaa7

  • User
  • Posts: 2.128
kdenext-repo-users only: KDE 4.10 is coming
« Reply #32 on: 2013/04/04, 16:40:19 »
I assume you are talking about a completly updated system, manlig was talking about "old stock" packages (altbestände) from deb-mm, which lets me assume his system wasn't in an up-to-date status. That presumably makes the difference.
Ok, you can't code, but you still might be able to write a bug report for Debian's sake

Offline piper

  • Global Moderator
  • User
  • *****
  • Posts: 1.728
  • we are the priests ... of the temples of syrinx
kdenext-repo-users only: KDE 4.10 is coming
« Reply #33 on: 2013/04/04, 16:43:15 »
Ah, Yes, I have a completely updated system, if anything, like today, a day behind in a dist-upgrade (didn't do one today yet, due to 4 hours  a day every day of sleep)
I either give too many fucks or no fucks at all, it's like I cannot find a middle ground for a moderate fuck distribution, it's like what the fuck

Free speech isn't just fucking saying what you want to say, it's also hearing what you don't want to fucking hear

Offline Lanzi

  • User
  • Posts: 1.622
kdenext-repo-users only: KDE 4.10 is coming
« Reply #34 on: 2013/04/04, 17:15:10 »
hehe... sometimes it is confusing with the languages...
:_)

If someday we have a new forum, maybe we can have different backgrounds for the languagesections.

Offline dsat

  • User
  • Posts: 99
Calibre NOT to be removed anymore
« Reply #35 on: 2013/04/04, 17:25:29 »
Hi,

thanks for the fixes.

Regards dsat

Offline devil

  • Administrator
  • User
  • *****
  • Posts: 4.394
RE: Calibre NOT to be removed anymore
« Reply #36 on: 2013/04/04, 17:35:39 »
piper,
the probs with libavcodec53 were only reported from 32-bit systems. My guess is, manlig has 32-bit as well

greetz
devil

Offline manilg

  • User
  • Posts: 219
RE: Calibre NOT to be removed anymore
« Reply #37 on: 2013/04/04, 17:42:26 »
Quote from: "devil"
piper,
the probs with libavcodec53 were only reported from 32-bit systems. My guess is, manlig has 32-bit as well

greetz
devil
That´s right

manilg

Offline dibl

  • siduction community member
  • Global Moderator
  • User
  • *****
  • Posts: 1.954
    • Land of the Buckeye
RE: Calibre NOT to be removed anymore
« Reply #38 on: 2013/04/04, 18:56:21 »
This one is a non-issue for me (I found it accidentally), but it might affect someone:

Code: [Select]
root@imerabox:/# apt-cache policy libnepomuksync4
libnepomuksync4:
  Installed: (none)
  Candidate: 4:4.9.5-0r0
  Version table:
     4:4.9.5-0r0 0
        500 http://packages.siduction.org/kdenext/ unstable/main amd64 Packages
        100 /var/lib/dpkg/status
root@imerabox:/# apt-get install libnepomuksync4
Reading package lists... Done
Building dependency tree      
Reading state information... Done
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
 libnepomuksync4 : Depends: libnepomukcore4 (= 4:4.9.5-0r0) but 4:4.10.2-1~siduction2 is to be installed
E: Unable to correct problems, you have held broken packages.

root@imerabox:/# apt-cache policy libnepomukcore4
libnepomukcore4:
  Installed: 4:4.10.2-1~siduction2
  Candidate: 4:4.10.2-1~siduction2
  Version table:
     4:4.10.2-1 0
          1 http://cdn.debian.net/debian/ experimental/main amd64 Packages
 *** 4:4.10.2-1~siduction2 0
        500 http://packages.siduction.org/kdenext/ unstable/main amd64 Packages
        100 /var/lib/dpkg/status
Asus ROG STRIX X299-E, Core i7-7740X, Nvidia GTX-1060, dual monitors, SSD 860 EVO, 2@WD1003FZEX in BTRFS

Offline agaida

  • User
  • Posts: 1.760
    • http://g-com.eu
kdenext-repo-users only: KDE 4.10 is coming
« Reply #39 on: 2013/04/04, 19:38:28 »
manilg: Wie gesagt - es war ein Schnellschuss, da wir diese verquere libavcodec-Sache erst gestern abend in i386 entdeckt haben. Und ich war brav und hab den machen lassen und danach  die rausgeworfenen Pakete wieder installiert. Man kann das durchaus noch bösartiger lösen - muss man aber nicht. Da ich einer der glücklichen Menschen bin, die bisher noch keinen Bedarf für marillats Büchse der Pandorra hatte, uppsss.. sorry.

Es freut mich aber, dass Du Dein System trotzdem wieder in einen updatefähigen Zustand versetzen und updaten konntest. :)

PS: Bitte tut euch einen Gefallen und entsorgt auf jeden Fall qtcurve*. Das Zeug macht nichts Gutes. Zur Belohnung läuft fast der gesamte GTK-Kram danach ca. 20-30% schneller und stürzt signifikant weniger ab. Das gilt vor allem für Inkscape and Iceweasel (Firefox).

English: In any case - please replace the qtcurce* packages with the gtk?-engines-oxygen packages. After that your desktop will be 20-30% more responsive with gtk-Apps like inkscape and firefox. Also the number of crashs in gtk-apps, esp. inkscape will decrease significantly.
There's this special biologist word we use for "stable". It's "dead". ~ Jack Cohen

Offline agaida

  • User
  • Posts: 1.760
    • http://g-com.eu
kdenext-repo-users only: KDE 4.10 is coming
« Reply #40 on: 2013/04/04, 19:51:20 »
dibl: This is infact noteworthy: Please have experimental only active, if you really need it. There is no other clean solution for that as $foo-x will ever be bigger than $foo-x~siduction?y
There's this special biologist word we use for "stable". It's "dead". ~ Jack Cohen

Offline dibl

  • siduction community member
  • Global Moderator
  • User
  • *****
  • Posts: 1.954
    • Land of the Buckeye
kdenext-repo-users only: KDE 4.10 is coming
« Reply #41 on: 2013/04/04, 23:20:53 »
Good point -- thanks!  This is the price of laziness, I think.   :lol:
Asus ROG STRIX X299-E, Core i7-7740X, Nvidia GTX-1060, dual monitors, SSD 860 EVO, 2@WD1003FZEX in BTRFS

Offline hefee

  • User
  • Posts: 392
kdenext-repo-users only: KDE 4.10 is coming
« Reply #42 on: 2013/04/05, 03:58:08 »
More or less all went fine with the upgrade(from 4.9.5) but one package doesn't want to upgrade. If I now run DU I get:
Code: [Select]

$ apt-get dist-update
Reading package lists...
Building dependency tree...
Reading state information...
You might want to run 'apt-get -f install' to correct these.
The following packages have unmet dependencies:
 kdelibs-bin : Depends: libkdecore5 (= 4:4.9.5-0r1) but 4:4.10.2-0r0~siduction1 is installed
               Depends: libkdeui5 (= 4:4.9.5-0r1) but 4:4.10.2-0r0~siduction1 is installed
               Depends: libkio5 (= 4:4.9.5-0r1) but 4:4.10.2-0r0~siduction1 is installed
               Depends: libkjsapi4 (= 4:4.9.5-0r1) but 4:4.10.2-0r0~siduction1 is installed
               Depends: libkjsembed4 (= 4:4.9.5-0r1) but 4:4.10.2-0r0~siduction1 is installed
               Depends: libkrosscore4 (= 4:4.9.5-0r1) but 4:4.10.2-0r0~siduction1 is installed
               Depends: libnepomuk4 (= 4:4.9.5-0r1) but 4:4.10.2-0r0~siduction1 is installed
               Depends: libnepomukutils4 (= 4:4.9.5-0r1) but 4:4.10.2-0r0~siduction1 is installed
 kdelibs5-dev : Depends: kdelibs-bin (= 4:4.10.2-0r0~siduction1) but 4:4.9.5-0r1 is installed


I had to run to fix it:
Code: [Select]

$ apt-get -f -t experimental install
Reading package lists... Done
Building dependency tree      
Reading state information... Done
Correcting dependencies... Done
The following packages were automatically installed and are no longer required:
  libhupnp1 libqtsolutions-soap-2.7-1 qtcurve-l10n
Use 'apt-get autoremove' to remove them.
The following extra packages will be installed:
  kdelibs-bin kdelibs5-data kdelibs5-dbg kdelibs5-dev kdelibs5-plugins kdoctools libkcmutils4 libkde3support4 libkdeclarative5 libkdecore5 libkdesu5 libkdeui5 libkdewebkit5 libkdnssd4 libkemoticons4 libkfile4 libkhtml5 libkidletime4
  libkimproxy4 libkio5 libkjsapi4 libkjsembed4 libkmediaplayer4 libknewstuff2-4 libknewstuff3-4 libknotifyconfig4 libkntlm4 libkparts4 libkprintutils4 libkpty4 libkrosscore4 libkrossui4 libktexteditor4 libkunitconversion4 libkutils4
  libnepomuk4 libnepomukquery4a libnepomukutils4 libplasma3 libsolid4 libthreadweaver4
Suggested packages:
  hspell media-player-info
The following packages will be upgraded:
  kdelibs-bin kdelibs5-data kdelibs5-dbg kdelibs5-dev kdelibs5-plugins kdoctools libkcmutils4 libkde3support4 libkdeclarative5 libkdecore5 libkdesu5 libkdeui5 libkdewebkit5 libkdnssd4 libkemoticons4 libkfile4 libkhtml5 libkidletime4
  libkimproxy4 libkio5 libkjsapi4 libkjsembed4 libkmediaplayer4 libknewstuff2-4 libknewstuff3-4 libknotifyconfig4 libkntlm4 libkparts4 libkprintutils4 libkpty4 libkrosscore4 libkrossui4 libktexteditor4 libkunitconversion4 libkutils4
  libnepomuk4 libnepomukquery4a libnepomukutils4 libplasma3 libsolid4 libthreadweaver4
41 upgraded, 0 newly installed, 0 to remove and 838 not upgraded.
133 not fully installed or removed.
Need to get 96.8 MB/98.4 MB of archives.
After this operation, 29.7 kB of additional disk space will be used.
Do you want to continue [Y/n]?

Offline Lanzi

  • User
  • Posts: 1.622
kdenext-repo-users only: KDE 4.10 is coming
« Reply #43 on: 2013/04/05, 05:53:46 »
@Agaida: Kannst Du da mal zu qtcurve nen Extrathread aufmachen?

Ich würde gerne wssen, was daheintersteckt.
Leider sind deine Aussagen auch nicht in beiden Sprachen deckungsgleich:
qtcurve entfernen oder ersetzen?

Quote

dpkg -l |grep qtcurve

ii  gtk2-engines-qtcurve:i386                                 1.8.15-4                           i386         This is a set of widget styles for Gtk2 based apps
ii  kde-style-qtcurve                                         1.8.14-2+b0~pre1                   i386         QtCurve widget style for KDE 4
ii  kwin-style-qtcurve                                        1.8.14-2+b0~pre1                   i386         QtCurve window decoration for KWin
ii  qtcurve                                                   1.8.14-2+b0~pre1                   i386         Unified window decoration for KDE and GTK+ (meta-package)

Offline hefee

  • User
  • Posts: 392
kdenext-repo-users only: KDE 4.10 is coming
« Reply #44 on: 2013/04/05, 07:11:03 »
@lanzi: agaida meint:
alle qtcurve Pakete weghauen und durch gtk2-engines-oxygen ersetzen