seduction
 Language:
Welcome, Guest. Please login or register.
Did you miss your activation email?
2020/09/19, 20:49:47


Help

Author [EN] [PL] [ES] [PT] [IT] [DE] [FR] [NL] [TR] [SR] [AR] [RU] Topic: kdenext-repo-users only: KDE 4.10 is coming  (Read 16720 times)

0 Members and 1 Guest are viewing this topic.

Offline der_bud

  • User
  • Posts: 944
  • member
kdenext-repo-users only: KDE 4.10 is coming
« on: 2013/04/02, 08:44:13 »
This will possibly not hit plain siduction, only the early adopters with KDE 4.9 who have siduction.org/kdenext enabled [1]: KDE 4.10.1 is coming in as an easter egg, nice  :lol:

Watch out for what is being removed and what will be reinstalled, D-U this morning had a lot to tell (http://paste.siduction.org/20130402063006). Care for your productive systems, test in VM or such. More info from team as well as release-announcement will come, I am sure. Thank you, team and santa.

---
[1] kdenext enabled like: http://news.siduction.org/2013/01/winterwonderland/
Du lachst? Wieso lachst du? Das ist doch oft so, Leute lachen erst und dann sind sie tot.

Offline devil

  • Administrator
  • User
  • *****
  • Posts: 4.436

Offline michaa7

  • User
  • Posts: 2.128
RE: kdenext-repo-users only: KDE 4.10 is coming
« Reply #2 on: 2013/04/02, 15:48:00 »
There
http://news.siduction.org/2013/04/kde-sc-4-10-1-packages-for-siduction-and-debian/
seems to be a wrong entry:

Quote
...
Besides KDE SC 4.10.1 we also have a fresh Razor-Qt 5.2 in our repo. For that you need

deb http://packages.siduction.org/razorqt unstable.org

in your sources.list.



I assume thisone is right:
Quote
deb http://packages.siduction.org/razorqt unstable main
Ok, you can't code, but you still might be able to write a bug report for Debian's sake

Offline moonwalker

  • Newbie
  • Posts: 1
RE: kdenext-repo-users only: KDE 4.10 is coming
« Reply #3 on: 2013/04/02, 16:53:13 »
There is a bug in the packages in repo causing suspend and hibernate options to disappear from power management. Here (http://forum.kde.org/viewtopic.php?f=66&t=110296) is a bit more info. Fix exists already, I assume updated package just needs to be rebuilt and uploaded to siduction repo by it's maintainer.

Offline Mte90

  • User
  • Posts: 149
  • KDE & Debian lover
    • http://www.mte90.net
RE: kdenext-repo-users only: KDE 4.10 is coming
« Reply #4 on: 2013/04/02, 16:53:18 »
In kate missing the support for pate...
http://kate-editor.org/2012/06/26/extending-kate-with-pytho/
i have read that for enable it's need to uncomment a row on the cmakelist.txt.

I have installed and i have no problem :-P

Offline dibl

  • siduction community member
  • Global Moderator
  • User
  • *****
  • Posts: 2.033
    • Land of the Buckeye
RE: kdenext-repo-users only: KDE 4.10 is coming
« Reply #5 on: 2013/04/02, 22:04:39 »
On my desktop system my usual KDE bits (dolphin, kate, etc.) seem fine in the new version.  Strangely, of all things, alsaplayer has suddenly stopped working -- it worked yesterday just before the KDE upgrade, and now won't go from krunner or in terminal, and shows no error output.  I can't imagine why that would be related to a KDE upgrade, but .... there you have it.


EDIT: On the positive side, Bangarang has stopped crashing, so that's a player alternative now.

EDIT #2: Never mind about alsaplayer -- a zombie alsaplayer process from 2 days ago was preventing it running.  Killed the zombie, and problem solved.
Asus ROG STRIX X299-E, Core i7-7740X, Nvidia GTX-1060, dual monitors, SSD 860 EVO, 2@WD1003FZEX in BTRFS

Offline clubex

  • User
  • Posts: 265
RE: kdenext-repo-users only: KDE 4.10 is coming
« Reply #6 on: 2013/04/02, 23:35:52 »
Initially the du produced a white screen with a movable cursor; nothing else. Couldn't even configure anything on the desktop. Luckily purging the .kde cache solved that.

So apart from that the du went OK.
Code: [Select]

#inxi
CPU~Dual core AMD Athlon II X2 240 (-MCP-) clocked at 2812.835 Mhz Kernel~3.8-5.towo-siduction-amd64 x86_64 Up~1:26 Mem~1284.1/3959.9MB HDD~250.1GB(46.5% used) Procs~133 Client~Shell inxi~1.8.4

Offline agaida

  • User
  • Posts: 1.760
    • http://g-com.eu
Re: RE: kdenext-repo-users only: KDE 4.10 is coming
« Reply #7 on: 2013/04/03, 00:25:58 »
Quote from: "michaa7"

Besides KDE SC 4.10.1 we also have a fresh Razor-Qt 5.2 in our repo. For that you need

deb http://packages.siduction.org/razorqt unstable.org


Give this line a chance:
Code: [Select]

deb http://packages.siduction.org/razorqt unstable main
There's this special biologist word we use for "stable". It's "dead". ~ Jack Cohen

Offline michaa7

  • User
  • Posts: 2.128
Re: RE: kdenext-repo-users only: KDE 4.10 is coming
« Reply #8 on: 2013/04/03, 00:48:13 »
That's *exactly* what I wrote above. But you didn't care to notice ...
Ok, you can't code, but you still might be able to write a bug report for Debian's sake

Offline agaida

  • User
  • Posts: 1.760
    • http://g-com.eu
Re: RE: kdenext-repo-users only: KDE 4.10 is coming
« Reply #9 on: 2013/04/03, 02:04:57 »
some browser or cache fault, i think - dont have the second part of your post, only the cite of devils news entry. and yes, your line is absolutely right, sorry for the noise.
There's this special biologist word we use for "stable". It's "dead". ~ Jack Cohen

Offline DeepDayze

  • User
  • Posts: 413
RE: Re: RE: kdenext-repo-users only: KDE 4.10 is coming
« Reply #10 on: 2013/04/03, 02:15:49 »
Sounds good, let me know when its safe to switch from 4.9.5 (which I got from kde-qt repo) to 4.10.1

If all the bugs in the packages as reported above are fixed put up an update for us as well :)

Should I also delete/rename the .kde folder before upgrading?

Offline agaida

  • User
  • Posts: 1.760
    • http://g-com.eu
RE: Re: RE: kdenext-repo-users only: KDE 4.10 is coming
« Reply #11 on: 2013/04/03, 02:17:49 »
works for me™ - but if you have objections, you should wait for two or three days :)
There's this special biologist word we use for "stable". It's "dead". ~ Jack Cohen

Offline DeepDayze

  • User
  • Posts: 413
RE: Re: RE: kdenext-repo-users only: KDE 4.10 is coming
« Reply #12 on: 2013/04/03, 02:26:03 »
OK I did add kdenext to my sources.list d and did a test to see what gets installed/removed:

Code: [Select]

~# apt-get dist-upgrade
Reading package lists... Done
Building dependency tree      
Reading state information... Done
Calculating upgrade... Done
The following packages will be REMOVED:
  libnepomuksync4
The following NEW packages will be installed:
  libkactivities-models1 libnepomukwidgets4 libxcb-damage0
The following packages will be upgraded:
  dolphin freespacenotifier kate kate-data katepart kde-baseapps kde-baseapps-bin kde-baseapps-data kde-plasma-desktop kde-runtime kde-runtime-data kde-standard kde-style-oxygen kde-wallpapers kde-wallpapers-default kde-window-manager
  kde-workspace kde-workspace-bin kde-workspace-data kde-workspace-kgreet-plugins kdeartwork kdeartwork-emoticons kdeartwork-style kdeartwork-theme-window kdebase-runtime kdebase-workspace-bin kdeedu kdegraphics kdelibs-bin
  kdelibs5-data kdelibs5-plugins kdepasswd kdepimlibs-kio-plugins kdeplasma-addons kdeutils kdewallpapers kdm kdoctools kfind khelpcenter4 kinfocenter klipper kmenuedit konq-plugins konqueror konsole kscreensaver ksysguard ksysguardd
  ktouch ktouch-data kwrite libakonadi-contact4 libakonadi-kabc4 libakonadi-kcal4 libakonadi-kde4 libakonadi-kmime4 libavogadro1 libdlrestrictions1 libgpgme++2 libkabc4 libkactivities-bin libkactivities6 libkateinterfaces4
  libkatepartinterfaces4 libkblog4 libkcal4 libkcalcore4 libkcalutils4 libkcmutils4 libkde3support4 libkdeclarative5 libkdecorations4abi1 libkdecore5 libkdesu5 libkdeui5 libkdewebkit5 libkdnssd4 libkemoticons4 libkephal4abi1 libkfile4
  libkholidays4 libkhtml5 libkidletime4 libkimap4 libkimproxy4 libkio5 libkjsapi4 libkjsembed4 libkldap4 libkmediaplayer4 libkmime4 libknewstuff2-4 libknewstuff3-4 libknotifyconfig4 libkntlm4 libkonq-common libkonq5-templates
  libkonq5abi1 libkonqsidebarplugin4a libkontactinterface4 libkparts4 libkpimidentities4 libkpimtextedit4 libkpimutils4 libkprintutils4 libkpty4 libkresources4 libkrosscore4 libkrossui4 libkscreensaver5 libksgrd4 libksignalplotter4
  libktexteditor4 libktnef4 libkunitconversion4 libkutils4 libkwineffects1abi4 libkwinglutils1abi1 libkworkspace4abi2 libkxmlrpcclient4 libmailtransport4 libmicroblog4 libnepomuk4 libnepomukcore4 libnepomukquery4a libnepomukutils4
  libplasma-geolocation-interface4 libplasma3 libplasmaclock4abi3 libplasmagenericshell4 libprocesscore4abi1 libprocessui4a libqgpgme1 libsolid4 libsolidcontrol4abi2 libsolidcontrolifaces4abi2 libsoprano4 libsyndication4
  libtaskmanager4abi3 libthreadweaver4 libweather-ion6 nepomuk-core-data nepomuk-core-runtime oxygen-icon-theme plasma-containments-addons plasma-dataengines-addons plasma-dataengines-workspace plasma-desktop
  plasma-desktopthemes-artwork plasma-runners-addons plasma-scriptengine-javascript plasma-scriptengine-python plasma-wallpapers-addons plasma-widget-folderview plasma-widget-lancelot plasma-widgets-addons plasma-widgets-workspace
  python-kde4 python-qt4 python-qt4-dbus python-sip rekonq soprano-daemon systemsettings
165 upgraded, 3 newly installed, 1 to remove and 0 not upgraded.
Need to get 321 MB of archives.
After this operation, 15.9 MB of additional disk space will be used.
Do you want to continue [Y/n]?


One thing I saw was libnepomuksync4 is to be removed...is it OK to let this package go?

Offline agaida

  • User
  • Posts: 1.760
    • http://g-com.eu
RE: Re: RE: kdenext-repo-users only: KDE 4.10 is coming
« Reply #13 on: 2013/04/03, 03:02:20 »
yes, that library was removed upstream
There's this special biologist word we use for "stable". It's "dead". ~ Jack Cohen

Offline DeepDayze

  • User
  • Posts: 413
Re: RE: Re: RE: kdenext-repo-users only: KDE 4.10 is coming
« Reply #14 on: 2013/04/03, 04:24:08 »
Quote from: "agaida"
yes, that library was removed upstream


OK great, thanks