seduction
 Language:
Welcome, Guest. Please login or register.
Did you miss your activation email?
2020/02/20, 23:47:09


Help

Author [EN] [PL] [ES] [PT] [IT] [DE] [FR] [NL] [TR] [SR] [AR] [RU] Topic: New KDE software in kdenext  (Read 10057 times)

0 Members and 1 Guest are viewing this topic.

Offline Santa

  • User
  • Posts: 261
  • siduction's KDE packager
New KDE software in kdenext
« on: 2015/10/01, 17:35:44 »
Hi,


after the debian's switch to GCC 5 kdenext was updated today providing new KDE packages. So right now there is:


KDE Frameworks 5.14
Plasma 5.4.1
KDE Applications 15.08.1 (except for kdepim which is 4.14.x, previous one was 4.4.x)


So, assuming you have kdenext in your sources.list:


What is suposed to work out of the box:
1) dist-upgrading with apt (not aptitude) from a siduction KDE with kdenext last upgraded before July 31 2015 (date of the debian/ubuntu switch to GCC 5)
2) dist-upgrading with apt (not aptitude) a fresh new indiansummer installation following the instructions https://community.kde.org/Plasma/InstallingNext#siduction


What is, probably, NOT going to work out of the box:
3) dist-upgrading now from a siduction KDE last upgraded after July 31 (date of the debian/ubuntu switch to GCC 5)


What is NOT going to work:
4) dist-upgrading with aptitude from a siduction KDE last upgraded after July 31 (date of the debian/ubuntu switch to GCC 5). The reason for this is that after the GCC 5 transition many package libraries had to be renamed from libfooX to libfooXv5 where libfooXv5 conflicts with libfooXv5 because they share the same files (example https://packages.qa.debian.org/x/xapian-core/news/20150802T172039Z.html). This is a very undesirable situation because it confuses package managers (they have problems to figure out that libfooXv5 is a replacement for libfooX). It was feasible to tweak some packages to make it work properly with apt, but not feasible for aptitude.


So if you find issues or have doubts please post:
  • Here if you are in case 1) 2) and 3) for KDE issues not related to kdepim
  • In this other thread if you are in case 1) 2) and 3) and you have issues specific of kdepim (http://forum.siduction.org/index.php?topic=5800.0)
  • For the case 4) just use apt this time. You can continue to use aptitude if you like it more after dist-upgrading today. However remember that apt is the recommended package manager for siduction.
If you are in other case such as not having kdenext in your sources.list please post somewhere else. As a friendly reminder, we have subforums for software support:
http://forum.siduction.org/index.php?board=61.0
and experiments (such as doing things not actually supported):
http://forum.siduction.org/index.php?board=57.0
« Last Edit: 2015/10/03, 22:57:36 by Santa »
Sometimes standing for what you believe means standing alone.

Offline Mte90

  • User
  • Posts: 144
  • KDE & Debian lover
    • http://www.mte90.net
Re: New KDE software in kdenext
« Reply #1 on: 2015/10/01, 19:01:54 »
I am in 4 case and I can see that with the update of some packages like: libakonadi-kde4, libsyndication4 or soprano-daemon, libstreamanalyzer0v5, apt ask to remove many package of kde.
« Last Edit: 2015/10/01, 19:06:03 by Mte90 »

Offline jure

  • User
  • Posts: 520
Re: New KDE software in kdenext
« Reply #2 on: 2015/10/01, 19:16:50 »
Hi Santa,

I don`t know what happens in the last two day`s, but today here many packages would be removed - with and without kdenext. My system is siduction "Riders on the storm" kde-full upgraded to plasma 5 in june/juli - last apt-get dist-upgrade was on 30.07.2015 - works without problems

apt-get dist-upgrade -s :

29.09.15 with kdenext
1348 aktualisiert, 164 neu installiert, 139 zu entfernen und 19 nicht aktualisiert

01.10.15 with kdenext
898 aktualisiert, 48 neu installiert, 684 zu entfernen und 162 nicht aktualisiert

01.10.15 without kdenext
904 aktualisiert, 43 neu installiert, 659 zu entfernen und 161 nicht aktualisiert


thx for your work !

edit:
Quote
apt-cache policy kdepim
kdepim:
  Installiert:           4:4.14.5+really4.4.11.1+l10n-0r2.1
  Installationskandidat: 4:4.14.10-2
  Versionstabelle:
     4:4.14.10-2 0
        500 http://http.debian.net/debian/ unstable/main amd64 Packages
« Last Edit: 2015/10/01, 20:10:14 by jure »
Gruss Juergen

Offline clubex

  • User
  • Posts: 265
Re: New KDE software in kdenext
« Reply #3 on: 2015/10/01, 20:36:48 »
All seemed to go well during the dist-upgrade. Except for a grave bug report for kwin and I had to do one -f install. I stopped sddm and shifted to multi-user.target to do the upgrade.

So far I haven't unearthed any problem while using KDE since the upgrade. I haven't shutdown and rebooted yet; so fingers crossed!

I'm in the 3) camp due to a reinstallation, dist-upgrade a few days ago. The installation was due in large part because something in a systemd upgrade left my beloved very, very old installation in too much of a mess.

Edit: Forget to offer my thanks to Santa.
« Last Edit: 2015/10/01, 22:20:48 by clubex »

Offline ayla

  • User
  • Posts: 1.697
Re: New KDE software in kdenext
« Reply #4 on: 2015/10/01, 21:02:39 »
Hi,

did the d-u right now, I was in 3), dist-upgraded 31. of Juli the last time, kde-next enabled.

Half of my system was gone after d-u,  had to manually purge  a few libs and apps and then reinstall dolphin, kamil and kde-standard.

After that my system is working again, all settings kept, just lost my emails :(

To say it clear: This was my own fault, I d-u-ed two days after Santas warning.

Thanks for your work Santa, my system is in a far better condition as the one I updated without the kde-next repo.

here is my history.log and dpkg.log for those who have a similar situation. hth.

http://paste.siduction.org/20151001184607
http://paste.siduction.org/20151001185356

Greets
ayla
« Last Edit: 2015/10/01, 21:05:43 by ayla »
Kernel: 4.18.11-towo.1-siduction-amd64 x86_64
Desktop: KDE Plasma 5.13.5
(mostly) kept current siduction "18.3.0 Patience"
HP EliteBook 8570p; MoBo: HP model: 17A7 v: KBC Version 42.35
Dual core  i5-3320M (-MT-MCP-)
Intel 3. Gen Graphics (Ivybridge) Driver:i915/ intel
 Wifi Intel Centrino N6205

Offline ghstryder

  • User
  • Posts: 84
Re: New KDE software in kdenext
« Reply #5 on: 2015/10/01, 22:05:16 »
This is the way things look here today. Thanks to everyone involved.

Code: [Select]
# apt-get dist-upgrade
Reading package lists... Done
Building dependency tree       
Reading state information... Done
Calculating upgrade... Done
The following packages have been kept back:
  cpp-5 gcc-5-base libatomic1 libcilkrts5 libgcc1 libgfortran3 libgomp1 libitm1 liblsan0 libquadmath0 libstdc++6
  libtsan0 libubsan0
0 upgraded, 0 newly installed, 0 to remove and 13 not upgraded.
LibreOffice is at 5.0.2.2. The only thing I have not been able to get back (that I have noticed) is Yakuake due to a couple of dependencies, and that is hardly an emergency.

This was a fresh install of Indian Summer in mid-July with kde-next enabled.

Offline Lanzi

  • User
  • Posts: 1.622
Re: New KDE software in kdenext
« Reply #6 on: 2015/10/01, 22:08:26 »
As always Thanks a llot Santa.
You are doing a great job!

I am still waiting... Last DU 20th of July.
Maybe I should wait a little longer... Lets see :-D


Offline gabrielb

  • User
  • Posts: 33
Re: New KDE software in kdenext
« Reply #7 on: 2015/10/01, 22:13:05 »
Hi,

did a du a few minutes ago, on a system in state 1)+a few packages installed in the meantime.

All in all du went very smooth, but a few packages had to go (e.g. plasma-widgets-workspace, kile).

Some packages

Code: [Select]
libksgrd4 libkworkspace4abi2 libplasma-geolocation-interface4 libplasmaclock4abi4 libplasmagenericshell4 libprocesscore4abi1 libprocessui4a libtaskmanager4abi4 libweather-ion6 plasma-dataengines-workspace
are newer in sid than in kde-next, so i managed to get them back by "downgrading" to kde-next.

But kile seems to be gone, for now, because

Code: [Select]
libnepomuk4 libnepomukutils4 libnepomukquery4a
are not installable, as they depend on a non-existant version (=4:4.14.3-siduction1) of

Code: [Select]
libkdecore5 libkdeui5
(4:4.14.12-siduction1.2.1 available)

Everything else seems to be working, i guess.
Thanks for your hard work, Santa!

holgerw

  • Guest
Re: New KDE software in kdenext
« Reply #8 on: 2015/10/02, 06:44:49 »
Hello,

nice to have a repo with current kf5 and plasma5 stuff. I'll try following:
1. Installing last nox iso / or xorg iso without further de stuff
2. adding kdenext repo
3. Installing kde-standard and additional stuff.

Prefering to kdepim stuff: I'm lucky with very fast and also full featured claws mail but okay, I'll give kdepim another try for comparing with claws mail.

I'll give feedback how kf5 works.

Kind regards,
  Holger

Offline gabrielb

  • User
  • Posts: 33
Re: New KDE software in kdenext
« Reply #9 on: 2015/10/02, 10:01:01 »
kile came back today. Thanks :)

Offline der_bud

  • User
  • Posts: 901
  • member
Re: New KDE software in kdenext
« Reply #10 on: 2015/10/02, 14:20:27 »
@Mte90, @jure: you mentioned several packages to be removed. That is kind of expected, because
after the GCC 5 transition many package libraries had to be renamed from libfooX to libfooXv5
Please take a closer look on apt output if the ones to be removed have canditates in the newly installed section with similar names +v5. (And additionally, perhaps some packages might be completely obsolete now).

For me all went well with a system mostly being case 1)  with a bit of 3) : a kdenext already on KF5/Plasma5, stopped DU around 29th july, but tried updating some stuff with help of aptitude's solver which worked somehow but left the system in a state I was not really sure about. I expected a real mess today, but there was only one error around kactivities-stuff, got solved by 'dpkg --configure -a' followed by 'apt-get install -f'. System up-to-date now. So in case what Santa called "probably not going to work out of the box" I was lucky ;)
Du lachst? Wieso lachst du? Das ist doch oft so, Leute lachen erst und dann sind sie tot.

Offline Santa

  • User
  • Posts: 261
  • siduction's KDE packager
Re: New KDE software in kdenext
« Reply #11 on: 2015/10/02, 15:44:17 »
Hi, first of all:


Indeed there was a small issue preventing yakuake and kile from being installed, this was fixed yesterday in the night by a kdelibs update. Thanks for noticing.


Regarding people in the situation 3) I plan to work on some things to make the dist-upgrade work a bit more out of the box, so if you are in this situation you might want to hold the dist-upgrade a few days to get something smoother.


All in all du went very smooth, but a few packages had to go (e.g. plasma-widgets-workspace, kile).

Some packages

Code: [Select]
libksgrd4 libkworkspace4abi2 libplasma-geolocation-interface4 libplasmaclock4abi4 libplasmagenericshell4 libprocesscore4abi1 libprocessui4a libtaskmanager4abi4 libweather-ion6 plasma-dataengines-workspace
are newer in sid than in kde-next, so i managed to get them back by "downgrading" to kde-next.


In general, when the package manager wants to remove lib* packages it's ok because:
a) the programs you have installed don't use it anymore
b) the library is replaced by a newer version (e.g. apt wants to remove libwhatever4 while at the same time libwhatever5 is installed)


Regarding the libraries you have mentioned, they fit in a), they are from the previous version of plasma from KDE SC 4 (obsolete).


At this point the only doubt would be plasma-dataengines-workspace, but this package is from KDE SC 4 too.


So, except for kile, which is fixed now, you can safely remove all those lib* packages and plasma-dataengines-workspace, you won't lose anything in your plasma 5 desktop.

Prefering to kdepim stuff: I'm lucky with very fast and also full featured claws mail but okay, I'll give kdepim another try for comparing with claws mail.


Regarding kdepim keep in mind than the one right now in debian sid and siduction is still based on kdelibs 4 and at some point (probably in the next few months) it would be replaced by the newer one based on KDE Frameworks. Thanks as allways for your valuable feedback.


@Mte90, @jure: you mentioned several packages to be removed. That is kind of expected, because
after the GCC 5 transition many package libraries had to be renamed from libfooX to libfooXv5
Please take a closer look on apt output if the ones to be removed have canditates in the newly installed section with similar names +v5. (And additionally, perhaps some packages might be completely obsolete now).


Regarding this, Mte90's case seems like something expected while jure's seems to have been experiencing a temporary problem. Could you please both paste the output of apt-get dist-upgrade? (so we can check if you are hitting a problem or not)
Sometimes standing for what you believe means standing alone.

Offline Mte90

  • User
  • Posts: 144
  • KDE & Debian lover
    • http://www.mte90.net
Re: New KDE software in kdenext
« Reply #12 on: 2015/10/02, 16:02:28 »
Code: [Select]
apt-get install libplasma3=4:4.14.12-siduction1.3.1 libkio5=4:4.14.12-siduction1.3.1 libstreamanalyzer0v5 libstreams0v5[code]
With that command and remove of plasma-dataengines-workspace now the upgrade have no problem (also with the remove) and i can install other 70 packages but i have other many packages.

[code]
root@siduction:/home/mte90# apt-get dist-upgrade
Lettura elenco dei pacchetti... Fatto
Generazione albero delle dipendenze       
Lettura informazioni sullo stato... Fatto
Calcolo dell'aggiornamento... Fatto
I seguenti pacchetti saranno RIMOSSI:
  digikam-private-libs gimp kscreensaver libakonadi-dev libboost-atomic1.55-dev libboost-chrono1.55-dev libboost-context1.55-dev libboost-coroutine1.55-dev libboost-dev
  libboost-filesystem1.55-dev libboost-serialization1.55-dev libboost-system1.55-dev libboost1.55-dev libgegl-0.2-0 libgimp2.0 libgstreamer0.10-dev libhighgui2.3
  libicu-dev libkexiv2-11 libkgeomap2 libmagickcore5-extra libmarblewidget21 libopencv-calib3d2.3 libopencv-contrib2.3 libopencv-features2d2.3 libopencv-highgui2.3
  libopencv-legacy2.3 libopencv-objdetect2.3 libopenexr6 libopenimageio1.2 libopenimageio1.3 libopenimageio1.4 libopenimageio1.5 libsmokebase3 libsmokeqtwebkit4-3
  libxml2-dev libxslt1-dev plasma-scriptengine-ruby plasma-scriptengines ruby-kde4 ruby-plasma ruby-qt4-webkit sane xsane
I seguenti pacchetti NUOVI saranno installati:
  libde265-0 libkexiv2-11v5 libkvkontakte1 libmediawiki1 libopencv-calib3d2.4v5 libopencv-contrib2.4v5 libopencv-features2d2.4v5 libopencv-gpu2.4v5 libopencv-highgui2.4v5
  libopencv-legacy2.4v5 libopencv-objdetect2.4v5 libopencv-ocl2.4v5 libopencv-stitching2.4v5 libopencv-superres2.4v5 libopencv-ts2.4v5 libopencv-videostab2.4v5
  libopenexr6v5 libsmokebase3v5
I seguenti pacchetti sono stati mantenuti alla versione attuale:
  cpp-5 g++-5 gcc-5 gcc-5-base gcc-5-base:i386 libasan2 libatomic1 libcc1-0 libcilkrts5 libcrypto++-dev libgcc-5-dev libgcc1 libgcc1:i386 libgfortran3 libgomp1
  libgomp1:i386 libitm1 liblsan0 libmpx0 libquadmath0 libstdc++-5-dev libstdc++6 libstdc++6:i386 libtsan0 libubsan0
I seguenti pacchetti saranno aggiornati:
  digikam digikam-data frei0r-plugins gmic-zart gstreamer1.0-plugins-bad kde-runtime kdegraphics-thumbnailers kipi-plugins kipi-plugins-common libastro1
  libgstreamer-plugins-bad1.0-0 libmagickcore-6.q16-2-extra libokularcore6 libopencv-calib3d2.4 libopencv-contrib2.4 libopencv-core2.4 libopencv-features2d2.4
  libopencv-flann2.4 libopencv-gpu2.4 libopencv-highgui2.4 libopencv-imgproc2.4 libopencv-legacy2.4 libopencv-ml2.4 libopencv-objdetect2.4 libopencv-ocl2.4
  libopencv-photo2.4 libopencv-stitching2.4 libopencv-superres2.4 libopencv-ts2.4 libopencv-video2.4 libopencv-videostab2.4 libopencv2.4-java libopencv2.4-jni
  libopenexr-dev libqtruby4shared2 libsmokekdecore4-3 libsmokekdeui4-3 libsmokekfile3 libsmokekhtml3 libsmokekio3 libsmokeknewstuff2-3 libsmokeknewstuff3-3
  libsmokekparts3 libsmokektexteditor3 libsmokekutils3 libsmokenepomuk3 libsmokeplasma3 libsmokeqtcore4-3 libsmokeqtdbus4-3 libsmokeqtgui4-3 libsmokeqtnetwork4-3
  libsmokeqtopengl4-3 libsmokeqtsql4-3 libsmokeqtsvg4-3 libsmokeqtxml4-3 libsmokesolid3 okular plasma-scriptengine-javascript ruby-qt4
59 aggiornati, 18 installati, 44 da rimuovere e 25 non aggiornati.
È necessario scaricare 44,0 MB di archivi.
Dopo quest'operazione, verranno liberati 217 MB di spazio su disco.

Offline Santa

  • User
  • Posts: 261
  • siduction's KDE packager
Re: New KDE software in kdenext
« Reply #13 on: 2015/10/02, 16:29:54 »

Hi Mte90,

Code: [Select]
apt-get install libplasma3=4:4.14.12-siduction1.3.1 libkio5=4:4.14.12-siduction1.3.1 libstreamanalyzer0v5 libstreams0v5[code]
With that command and remove of plasma-dataengines-workspace now the upgrade have no problem (also with the remove) and i can install other 70 packages but i have other many packages.

[code]
root@siduction:/home/mte90# apt-get dist-upgrade
Lettura elenco dei pacchetti... Fatto
Generazione albero delle dipendenze       
Lettura informazioni sullo stato... Fatto
Calcolo dell'aggiornamento... Fatto
I seguenti pacchetti saranno RIMOSSI:
  digikam-private-libs gimp kscreensaver libakonadi-dev libboost-atomic1.55-dev libboost-chrono1.55-dev libboost-context1.55-dev libboost-coroutine1.55-dev libboost-dev
  libboost-filesystem1.55-dev libboost-serialization1.55-dev libboost-system1.55-dev libboost1.55-dev libgegl-0.2-0 libgimp2.0 libgstreamer0.10-dev libhighgui2.3
  libicu-dev libkexiv2-11 libkgeomap2 libmagickcore5-extra libmarblewidget21 libopencv-calib3d2.3 libopencv-contrib2.3 libopencv-features2d2.3 libopencv-highgui2.3
  libopencv-legacy2.3 libopencv-objdetect2.3 libopenexr6 libopenimageio1.2 libopenimageio1.3 libopenimageio1.4 libopenimageio1.5 libsmokebase3 libsmokeqtwebkit4-3
  libxml2-dev libxslt1-dev plasma-scriptengine-ruby plasma-scriptengines ruby-kde4 ruby-plasma ruby-qt4-webkit sane xsane
I seguenti pacchetti NUOVI saranno installati:
  libde265-0 libkexiv2-11v5 libkvkontakte1 libmediawiki1 libopencv-calib3d2.4v5 libopencv-contrib2.4v5 libopencv-features2d2.4v5 libopencv-gpu2.4v5 libopencv-highgui2.4v5
  libopencv-legacy2.4v5 libopencv-objdetect2.4v5 libopencv-ocl2.4v5 libopencv-stitching2.4v5 libopencv-superres2.4v5 libopencv-ts2.4v5 libopencv-videostab2.4v5
  libopenexr6v5 libsmokebase3v5
I seguenti pacchetti sono stati mantenuti alla versione attuale:
  cpp-5 g++-5 gcc-5 gcc-5-base gcc-5-base:i386 libasan2 libatomic1 libcc1-0 libcilkrts5 libcrypto++-dev libgcc-5-dev libgcc1 libgcc1:i386 libgfortran3 libgomp1
  libgomp1:i386 libitm1 liblsan0 libmpx0 libquadmath0 libstdc++-5-dev libstdc++6 libstdc++6:i386 libtsan0 libubsan0
I seguenti pacchetti saranno aggiornati:
  digikam digikam-data frei0r-plugins gmic-zart gstreamer1.0-plugins-bad kde-runtime kdegraphics-thumbnailers kipi-plugins kipi-plugins-common libastro1
  libgstreamer-plugins-bad1.0-0 libmagickcore-6.q16-2-extra libokularcore6 libopencv-calib3d2.4 libopencv-contrib2.4 libopencv-core2.4 libopencv-features2d2.4
  libopencv-flann2.4 libopencv-gpu2.4 libopencv-highgui2.4 libopencv-imgproc2.4 libopencv-legacy2.4 libopencv-ml2.4 libopencv-objdetect2.4 libopencv-ocl2.4
  libopencv-photo2.4 libopencv-stitching2.4 libopencv-superres2.4 libopencv-ts2.4 libopencv-video2.4 libopencv-videostab2.4 libopencv2.4-java libopencv2.4-jni
  libopenexr-dev libqtruby4shared2 libsmokekdecore4-3 libsmokekdeui4-3 libsmokekfile3 libsmokekhtml3 libsmokekio3 libsmokeknewstuff2-3 libsmokeknewstuff3-3
  libsmokekparts3 libsmokektexteditor3 libsmokekutils3 libsmokenepomuk3 libsmokeplasma3 libsmokeqtcore4-3 libsmokeqtdbus4-3 libsmokeqtgui4-3 libsmokeqtnetwork4-3
  libsmokeqtopengl4-3 libsmokeqtsql4-3 libsmokeqtsvg4-3 libsmokeqtxml4-3 libsmokesolid3 okular plasma-scriptengine-javascript ruby-qt4
59 aggiornati, 18 installati, 44 da rimuovere e 25 non aggiornati.
È necessario scaricare 44,0 MB di archivi.
Dopo quest'operazione, verranno liberati 217 MB di spazio su disco.


So, for your case I'm seeing 2 problems (not related to kde and therefore "out of my jurisdiction"):
1. gimp being removed
2. libstdc++6 and others on hold


Probably this happens because you have libstdc++6 installed with multiarch both for amd64 and i386. When you have a library installed that way it's usually required to have the exact same version for both architectures (at least for ) so when a new version is uploaded to sid the dist-upgrade won't work properly until it's built for both architectures. The libstdc++6 package is built from the gcc-5 source package, and as you can see here:
https://buildd.debian.org/status/package.php?p=gcc-5&suite=unstable
the package is being built for i386 while I'm writing this post (the status will change with time obviously).


Also if you type "apt-cache policy libstdc++6:amd64" and "apt-cache policy libstdc++6:i386" I presume you will get different versions.


So, recommended way of proceeding: do "apt-get update" from time to time and when "apt-cache policy libstdc++6:amd64" and "apt-cache policy libstdc++6:i386" report the exact same version try to dist-upgrade again. Probably it will work fine, but if it doesn't feel free to post here again (even while this is not KDE specific problem).


Regards.
Sometimes standing for what you believe means standing alone.

Offline Mte90

  • User
  • Posts: 144
  • KDE & Debian lover
    • http://www.mte90.net
Re: New KDE software in kdenext
« Reply #14 on: 2015/10/02, 16:31:56 »
perfect thanks for the suggestions!