seduction
 Language:
Welcome, Guest. Please login or register.
Did you miss your activation email?
2020/04/09, 20:39:22


Help

Author [EN] [PL] [ES] [PT] [IT] [DE] [FR] [NL] [TR] [SR] [AR] [RU] Topic: New KDE software in kdenext  (Read 10207 times)

0 Members and 1 Guest are viewing this topic.

Offline jure

  • User
  • Posts: 520
Re: New KDE software in kdenext
« Reply #15 on: 2015/10/02, 16:46:52 »
Hi

I attached the output of apt-get dist-upgrade from 14:30 UTC
2 days ago "164 new installed, 139 removed" and today "48 new installed, 677 removed"
Gruss Juergen

Offline Santa

  • User
  • Posts: 261
  • siduction's KDE packager
Re: New KDE software in kdenext
« Reply #16 on: 2015/10/02, 17:02:12 »

Hi jure,

Hi

I attached the output of apt-get dist-upgrade from 14:30 UTC
2 days ago "164 new installed, 139 removed" and today "48 new installed, 677 removed"


So you have libtsc++6 installed both for amd64 and i386 too; my advice is the same I gave Mte90:  do "apt-get update" from time to time and when "apt-cache policy libstdc++6:amd64" and "apt-cache policy libstdc++6:i386" report the exact same version try to dist-upgrade again. If you have further issues after that, please post again so we can find out if there are further problems beyond libstdc++6 not being built yet for i386.
Sometimes standing for what you believe means standing alone.

Offline gypsy56

  • User
  • Posts: 34
Re: New KDE software in kdenext
« Reply #17 on: 2015/10/02, 17:17:13 »
I made a dist-upgrade and the most works fine but if I shut down I have a black screeen and nothing goes. So I must go to a tty and make there a shutdown. Do I miss a packet in kde?

Offline melmarker

  • Global Moderator
  • User
  • *****
  • Posts: 2.800
    • g-com.eu
Re: New KDE software in kdenext
« Reply #18 on: 2015/10/02, 19:24:57 »
in addition to Santa i would suggest to think about multiarch et al. Do you really need multiarch or i386 based programms in this installation - can the same or sufficient functionality be archived with a vm? if so, i would suggest a virtual machine with the needed programs - in my case it was only teamviewer what i need to support others - o.k. i use a win10 vm for that - skype would be another item - but i use a different machine for that right now or my cell phone directly :).

After these descisions i now have a i386-free main installation which is pure fun as i only has to watch out for the 'normal' transition things 8)
Those who would give up essential Liberty, to purchase a little temporary Safety, deserve neither Liberty nor Safety. (Benjamin Franklin, November 11, 1755)
Never attribute to malice that which can be adequately explained by stupidity. (Hanlons razor)

Offline domicius

  • User
  • Posts: 35
    • My personal ramblings
Re: New KDE software in kdenext
« Reply #19 on: 2015/10/03, 08:25:40 »
Oh, my. I mistakenly did the unsupported "apt-get upgrade" - I misread some of the last posts here mentioning "apt-get update" while on my smartphone, tried issuing that command and everything seemed OK, so I went with it. It occurred to me only after things were installing already that I remember reading something on this forum regarding "apt-get upgrade"...  :-\

The reason I didn't simply go with dist-upgrade was that it wanted to remove a lot of stuff like plasma-desktop, kde-workspace, dolphin and a bunch of other kde stuff, along with apps like ardour, audacity, vlc, inkscape etc.

And I think I should be under case 1) as I didn't do a DU after July 29, but I did do a couple of selected manual upgrades like "apt-get install linux-image..." and also some system stuff like mesa libs, even of some kf5 stuff etc.

So I'm not sure if what I'm experiencing is due to any of what I did (wrong), as I explained above, but here are my experiences trying to DU this system.

After apt-get upgrade, there were still some, albeit less stuff that DU would remove, so I selectively did some installs that didn't seem to remove half of my system at once, only some libs that were replaced.

At the end, I got "stuck" with libtag: I couldn't install libtag1v5 without first manually removing libtag1c2a which took most of the KDE with it (at that point I went with it, because I couldn't start KDE anymore anyway), but I reinstalled most of it back with kde-standard, bringing back the rest manually.

One of the packages I had to reinstall manually was kscreen and that gave me problems until I figured out which package is causing it and removed it. With kscreen installed, I'd get a black screen after logging in (either on dock, connected with an external monitor or off the dock and an external monitor). The only thing I'd see after "systemctl start sddm.service" is the KDE splash screen with the progress bar and after that completed, it all went dark.

Without kscreen I can see my desktop, but now I rely upon xrandr to configure my display and at first I thought there was a bug in KDE causing the panel's settings not to be respected (windows would go under panel, even if that wasn't allowed), trying to offset the display using xrandr made everything "magically" work again, even after reverting the offset, so I'm not sure what all of that was about.

Everything else seems to be in order now.

After going through all of this, the latest DU at the moment wants to remove gtk3-engines-oxygen and I'm not sure I should let that go (I use quite a few gtk apps under KDE and I do want them integrated nicely, I did use the Oxygen theme prior to KF5, I'm on Breeze now):

Code: [Select]
The following packages will be REMOVED:
  gtk3-engines-oxygen
The following NEW packages will be installed:
  libgck-1-0 libgcr-3-common libgcr-base-3-1
The following packages have been kept back:
  dmeventd dmsetup libdevmapper-event1.02.1 libdevmapper1.02.1 liblvm2app2.2 liblvm2cmd2.02 lvm2
The following packages will be upgraded:
  firmware-zd1211 gir1.2-gtk-3.0 gvfs gvfs-backends gvfs-bin gvfs-common gvfs-daemons gvfs-libs isc-dhcp-client isc-dhcp-common libcap2 libcap2-bin libgail-3-0 libgtk-3-0 libgtk-3-bin libgtk-3-common libhttpclient-java
  libhttpcore-java libhttpmime-java libjna-java libjna-jni
21 upgraded, 3 newly installed, 1 to remove and 7 not upgraded.
Need to get 27.0 MB of archives.

UPDATE: OK, after checking https://tracker.debian.org/pkg/oxygen-gtk3 I guess that's gone now (removed from unstable and testing), so I might as well let go it to?
Dom

Offline drb

  • User
  • Posts: 162
Re: New KDE software in kdenext
« Reply #20 on: 2015/10/03, 11:20:46 »
With a d-u -dV, the only package I'll miss is gimp. With kdenext, will gimp reinstall after removal?

Offline clubex

  • User
  • Posts: 265
Re: New KDE software in kdenext
« Reply #21 on: 2015/10/03, 12:18:29 »
drd: gimp is installable on my category 3) machine and seems to work fine although I haven't    had time to give it a thorough test.

That said I've had a some other difficulties

After yesterday's du containing a libsystemd upgrade etc. my desktop and keyboard froze althougth the mouse was still usable. A hard reset was needed. After that the machine booted to desktop with no problems.

I need Krita but it is still not installable because of unmet dependencies ie.
Code: [Select]
krita : Depends: calligra-libs (= 1:2.8.6+dfsg-siduction1.4) but it is not going to be installed
         Depends: libilmbase6 (>= 1.0.1) but it is not installable
         Depends: libopenexr6 (>= 1.6.1) but it is not installable

Code: [Select]
CPU~Quad core AMD Phenom 9650 (-MCP-) speed/max~1150/2300 MHz Kernel~4.2.2-towo.1-siduction-amd64 x86_64 Up~29 min Mem~987.8/7989.8MB HDD~250.1GB(64.8% used) Procs~194 Client~Shell inxi~2.2.28 

Online Penyelam

  • User
  • Posts: 146
X doesn't start
« Reply #22 on: 2015/10/03, 13:19:44 »

Quote
Do NOT dist-upgrade after July 31 until you find here further instructions, we will keep you posted.


Quote
1) dist-upgrading with apt (not aptitude) from a siduction KDE with kdenext last upgraded before July 29

I did the last du before the migration at 31th July, so I expected I'm still in 1)
After I ran a du recenty, X doesn't start.
With init 5 nothing happens, with startx a new console opens with a rectangle behind the login prompt.


Code: [Select]
System:    Host: siductionbox Kernel: 4.2.2-towo.1-siduction-amd64 x86_64 (64 bit gcc: 5.2.1) Console: tty 1
           Distro: siduction 13.2.1 December - kde - (201401272125)
Machine:   Mobo: MSI model: 870-C45(FX) V2 (MS-7715) v: 1.0 Bios: American Megatrends v: V3.1 date: 04/16/2012
CPU:       Dual core AMD Athlon II X2 260 (-MCP-) cache: 2048 KB
           flags: (lm nx sse sse2 sse3 sse4a svm) bmips: 12805
           clock speeds: max: 3200 MHz 1: 2500 MHz 2: 1900 MHz
Graphics:  Card: NVIDIA GF119 [GeForce GT 520] bus-ID: 01:00.0
           Display Server: X.org 1.17.2 drivers: nouveau (unloaded: fbdev,vesa)
           tty size: 200x75 Advanced Data: N/A for root out of X
Network:   Card: Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet Controller
           driver: r8169 v: 2.3LK-NAPI port: e800 bus-ID: 02:00.0
           IF: eth0 state: down mac: 8c:89:a5:9d:09:cd
Drives:    HDD Total Size: 2136.5GB (26.6% used) ID-1: /dev/sdb model: ST1000DM003 size: 1000.2GB temp: 32C
           ID-2: /dev/sda model: Samsung_SSD_840 size: 120.0GB temp: 0C
           ID-3: /dev/sdc model: SAMSUNG_HD103SI size: 1000.2GB temp: 23C
           ID-4: USB /dev/sdd model: Cruzer size: 16.0GB temp: 0C
Partition: ID-1: / size: 110G used: 7.8G (8%) fs: ext3 dev: /dev/sda1
           ID-2: /home size: 721G used: 430G (63%) fs: ext4 dev: /dev/sdb1
Info:      Processes: 125 Uptime: 3 min Memory: 274.3/7987.4MB Init: systemd runlevel: 5 Gcc sys: 4.9.3
           Client: Shell (bash 4.3.421) inxi: 2.2.28


Code: [Select]
google-chrome.list:deb http://dl.google.com/linux/chrome/deb/ stable main
misc.list:deb-src http://ftp.spline.de/pub/siduction/kdenext unstable main
misc.list:deb http://packages.siduction.org/kdenext unstable main
siduction.list:deb http://ftp.spline.de/pub/siduction/base unstable main
siduction.list:deb http://ftp.spline.de/pub/siduction/extra unstable main contrib
siduction.list:deb http://ftp.spline.de/pub/siduction/fixes unstable main

Code: [Select]
root@siductionbox:~# dpkg -l | grep kwin
rc  kwin                                       4:5.3.2-siduction1                     amd64        KDE window manager
ii  kwin-data                                  4:5.4.1-siduction1.4.3                 all          KDE window manager data files
ii  kwin-style-breeze                          4:5.4.1-siduction1.4                   amd64        KWin Breeze Style
rc  libkwin4-effect-builtins1                  4:5.3.2-siduction1                     amd64        KDE window manager effect builtins library
rc  libkwineffects1abi5                        4:4.11.22-3                            amd64        library used by effects for the KDE window manager
ii  libkwineffects6                            4:5.4.1-siduction1.4.3                 amd64        KDE window manager effects library
rc  libkwinglesutils1                          4:4.11.22-3                            amd64        library with OpenGL/ES utilities for the KDE window manager
rc  libkwinglutils1abi2                        4:4.11.22-3                            amd64        library with OpenGL utilities for the KDE window manager
ii  libkwinglutils6                            4:5.4.1-siduction1.4.3                 amd64        KDE window manager gl utils library
ii  libkwinxrenderutils6                       4:5.4.1-siduction1.4.3                 amd64        KDE window manager render utils library



Code: [Select]

root@siductionbox:~# apt-get install --reinstall kwin-x11 --install-recommends
Paketlisten werden gelesen... Fertig
Abhängigkeitsbaum wird aufgebaut.       
Statusinformationen werden eingelesen.... Fertig
Einige Pakete konnten nicht installiert werden. Das kann bedeuten, dass
Sie eine unmögliche Situation angefordert haben oder, wenn Sie die
Unstable-Distribution verwenden, dass einige erforderliche Pakete noch
nicht erstellt wurden oder Incoming noch nicht verlassen haben.
Die folgenden Informationen helfen Ihnen vielleicht, die Situation zu lösen:


Die folgenden Pakete haben unerfüllte Abhängigkeiten:
 kwin-x11 : Hängt ab von: kwin-common (= 4:5.4.1-siduction1.4.3) soll aber nicht installiert werden
E: Probleme können nicht korrigiert werden, Sie haben zurückgehaltene defekte Pakete.


root@siductionbox:~# apt-get install kwin-x11 kwin-common
Paketlisten werden gelesen... Fertig
Abhängigkeitsbaum wird aufgebaut.       
Statusinformationen werden eingelesen.... Fertig
Einige Pakete konnten nicht installiert werden. Das kann bedeuten, dass
Sie eine unmögliche Situation angefordert haben oder, wenn Sie die
Unstable-Distribution verwenden, dass einige erforderliche Pakete noch
nicht erstellt wurden oder Incoming noch nicht verlassen haben.
Die folgenden Informationen helfen Ihnen vielleicht, die Situation zu lösen:


Die folgenden Pakete haben unerfüllte Abhängigkeiten:
 kwin-common : Hängt ab von: qml-module-org-kde-kquickcontrolsaddons soll aber nicht installiert werden
               Hängt ab von: qml-module-qtmultimedia soll aber nicht installiert werden
               Hängt ab von: kio soll aber nicht installiert werden
               Hängt ab von: libkf5declarative5 (>= 5.0.0) soll aber nicht installiert werden
               Hängt ab von: libkf5kcmutils5 (>= 4.96.0) soll aber nicht installiert werden
               Hängt ab von: libkf5newstuff5 (>= 4.95.0) soll aber nicht installiert werden
               Hängt ab von: libkf5notifications5 (>= 4.96.0) soll aber nicht installiert werden
               Hängt ab von: libkf5plasma5 (>= 5.2.0) soll aber nicht installiert werden
               Hängt ab von: libkwin4-effect-builtins1 soll aber nicht installiert werden
E: Probleme können nicht korrigiert werden, Sie haben zurückgehaltene defekte Pakete.


What can I do?

Btw, the eth0 enty in interfaces was removed after du



« Last Edit: 2015/10/03, 14:52:27 by Penyelam »

Offline Santa

  • User
  • Posts: 261
  • siduction's KDE packager
Re: New KDE software in kdenext
« Reply #23 on: 2015/10/03, 23:36:57 »

Hi,


UPDATE: OK, after checking https://tracker.debian.org/pkg/oxygen-gtk3 I guess that's gone now (removed from unstable and testing), so I might as well let go it to?


Yes. By the way, the apt-get upgrade done by mistake moved you to the case 3), I'm glad you could sort the thing out.


I made a dist-upgrade and the most works fine but if I shut down I have a black screeen and nothing goes. So I must go to a tty and make there a shutdown. Do I miss a packet in kde?


I doubt you miss any packet, this seems more like a kde bug, but do you have kde-standard or kde-full installed?
For the record shutdown works properly here.

With a d-u -dV, the only package I'll miss is gimp. With kdenext, will gimp reinstall after removal?


Like clubex said gimp is installable after dist-upgrading, so you could go ahead and reinstall it once you have dist-upgraded if that's what you want to know.

I need Krita but it is still not installable because of unmet dependencies


Fixed, just do "apt-get update" and try again please.



Quote
Do NOT dist-upgrade after July 31 until you find here further instructions, we will keep you posted.


Quote
1) dist-upgrading with apt (not aptitude) from a siduction KDE with kdenext last upgraded before July 29

I did the last du before the migration at 31th July, so I expected I'm still in 1)


Indeed the correct date is July 31, not July 29, edited first post fixing the typo. So yes, you are in case 1)


After I ran a du recenty, X doesn't start.
With init 5 nothing happens, with startx a new console opens with a rectangle behind the login prompt.

[snip]

What can I do?

Btw, the eth0 enty in interfaces was removed after du


While you are in a situation where the dist-upgrade is suposed to work "out of the box", I'm inclined to think the dist-upgrade didn't finish successfully for your particular case, leaving you a system not completely updated. The reason why I suspect this is this thing you have posted:
Code: [Select]
kwin                                       4:5.3.2-siduction1                     amd64        KDE window manager
ii  kwin-data                                  4:5.4.1-siduction1.4.3                 all          KDE window manager data files


kwin should have been updated to 4:5.4.1-siduction1.4.3 after the upgrade, so something went wrong in the dist-upgrade.


So before trying anything else could you please try "apt-get dist-upgrade" and "apt-get -f dist-upgrade" and post the corresponding output of both commands?
Sometimes standing for what you believe means standing alone.

Offline clubex

  • User
  • Posts: 265
Re: New KDE software in kdenext
« Reply #24 on: 2015/10/04, 00:48:26 »
Krita is now installable.

Thanks Santa.

Offline gypsy56

  • User
  • Posts: 34
Re: New KDE software in kdenext
« Reply #25 on: 2015/10/04, 08:25:10 »
Quote
I doubt you miss any packet, this seems more like a kde bug, but do you have kde-standard or kde-full installed?
I have kde-full. As workarround I shutdown from Konsole.

Offline clubex

  • User
  • Posts: 265
Re: New KDE software in kdenext
« Reply #26 on: 2015/10/04, 15:33:26 »
Santa:
When we have successfully upgraded should we stop using the kdenext repo?

Offline jure

  • User
  • Posts: 520
Re: New KDE software in kdenext
« Reply #27 on: 2015/10/04, 16:26:19 »
I apt-get dist-upgraded my i386 Notebook -  Firestarter -  with kdenext (last upgrade on 31.07.15) without any problems, incl. new kernel and nvidia 340.93..
Quote
1153 aktualisiert, 139 neu installiert, 2 durch eine ältere Version ersetzt, 67 zu entfernen und 1 nicht aktualisiert

thx to Santa for the good job !
Gruss Juergen

Online Penyelam

  • User
  • Posts: 146
Re: X doesn't start - New KDE software in kdenext
« Reply #28 on: 2015/10/04, 17:39:28 »
Hi Santa,
I got a lot of new pakages with the du, but it seems it didn't complete.
A second run (incl. update) provided nothing.


Code: [Select]
root@siductionbox:~# apt-get dist-upgrade
:
Es wurden 323 MB in 26 min 7 s geholt (206 kB/s).                                                                       
Lese Changelogs... Fertig
Extrahiere Vorlagen aus Paketen: 100%
Vorkonfiguration der Pakete ...
(Lese Datenbank ... 158682 Dateien und Verzeichnisse sind derzeit installiert.)
:
Trigger für siduction-dynamic-dms (2014.08.13) werden verarbeitet ...
root@siductionbox:~#




root@siductionbox:~# apt-get -f dist-upgrade
Paketlisten werden gelesen... Fertig
Abhängigkeitsbaum wird aufgebaut.       
Statusinformationen werden eingelesen.... Fertig
Paketaktualisierung (Upgrade) wird berechnet... Fertig
0 aktualisiert, 0 neu installiert, 0 zu entfernen und 0 nicht aktualisiert.

Edit:
tried another du:
Code: [Select]
root@siductionbox:~# apt-get -f dist-upgrade
Paketlisten werden gelesen... Fertig
Abhängigkeitsbaum wird aufgebaut.       
Statusinformationen werden eingelesen.... Fertig
Paketaktualisierung (Upgrade) wird berechnet... Fertig
Die folgenden Pakete werden aktualisiert (Upgrade):
  libaudit-common libaudit1
2 aktualisiert, 0 neu installiert, 0 zu entfernen und 0 nicht aktualisiert.
Es müssen 62,0 kB an Archiven heruntergeladen werden.
Nach dieser Operation werden 1.024 B Plattenplatz freigegeben.
Möchten Sie fortfahren? [J/n]
Holen: 1 http://http.debian.net/debian/ unstable/main libaudit-common all 1:2.4.4-4 [14,8 kB]
Holen: 2 http://http.debian.net/debian/ unstable/main libaudit1 amd64 1:2.4.4-4 [47,2 kB]       
Es wurden 62,0 kB in 1 s geholt (38,4 kB/s).
Lese Changelogs... Fertig
(Lese Datenbank ... 165305 Dateien und Verzeichnisse sind derzeit installiert.)
Vorbereitung zum Entpacken von .../libaudit-common_1%3a2.4.4-4_all.deb ...
Entpacken von libaudit-common (1:2.4.4-4) über (1:2.4.4-3) ...
Trigger für man-db (2.7.3-1) werden verarbeitet ...
Trigger für siduction-dynamic-dms (2014.08.13) werden verarbeitet ...
libaudit-common (1:2.4.4-4) wird eingerichtet ...
(Lese Datenbank ... 165305 Dateien und Verzeichnisse sind derzeit installiert.)
Vorbereitung zum Entpacken von .../libaudit1_1%3a2.4.4-4_amd64.deb ...
Entpacken von libaudit1:amd64 (1:2.4.4-4) über (1:2.4.4-3+b1) ...
libaudit1:amd64 (1:2.4.4-4) wird eingerichtet ...
Trigger für libc-bin (2.19-22) werden verarbeitet ...
root@siductionbox:~#
« Last Edit: 2015/10/04, 17:52:00 by Penyelam »

Offline Santa

  • User
  • Posts: 261
  • siduction's KDE packager
Re: New KDE software in kdenext
« Reply #29 on: 2015/10/04, 19:20:18 »

Hi,

Quote
I doubt you miss any packet, this seems more like a kde bug, but do you have kde-standard or kde-full installed?
I have kde-full. As workarround I shutdown from Konsole.


So you shouldn't be missing any package to make kde work properly, I would recommend you to ask in the kde forums (they will know better than me what you could try), since it seems a KDE bug/problem, but note that I can't reproduce it.


Santa:
When we have successfully upgraded should we stop using the kdenext repo?


Nope. Addind and removing the kdenext repository depending on the day is just a recipe to break your system.


Hi Santa,
I got a lot of new pakages with the du, but it seems it didn't complete.
A second run (incl. update) provided nothing.
[snip]


Ok, then try "dpkg --configure -a" and paste the output please.
Sometimes standing for what you believe means standing alone.