seduction
 Language:
Welcome, Guest. Please login or register.
Did you miss your activation email?
2019/12/06, 16:07:20


Help

Author [EN] [PL] [ES] [PT] [IT] [DE] [FR] [NL] [TR] [SR] [AR] [RU] Topic: Firefox slow after DU [Solved]  (Read 3417 times)

0 Members and 1 Guest are viewing this topic.

Offline towo

  • Global Moderator
  • User
  • *****
  • Posts: 2.308
Re: Firefox slow after DU
« Reply #15 on: 2016/07/26, 06:49:00 »
So your system is indeed using modesetting. If you want to check, if this is the culprint, you can make an


/etc/X11/xorg.conf.d/20-intel.conf which contains


Code: [Select]

Section "Device"
Identifier "My GPU"
Driver "intel"
EndSection


Then restart X and look, if the issue is gone.
Ich gehe nicht zum Karneval, ich verleihe nur manchmal mein Gesicht.

Offline piper

  • Global Moderator
  • User
  • *****
  • Posts: 1.723
  • we are the priests ... of the temples of syrinx
Re: Firefox slow after DU
« Reply #16 on: 2016/07/26, 10:11:10 »
If towo's advise don't work for you, can you please use paste and paste the output of

Code: [Select]
about:support
use the

Code: [Select]
copy text to clipboard
and paste it all


my basics


Code: [Select]
Application Basics
------------------

Name: Firefox
Version: 50.0a1
Build ID: 20160724030208
Update Channel: nightly
User Agent: Mozilla/5.0 (X11; Linux x86_64; rv:50.0) Gecko/20100101 Firefox/50.0
OS: Linux 4.6.4-towo.1-siduction-amd64
Multiprocess Windows: 0/1 (Disabled)
Safe Mode: false
I either give too many fucks or no fucks at all, it's like I cannot find a middle ground for a moderate fuck distribution, it's like what the fuck

Free speech isn't just fucking saying what you want to say, it's also hearing what you don't want to fucking hear

Offline Miho

  • User
  • Posts: 9
Re: Firefox slow after DU
« Reply #17 on: 2016/07/27, 17:45:15 »
towo's advise works for me - thx!

Online finotti

  • User
  • Posts: 105
Re: Firefox slow after DU
« Reply #18 on: 2016/07/27, 18:21:22 »
It seems to work for me too, but I can't test it very well now.  I will do it this weekend and mark it as solved if it is indeed.

Online finotti

  • User
  • Posts: 105
Re: Firefox slow after DU [Solved]
« Reply #19 on: 2016/07/28, 14:54:23 »
Indeed, problem solved!  Thanks towo and all for the great support!

Offline buhtz

  • User
  • Posts: 42
Re: Firefox slow after DU
« Reply #20 on: 2016/07/30, 13:40:20 »
So your system is indeed using modesetting. If you want to check, if this is the culprint, you can make an

/etc/X11/xorg.conf.d/20-intel.conf which contains
Code: [Select]

Section "Device"
   Identifier "My GPU"
   Driver "intel"
EndSection
The issue is gone. Thank you very much!

But could you please explain your solution?

I understand that there is a different "mode" in X. There is no need (for me) to understand that in details.
But what I want to understand is why this simple text-file here (de)activate that mode.

Does this modify a setting int he Debians own (new) intel driver. Or does this totaly switch to the old intels-own driver?

btw:
Firefox use Gecko, right?
There are similar problems with WebKit, too. https://bugs.freedesktop.org/show_bug.cgi?id=85064
« Last Edit: 2016/08/03, 08:24:43 by buhtz »

Online finotti

  • User
  • Posts: 105
Re: Firefox slow after DU [Solved]
« Reply #21 on: 2016/08/10, 17:11:32 »
I think that the intel driver wasn't being loaded (see the output of inxi in the original post) before.  The config file simply told the system to us the intel drive.

But I could be wrong...

Offline musca

  • Global Moderator
  • User
  • *****
  • Posts: 725
  • sid, fly high!
Re: Firefox slow after DU [Solved]
« Reply #22 on: 2016/08/11, 22:58:41 »
yes, it is right.

formerly there has been a separate driver package xserver-xorg-video-modesetting.
Some time ago this driver has been integrated into the xserver-xorg-core package.

Now the automatic detection was changed so modesetting is used for intel devices.
~$ zless /usr/share/doc/xserver-xorg-core/NEWS.Debian.gz
xorg-server (2:1.18.3-2) unstable; urgency=medium

  X now defaults to using built-in modesetting video driver on Intel
  hardware which is "4th gen GMA" and newer, so roughly speaking on hardware
  from 2007 and up. If this triggers new bugs on your hw, please file them
  against the xserver.

  Continuing to use the -intel driver is possible by dropping the template
  xorg.conf to /etc/X11:

  # cp /usr/share/doc/xserver-xorg-video-intel/xorg.conf /etc/X11

 -- Timo Aaltonen <tj...on@debian.org>  Tue, 19 Jul 2016 04:28:05 +0300


There is an explanation on Timo's blog.

The mentioned the template should be included in the xserver-xorg-video-intel package - I can't find it.

greetings,
musca
« Last Edit: 2016/08/11, 23:13:14 by musca »
„Es irrt der Mensch, solang er strebt.“  (Goethe, Faust)

Offline der_bud

  • User
  • Posts: 896
  • member
Re: Firefox slow after DU [Solved]
« Reply #23 on: 2016/08/12, 10:01:31 »
... should be included in the xserver-xorg-video-intel package - I can't find it. ...
Seems to be a funny bug. Here too, reinstalling xserver-xorg-video-intel does not create that template xorg.conf. But regarding  https://packages.debian.org/en/sid/amd64/xserver-xorg-video-intel/filelist it is in the file list. So I downloaded the *.deb file and opened it with an archive manager, there is '...data.tar.xz\data.tar\.\usr\share\doc\xserver-xorg-video-intel\xorg.conf', but it does not get installed.
Du lachst? Wieso lachst du? Das ist doch oft so, Leute lachen erst und dann sind sie tot.

Offline musca

  • Global Moderator
  • User
  • *****
  • Posts: 725
  • sid, fly high!
Re: Firefox slow after DU [Solved]
« Reply #24 on: 2016/08/12, 11:03:35 »
Hello der_bud,

siduction/fixes includes a package which doesn't provide the file. (cleanup needed?)
The debian package is installable with:
Code: [Select]
apt-get install xserver-xorg-video-intel=2:2.99.917+git20160706-1
The original content is:
musca@sidbox:~$ cat /usr/share/doc/xserver-xorg-video-intel/xorg.conf
Section "Device"
    Identifier "Intel"
    Driver "intel"
#    Option "AccelMethod" "uxa"
EndSection

SNA (Sandybridge New Acceleration) is its default mode.
UXA (Universal Xcceleration Architecture) might be worth a try. Just uncomment the line.
Users can create this configuration file with:
Code: [Select]
mkdir-p /etc/X11/xorg.conf.d \
 && echo -e "\nSection \"Device\"\n    Identifier \"Intel\"\n    Driver \"intel\"\n#    Option \"AccelMethod\" \"uxa\"\nEndSection" >> /etc/X11/xorg.conf.d/20-intel.conf

greetings
musca
« Last Edit: 2016/08/12, 15:15:10 by musca »
„Es irrt der Mensch, solang er strebt.“  (Goethe, Faust)

Offline musca

  • Global Moderator
  • User
  • *****
  • Posts: 725
  • sid, fly high!
Re: Firefox slow after DU [Solved]
« Reply #25 on: 2016/08/12, 15:00:42 »
Hello der_bud,

cleanup is neccessary, because in April intel had tagged the driver in git as version 2.99.918 but withdrawn to 917 later.

If you experience any problems with the intel driver we suggest to purge and install the intel driver,
Code: [Select]
apt update && apt purge xserver-xorg-video-intel && apt install xserver-xorg-video-intel
or just downgrade to the current version, e.g. :
Code: [Select]
apt install xserver-xorg-video-intel=2:2.99.917+git20160706-1
greetings
musca
„Es irrt der Mensch, solang er strebt.“  (Goethe, Faust)