seduction
 Language:
Welcome, Guest. Please login or register.
Did you miss your activation email?
2020/11/28, 09:08:03


Help

Author [EN] [PL] [ES] [PT] [IT] [DE] [FR] [NL] [TR] [SR] [AR] [RU] Topic: [SOLVED] KDE takes over two minutes to boot  (Read 1425 times)

0 Members and 1 Guest are viewing this topic.

Offline vayu

  • User
  • Posts: 222
[SOLVED] KDE takes over two minutes to boot
« on: 2017/11/02, 23:30:57 »
After entering my password at the sddm login screen, it takes over two minutes to come to the KDE desktop.
systemd-analyze blame doesn't seem to help for the KDE stuff, in my output nmbd is taking a long time, but I don't believe that's what's taking so long.  It's a full 2 to 3 minutes once I enter my password to get to the desktop.  I think what analyze blame is reporting is the time it took to get to the login screen.
This started several du's ago.

44.782s nmbd.service
         24.397s spamassassin.service
         17.377s systemd-fsck@dev-disk-by\x2duuid-45a322f2\x2df421\x2d4e43\x2d8902\x2ddba656ba3e66.service
         17.038s systemd-fsck@dev-disk-by\x2duuid-6c17b3af\x2dd2a0\x2d4612\x2d80be\x2d3bb39b8f7515.service
         11.689s webmin.service
          9.709s NetworkManager-wait-online.service
« Last Edit: 2017/11/06, 19:19:41 by vayu »

Offline absolut

  • User
  • Posts: 438
Re: KDE takes over two minutes to boot
« Reply #1 on: 2017/11/02, 23:45:37 »
do you have a NAS that is being mounted on bootup / login?

Offline mld

  • User
  • Posts: 10
Re: KDE takes over two minutes to boot
« Reply #2 on: 2017/11/06, 06:34:27 »
What system do you have (Arch, Kernel, HW)? Does it happen with other DEs or just with KDE ? Ist it a recent observation?

Offline vayu

  • User
  • Posts: 222
Re: KDE takes over two minutes to boot
« Reply #3 on: 2017/11/06, 07:15:00 »
 
Quote
What system do you have (Arch, Kernel, HW)? Does it happen with other DEs or just with KDE ? Ist it a recent observation?
Kernel~4.13.11-towo.1-siduction-amd64 x86_64Plasma 5.10.5, Frameworks 5.37.0, QT 5.9.2
This started happening maybe 10 or so du's ago. And has been a problem through several kernel versions. I'm pretty sure it started after a KDE update, but I didn't put together which one.

I've searched everywhere, the closest thing I've found was to turn off the KDE splash screen, that didn't help.  None of the systemd analyze reports give any clues. 

Booting in general is ok, the problem seems to be KDE startup.  I've tried making a new user and logging in from a clean KDE desktop, that didn't help either. 

I'm quite frustrated.  My system was working so great, it still is except 2-3 minutes is a ridiculously long time to wait.  Once I'm in, everything is reasonably fast and normal.   
« Last Edit: 2017/11/06, 07:19:07 by vayu »

Offline finotti

  • User
  • Posts: 163

Offline vayu

  • User
  • Posts: 222
Re: KDE takes over two minutes to boot
« Reply #5 on: 2017/11/06, 19:18:45 »
Quote
Could this be the issue? https://forum.siduction.org/index.php?topic=6856.msg55755#msg55755
That was it. A thousand times thankyou!!