seduction
 Language:
Welcome, Guest. Please login or register.
Did you miss your activation email?
2020/12/03, 14:37:11


Help

Author [EN] [PL] [ES] [PT] [IT] [DE] [FR] [NL] [TR] [SR] [AR] [RU] Topic: [obsolet] Nvidia und aptosid kernel 2.6.38  (Read 11206 times)

0 Members and 1 Guest are viewing this topic.

Online towo

  • Global Moderator
  • User
  • *****
  • Posts: 2.417
[obsolet] Nvidia und aptosid kernel 2.6.38
« on: 2011/03/15, 10:01:51 »
Mit dem Update auf den aktuellen 2.6.38er Kernel in aptosid wird der propritäre Treiber nicht mehr funktionieren, da das Modul nicht baut. Grund hierfür ist

0019-BKL-That-s-all-folks.patch

welcher alle Reste von BKL related Files aus den Sourcen entfernt.

Es bleiben nun nur wenige Möglichkeiten:

1. Warten, ob Nvidia irgendwann reagiert und 2.6.37 weiter benutzen. Das kann lange dauern, da aptosid die einzige Distro ist, die BKL so rigoros aus dem Kernel verbannt hat
2. Kernel von frickelplatz nehmen, da ist dieser Patch nicht drin
3. Nouveau benutzen.
Ich gehe nicht zum Karneval, ich verleihe nur manchmal mein Gesicht.

Offline seagull

  • User
  • Posts: 70
Besitzer mit Nvidia Karten und aptosid kernel 2.6.38
« Reply #1 on: 2011/03/15, 10:23:46 »
Danke für die klare Ansage!
Der prop. Treiber baut das Kernel-Modul nicht mehr... kann ich bestätigen. f. nvidia 260.19.44.

Habe mich für "Warten" entschieden!

Offline mylo

  • User
  • Posts: 922
Re: Besitzer mit Nvidia Karten und aptosid kernel 2.6.38
« Reply #2 on: 2011/03/15, 10:24:16 »
Quote from: "towo"
...
2. Kernel von frickelplatz nehmen, da ist dieser Patch nicht drin...


Hi towo,
wie geht man dazu vor?

Deinstallieren und installieren?
D-U mit offener Quelle frickelplatz und auskommmentierter aptosid-Quelle?

Oder?

Danke für einen Hinweis.
Regards mylo
____________________________________________ ____
"Die gefährlichste aller Weltanschauungen ist die Weltanschauung der Leute,
welche die Welt nicht angeschaut haben."               Alexander von Humboldt

Offline kris99

  • User
  • Posts: 112
[obsolet] Nvidia und aptosid kernel 2.6.38
« Reply #3 on: 2011/03/15, 11:12:24 »
Hallo mylo

ganz einfach, folgende Datei erstellen
Code: [Select]
# vim /etc/apt/sources.list.d/frickel.listmit diesem Inhalt
Code: [Select]
deb http://frickelplatz.de/debian/ sid main contrib non-freelokales repository aktualisieren
Code: [Select]
# apt-get updateund dann die oder das Metakernelpackage deinstallieren. Dazu mußt Du wissen, wie das Metapackage heißt. Ein beherztes
Code: [Select]
# dpkg -l|grep linux-imagezeigt Dir die Situation. Z. B. entfernt
Code: [Select]
# apt-get remove linux-image-2.6-amd64das Metapackage der gesamten 2.6 Kernelversionen. Von nun an mußt Du allerdings ein Kernelupdate händisch anfordern, z.B.:
Code: [Select]
# apt-get install linux-image-2.6.38-0.towo.1-frickel-amd64 linux-headers-2.6.38-0.towo.1-frickel-amd64

Kris

Online towo

  • Global Moderator
  • User
  • *****
  • Posts: 2.417
[obsolet] Nvidia und aptosid kernel 2.6.38
« Reply #4 on: 2011/03/15, 11:15:31 »
Code: [Select]
apt-get install linux-image-2.6-frickel-$arch linux-headers-2.6-frickel-$arch

das installiert sowohl die Metas, als auch den Kernel und Header selbst.
Ich gehe nicht zum Karneval, ich verleihe nur manchmal mein Gesicht.

Offline kris99

  • User
  • Posts: 112
[obsolet] Nvidia und aptosid kernel 2.6.38
« Reply #5 on: 2011/03/15, 11:19:44 »
Quote from: "towo"
Code: [Select]
apt-get install linux-image-2.6-frickel-$arch linux-headers-2.6-frickel-$arch

das installiert sowohl die Metas, als auch den Kernel und Header selbst.


Wow! wieder etwas neues gelernt  :D

Offline mylo

  • User
  • Posts: 922
[obsolet] Nvidia und aptosid kernel 2.6.38
« Reply #6 on: 2011/03/15, 12:06:33 »
super, vielen Dank Euch für die tolle Anleitung!!
Regards mylo
____________________________________________ ____
"Die gefährlichste aller Weltanschauungen ist die Weltanschauung der Leute,
welche die Welt nicht angeschaut haben."               Alexander von Humboldt

jackyohh

  • Guest
[obsolet] Nvidia und aptosid kernel 2.6.38
« Reply #7 on: 2011/03/15, 21:52:47 »
hi,

ich hab wie vorgeschlagen den kernel von frickelplatz installiert und das nvidia modul (bei mir 270.26-0~frickel.1) hat er auch ohne murren gebaut. leider wird meine grafikkarte wohl nicht mehr erkannt!

Code: [Select]

...
#
[    40.861] (EE) No devices detected.
#
[    40.861]
#
Fatal server error:
#
[    40.861] no screens found
...


die komplette log gibts hier http://pastebin.com/hkC0WbMy

Online towo

  • Global Moderator
  • User
  • *****
  • Posts: 2.417
[obsolet] Nvidia und aptosid kernel 2.6.38
« Reply #8 on: 2011/03/15, 21:55:38 »
dpkg -l | grep -i nvidia
Ich gehe nicht zum Karneval, ich verleihe nur manchmal mein Gesicht.

jackyohh

  • Guest
[obsolet] Nvidia und aptosid kernel 2.6.38
« Reply #9 on: 2011/03/15, 22:10:19 »
Code: [Select]
$ dpkg -l | grep -i nvidia
ii  libgl1-nvidia-alternatives                           270.26-0~frickel.1                       simplifies replacing MESA libGL with GPU vendor libraries
ii  libgl1-nvidia-alternatives-ia32                      270.26-0~frickel.1                       simplifies replacing MESA libGL with GPU vendor libraries (32-bit)
ii  libgl1-nvidia-glx                                    270.26-0~frickel.1                       NVIDIA binary OpenGL libraries
ii  libgl1-nvidia-glx-ia32                               270.26-0~frickel.1                       NVIDIA binary OpenGL 32-bit libraries
ii  libglx-nvidia-alternatives                           270.26-0~frickel.1                       simplifies replacing Xorg module libglx.so with GPU vendor library
ii  nvidia-common                                        20110126+0~anbe0                         NVIDIA binary graphics driver support files
ii  nvidia-glx                                           270.26-0~frickel.1                       NVIDIA binary Xorg driver
ii  nvidia-glx-ia32                                      270.26-0~frickel.1                       NVIDIA binary driver 32-bit libs
ii  nvidia-kernel-2.6.31-6.slh.2-sidux-amd64             195.36.24-0+2.6.31-25                    NVIDIA binary kernel module for Linux 2.6.31-6.slh.2-sidux-amd64
ii  nvidia-kernel-2.6.37-0.slh.18-aptosid-amd64          270.26-0~frickel.1+2.6.37-18             NVIDIA binary kernel module for Linux 2.6.37-0.slh.18-aptosid-amd64
ii  nvidia-kernel-2.6.37-0.slh.2-aptosid-amd64           195.36.31-6+2.6.37-2                     NVIDIA binary kernel module for Linux 2.6.37-0.slh.2-aptosid-amd64
ii  nvidia-kernel-2.6.37-0.slh.7-aptosid-amd64           195.36.31-6+2.6.37-7                     NVIDIA binary kernel module for Linux 2.6.37-0.slh.7-aptosid-amd64
ii  nvidia-kernel-2.6.37-2.slh.4-aptosid-amd64           260.19.36-0~frickel.2+2.6.37-33          NVIDIA binary kernel module for Linux 2.6.37-2.slh.4-aptosid-amd64
ii  nvidia-kernel-2.6.37-3.slh.3-aptosid-amd64           270.26-0~frickel.1+2.6.37-38             NVIDIA binary kernel module for Linux 2.6.37-3.slh.3-aptosid-amd64
ii  nvidia-kernel-2.6.38-0.towo.1-frickel-amd64          270.26-0~frickel.1+2.6.38-5              NVIDIA binary kernel module for Linux 2.6.38-0.towo.1-frickel-amd64
ii  nvidia-kernel-common                                 20110126+0~anbe0                         NVIDIA binary kernel module support files
ii  nvidia-kernel-source                                 270.26-0~frickel.1                       NVIDIA binary kernel module source
ii  nvidia-settings                                      195.36.24-1                              Tool for configuring the NVIDIA graphics driver
ii  nvidia-vdpau-driver                                  270.26-0~frickel.1                       NVIDIA vdpau driver
ii  nvidia-vdpau-driver-ia32                             270.26-0~frickel.1                       NVIDIA vdpau 32-bit driver

Online towo

  • Global Moderator
  • User
  • *****
  • Posts: 2.417
[obsolet] Nvidia und aptosid kernel 2.6.38
« Reply #10 on: 2011/03/15, 22:12:05 »
cat /etc/X11/xorg.conf
lspci | grep -i vga
Ich gehe nicht zum Karneval, ich verleihe nur manchmal mein Gesicht.

jackyohh

  • Guest
[obsolet] Nvidia und aptosid kernel 2.6.38
« Reply #11 on: 2011/03/15, 22:29:23 »
xorg.conf http://pastebin.com/C4m6FUUK


Code: [Select]
$ lspci | grep -i vga
01:00.0 VGA compatible controller: nVidia Corporation G84 [GeForce 8400 GS] (rev a1)
04:00.0 VGA compatible controller: nVidia Corporation G86 [GeForce 8400 GS] (rev a1)


ich nutze zwei grafikkarte im dual head betrieb mit separatem X.
macht aber auch keinen unterschied, wenn ich nur eine karte verbaut hab.

unter 2.6.37-0.slh.18-aptosid-amd64 (mit nvdia 270.26) geht übrigens noch alles einwandfrei. aber 2.6.37-1 2.6.37-2 zickt bei mir schon rum. da erkennt er meine 2te grafikkarte nicht mehr, aber immerhin noch meine erste.

Online towo

  • Global Moderator
  • User
  • *****
  • Posts: 2.417
[obsolet] Nvidia und aptosid kernel 2.6.38
« Reply #12 on: 2011/03/15, 22:33:23 »
Grundsätzlich, Du hast 2 Grafikkarten, Du brauchst 2 Sektionen "Device".
Mal abgesehen davon wird Device 0 wohl eher die BusID 1:0:0 haben.
Ich gehe nicht zum Karneval, ich verleihe nur manchmal mein Gesicht.

jackyohh

  • Guest
[obsolet] Nvidia und aptosid kernel 2.6.38
« Reply #13 on: 2011/03/17, 20:20:08 »
sry, dass ich erst jetzt anworten kann. hab erst jetzt wieder etwas zeit gefunden.


wenn ich nur eine grafikarte nämlich die an BusID 4:0:0 starten will, dann bräuchte ich doch auch nur die eine angeben, oder etwa nicht? mit dem kernel 2.6.37-0.slh.18-aptosid-amd64 und identischem X funktioniert das ja auch einwandfrei.

auch das ausbauen der 2ten grafikkarte hat nichts gebracht.
entferne ich die xorg.conf kompett startet auch x, aber halt ohne nvidia treiber.

(die BusID hab ich jetzt übrigens angepasst. Device 0 ist nun BusID 1:0:0 )

jackyohh

  • Guest
[obsolet] Nvidia und aptosid kernel 2.6.38
« Reply #14 on: 2011/03/17, 20:43:19 »
gerade nochmal einen versuch gestartet und öhm ... es funktioniert !!! :shock:

ohne murren und rumzicken hat er mir schön den X gestartet. ich glaub er muss sich damals, beim bau der nvidia module, irgendwie verschluckt haben.
musste gestern, aus einem anderen grund, alle nvidia treiberbestandteile löschen und neu aufsetzen. hab aber nicht erwartet, dass es dadurch gelöst sein würde. zum glück hab ich mir geirrt.  
der letzte beitrag war also etwas voreilig ^^

danke nochmal für die hilfe