seduction
 Language:
Welcome, Guest. Please login or register.
Did you miss your activation email?
2020/02/28, 01:06:23


Help

Author [EN] [PL] [ES] [PT] [IT] [DE] [FR] [NL] [TR] [SR] [AR] [RU] Topic: plasma desktop crashes  (Read 608 times)

0 Members and 1 Guest are viewing this topic.

Offline dsat

  • User
  • Posts: 99
plasma desktop crashes
« on: 2018/09/09, 14:54:57 »
Hi,

since a while I have the problem that my plasma desktop crashes on start-up. If I remember it good it is related to the upgrade of xserver-xorg-core 1.19 to 1.20. I installed LXQT, so I have a desktop but I prefer KDE-Plasma.

After sddm login the desktop shows up twice, but not complete and interrupted by a black screen and then remains black only showing mouse cursor, no start menue, no control panel. I can start all programms with Alt+F2 and use them as usual.

That's what I tried so far:
- I created a second user but the problem persists
- I uninstalled and reinstall all plasma related packages but no success

System is a pure debian sid fully dist-upgraded, hardware is a Lenovo X230T:

Code: [Select]
root@x230t:# inxi -v3
System:    Host: x230t Kernel: 4.18.0-1-amd64 x86_64 bits: 64 compiler: gcc v: 7.3.0 Desktop: KDE Plasma 5.13.5
           Distro: Debian GNU/Linux buster/sid
Machine:   Type: Laptop System: LENOVO product: 34382BG v: ThinkPad X230 Tablet serial: R9VREMH
           Mobo: LENOVO model: 34382BG serial: 1ZPA02C11M9 UEFI [Legacy]: LENOVO v: GCETA5WW (2.65 )
           date: 09/09/2016
Battery:   ID-1: BAT0 charge: 18.1 Wh condition: 45.5/47.5 Wh (96%) model: SANYO 42T4865 status: Discharging
           Device-1: hid-00:02:76:21:b9:e8-battery model: ThinkPad Bluetooth Laser Mouse charge: N/A
           status: Discharging
CPU:       Topology: Dual Core model: Intel Core i5-3320M bits: 64 type: MT MCP arch: Ivy Bridge rev: 9
           L2 cache: 3072 KiB
           flags: lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx bogomips: 20753
           Speed: 1198 MHz min/max: 1200/3300 MHz Core speeds (MHz): 1: 1198 2: 1198 3: 1197 4: 1197
Graphics:  Device-1: Intel 3rd Gen Core processor Graphics driver: i915 v: kernel bus ID: 00:02.0
           Display: x11 server: X.Org 1.20.1 driver: modesetting unloaded: fbdev,vesa resolution: 1366x768~60Hz
           OpenGL: renderer: Mesa DRI Intel Ivybridge Mobile v: 4.2 Mesa 18.1.7 direct render: Yes
Network:   Device-1: Intel 82579LM Gigabit Network driver: e1000e v: 3.2.6-k port: 6080 bus ID: 00:19.0
           IF: enp0s25 state: up speed: 10 Mbps duplex: half mac: 3c:97:0e:5a:b2:69
           Device-2: Intel Centrino Advanced-N 6205 [Taylor Peak] driver: iwlwifi v: kernel bus ID: 03:00.0
           IF: wlan0 state: up mac: 84:3a:4b:06:78:74
           IF-ID-1: wwp0s20u4i6 state: down mac: 02:80:37:ec:02:00
Drives:    Local Storage: total: 465.76 GiB used: 265.23 GiB (56.9%)
Info:      Processes: 232 Uptime: 1h 04m Memory: 15.37 GiB used: 1.37 GiB (8.9%) Init: systemd runlevel: 5
           Compilers: gcc: 8.2.0 Shell: bash v: 4.4.23 inxi: 3.0.22

Two other sid installs, one in virtualbox and the other on hardware with nvidia graphics, do not have this issue.

Any idea how to solve this is appreciated.

Regards dsat

Offline hendrikL

  • User
  • Posts: 346
Re: plasma desktop crashes
« Reply #1 on: 2018/09/10, 07:23:25 »
Next test could be is to test the xorg-intel driver.

Offline dsat

  • User
  • Posts: 99
Re: plasma desktop crashes
« Reply #2 on: 2018/09/10, 09:58:42 »
Hi,
I removed xserver-xorg-video-intel and it makes no difference. Isn't that strange?
Regards dsat

Offline hendrikL

  • User
  • Posts: 346
Re: plasma desktop crashes
« Reply #3 on: 2018/09/10, 14:51:10 »
Not removing, you should try it,  because you are using the modset driver, so test it.
Why, because nvidea works fine and also the vm.
It also could be some kind of software which is causing that error.
Trial and error.

Offline dsat

  • User
  • Posts: 99
Re: plasma desktop crashes
« Reply #4 on: 2018/09/10, 16:26:35 »
How do I disable modesetting and activate i915 graphics?

I tried nomodeset as boot option but then I end up on a console with no graphics at all.

Do I need a xorg.conf with intel driver? xserver-xorg-video-intel is installed again.
« Last Edit: 2018/09/10, 17:08:18 by dsat »

Offline melmarker

  • Global Moderator
  • User
  • *****
  • Posts: 2.795
    • g-com.eu
Re: plasma desktop crashes
« Reply #5 on: 2018/09/10, 18:09:13 »
the pure nomodeset is a ubuntu thing - one will need to specify it - read more in the kernel documentation
Those who would give up essential Liberty, to purchase a little temporary Safety, deserve neither Liberty nor Safety. (Benjamin Franklin, November 11, 1755)
Never attribute to malice that which can be adequately explained by stupidity. (Hanlons razor)


Offline dsat

  • User
  • Posts: 99
Re: plasma desktop crashes
« Reply #7 on: 2018/09/11, 09:24:22 »
Hi,
I followed your link and have i915 graphics now:
Code: [Select]
inxi -G
Graphics:  Device-1: Intel 3rd Gen Core processor Graphics driver: i915 v: kernel
           Display: x11 server: X.Org 1.20.1 driver: intel resolution: 1366x768~60Hz
           OpenGL: renderer: Mesa DRI Intel Ivybridge Mobile v: 4.2 Mesa 18.1.7

But the behaviour did not change: black desktop with mouse cursor, no control panel, no start menu. What am I missing?
Regards dsat

Offline hendrikL

  • User
  • Posts: 346
Re: plasma desktop crashes
« Reply #8 on: 2018/09/11, 11:07:08 »
New user also doesn't work but lxqt is working?
Then you can move back to the modeset-driver by renaming the xorg.conf to xorg.conf~ and restarting the xserver, if you want so.
You can check the xorg.0.log , take a look too the journal ...

but i think
1. some kind of library is missing? (did you reinstalled plasma with the recommends? like apt install --install-recommends, how old is your installation, is it siduction or is it a pure debian?)
or
2. a special software is installed, which causing plasma to crash.

what is the difference between the nvidea driven pc and the x230?
check the installed software, plasma*, libkf5*, and so on, what is installed what is not ....

give us an "inxi -r"



Offline dsat

  • User
  • Posts: 99
Re: plasma desktop crashes
« Reply #9 on: 2018/09/11, 13:16:57 »
Hi,

I'm back on modesetting. System is pure debian sid and 2 or 3 years old. All packages are installed without recommends but I now changed configuration to install with recommends.

I have no access to the other two installs, because I'm not at home right now.

Code: [Select]
inxi -r
Repos:     Active apt repos in: /etc/apt/sources.list.d/debian.list
           1: deb http://ftp.de.debian.org/debian/ unstable main contrib non-free
           Active apt repos in: /etc/apt/sources.list.d/virtualbox.list
           1: deb http://download.virtualbox.org/virtualbox/debian/ stretch contrib non-free

I hope virtualbox from Oracle is not too special.

I'll try to reinstall with recommends.
Regard dsat