seduction
 Language:
Welcome, Guest. Please login or register.
Did you miss your activation email?
2019/05/27, 05:17:01


Help

Author [EN] [PL] [ES] [PT] [IT] [DE] [FR] [NL] [TR] [SR] [AR] [RU] Topic: CAUTION -- python3.7 will remove hplip, libreoffice, etc. etc.  (Read 3923 times)

0 Members and 1 Guest are viewing this topic.

Offline NochEinNeuer

  • User
  • Posts: 118
Gerade machte ich ein apt update und ein apt -d dist-upgrade.Mir wurden keine Pakete mehr zum Entfernen vermerkt.
Könnte ich jetzt wieder ein d-u machen oder sollte ich doch noch warten?
Vielen Dank,

Offline tommy2

  • User
  • Posts: 113
I would think, being nothing is scheduled for removal you can remove the -d and continue with your full or dist upgrade that's what I would do.  :)

Offline harley-peter

  • User
  • Posts: 764
Here the system wants to remove yet hplip and hplip-gui

Offline melmarker

  • Global Moderator
  • User
  • *****
  • Posts: 2.630
    • g-com.eu
Kauf Dir nen Brother: https://buildd.debian.org/status/package.php?p=hplip - dat dauert wohl noch.
Those who would give up essential Liberty, to purchase a little temporary Safety, deserve neither Liberty nor Safety. (Benjamin Franklin, November 11, 1755)
Never attribute to malice that which can be adequately explained by stupidity. (Hanlons razor)

Offline dibl

  • siduction community member
  • Global Moderator
  • User
  • *****
  • Posts: 1.860
    • Land of the Buckeye
Quote from: harley-peter
Here the system wants to remove yet hplip and hplip-gui

Hier auch.

We can buy some time (instead of a Brother ...), using
Code: [Select]
apt upgrade
Of course, doing that, we slowly drift away from a complete sid system as we don't get the new packages.   :'(
Asus ROG STRIX X299-E, Core i7-7740X, Nvidia GTX-1060, dual monitors, SSD 860 EVO, 2@WD1003FZEX in BTRFS

Offline melmarker

  • Global Moderator
  • User
  • *****
  • Posts: 2.630
    • g-com.eu
dibl: Wrong, there will be no drift - thats the cool thing about apt

Code: [Select]
apt upgrade == apt-get upgrade --with-new-pkgs --$some-fancy-progress-bar
Those who would give up essential Liberty, to purchase a little temporary Safety, deserve neither Liberty nor Safety. (Benjamin Franklin, November 11, 1755)
Never attribute to malice that which can be adequately explained by stupidity. (Hanlons razor)

Offline dibl

  • siduction community member
  • Global Moderator
  • User
  • *****
  • Posts: 1.860
    • Land of the Buckeye
Quote from: melmarker
   
Code: [Select]
apt upgrade == apt-get upgrade --with-new-pkgs

Ahhhhhh!    :)

But, not the new packages which break the hplip dependencies, correct?
Asus ROG STRIX X299-E, Core i7-7740X, Nvidia GTX-1060, dual monitors, SSD 860 EVO, 2@WD1003FZEX in BTRFS

Offline tommy2

  • User
  • Posts: 113
I let them go and reinstalled them after the upgrade, apt did not complain so I think everything is back to normal, at least for now.  ;)

Offline melmarker

  • Global Moderator
  • User
  • *****
  • Posts: 2.630
    • g-com.eu
dibl: Right
Those who would give up essential Liberty, to purchase a little temporary Safety, deserve neither Liberty nor Safety. (Benjamin Franklin, November 11, 1755)
Never attribute to malice that which can be adequately explained by stupidity. (Hanlons razor)

Offline harley-peter

  • User
  • Posts: 764
@tommy2:
I cannot confirm this. After apt install hplip I get

Code: [Select]
Die folgenden Pakete haben unerfüllte Abhängigkeiten:
 hplip : Hängt ab von: python3 (< 3.7) aber 3.7.1-2 soll installiert werden
         Empfiehlt: printer-driver-postscript-hp soll aber nicht installiert werden
E: Probleme können nicht korrigiert werden, Sie haben zurückgehaltene defekte Pakete.

Offline piper

  • Global Moderator
  • User
  • *****
  • Posts: 1.630
  • we are the priests ... of the temples of syrinx

3 binary packages have unsatisfiable dependencies normal


Code: [Select]
    The dependencies of hplip-gui=3.18.10+dfsg0-3 cannot be satisfied on amd64 because: unsatisfied dependency on python3 (< 3.7)
    The dependencies of hplip=3.18.10+dfsg0-3 cannot be satisfied on mips, armel, mipsel, amd64, mips64el, i386, arm64, s390x, armhf, and ppc64el because: unsatisfied dependency on python3 (< 3.7)
    The dependencies of printer-driver-postscript-hp=3.18.10+dfsg0-3 cannot be satisfied on mips, armel, mipsel, amd64, mips64el, i386, arm64, s390x, armhf, and ppc64el because: unsatisfied dependency on python3 (< 3.7)

"We're all grown up and don't freak out when a piece of text contains the word 'fuck'. I still don't understand why people think that the word 'fuck' is what would keep certain groups from contributing to the Linux kernel. In all seriousness, it doesn't."

John Paul Adrian Glaubitz

Offline dibl

  • siduction community member
  • Global Moderator
  • User
  • *****
  • Posts: 1.860
    • Land of the Buckeye
Hurrah -- hplip & friends are now installable on a fully updated system.   8)

Code: [Select]
root@n5110:/# apt policy python3 hplip
python3:
  Installed: 3.7.1-2
  Candidate: 3.7.1-2
  Version table:
 *** 3.7.1-2 500
        500 http://deb.debian.org/debian unstable/main amd64 Packages
        100 /var/lib/dpkg/status
hplip:
  Installed: 3.18.10+dfsg0-3+b1
  Candidate: 3.18.10+dfsg0-3+b1
  Version table:
 *** 3.18.10+dfsg0-3+b1 500
        500 http://deb.debian.org/debian unstable/main amd64 Packages
        100 /var/lib/dpkg/status
     3.17.10+repack0-7.1 500
        500 http://packages.siduction.org/fixes unstable/main amd64 Packages
Asus ROG STRIX X299-E, Core i7-7740X, Nvidia GTX-1060, dual monitors, SSD 860 EVO, 2@WD1003FZEX in BTRFS

Offline tranquil

  • User
  • Posts: 50
Whew...finally!


Code: [Select]

The following packages were automatically installed and are no longer required:
  gnome-mime-data libcln6 libgnomevfs2-common libpython3.6
Use 'sudo apt autoremove' to remove them.
The following NEW packages will be installed:
  libpython3.7 libpython3.7-minimal libpython3.7-stdlib python3.7
  python3.7-minimal
The following packages will be upgraded:
  blueman firefox fonts-jura gir1.2-freedesktop gir1.2-glib-2.0 gnucash hplip
  libasound2 libasound2:i386 libblockdev-crypto2 libblockdev-fs2 libblockdev-loop2
  libblockdev-part-err2 libblockdev-part2 libblockdev-swap2 libblockdev-utils2
  libblockdev2 libcap-ng0 libffi6 libffi6:i386 libgdcm2.8 libgirepository-1.0-1
  libhpmud0 liblirc-client0 libnm0 libnss3 liborcus-0.13-0 libpolkit-agent-1-0
  libpolkit-backend-1-0 libpolkit-gobject-1-0 libpq5 libprotobuf-lite17
  libprotobuf17 libpython3-stdlib libreoffice
  libreoffice-avmedia-backend-gstreamer libreoffice-base libreoffice-base-core
  libreoffice-base-drivers libreoffice-calc libreoffice-common libreoffice-core
  libreoffice-draw libreoffice-help-common libreoffice-help-en-us
  libreoffice-impress libreoffice-java-common libreoffice-librelogo
  libreoffice-math libreoffice-nlpsolver libreoffice-ogltrans
  libreoffice-report-builder libreoffice-report-builder-bin
  libreoffice-script-provider-bsh libreoffice-script-provider-js
  libreoffice-script-provider-python libreoffice-sdbc-firebird
  libreoffice-sdbc-hsqldb libreoffice-sdbc-postgresql libreoffice-style-colibre
  libreoffice-style-tango libreoffice-wiki-publisher libreoffice-writer libruby2.5
  libsane-hpaio libsmbclient libtdb1 libudisks2-0 libunbound8 libupower-glib3
  libvolume-key1 libwbclient0 lintian network-manager policykit-1
  printer-driver-hpcups printer-driver-postscript-hp python3
  python3-dbus.mainloop.pyqt5 python3-gnucash python3-minimal python3-pyqt5
  python3-reportbug python3-uno qtchooser reportbug ruby2.5 samba-libs udisks2
  uno-libs3 upower ure xxd
93 upgraded, 5 newly installed, 0 to remove and 0 not upgraded.
Need to get 190 MB of archives.
After this operation, 26.8 MB of additional disk space will be used.
[/code.
Dual-booting Debian Stable and Unstable with Openbox window manager and Tint2 panel.

Offline sotnik

  • User
  • Posts: 40
Ok in my case only python3-pygpu will be deleted now.
« Last Edit: 2018/11/28, 11:42:56 by sotnik »

Offline hendrikL

  • User
  • Posts: 316
Well with kf5/plasma5 (kde) you have to be careful, read what apt want to do!

Code: [Select]
LANG=C apt full-upgrade -d
Reading package lists... Done
Building dependency tree
Reading state information... Done
Calculating upgrade... Done
The following packages will be REMOVED:
  kde-plasma-desktop kinfocenter libqalculate5v5 plasma-desktop plasma-widgets-addons plasma-workspace sddm-theme-breeze
The following packages will be upgraded:
  libcolorcorrect5 libkworkspace5-5 libplasma-geolocation-interface5 libtaskmanager6 libweather-ion7 python-dbus.mainloop.pyqt5 python-pyqt5
  python-pyqt5.qtwebkit python3-dbus.mainloop.pyqt5 python3-pyqt5 qtchooser
11 upgraded, 0 newly installed, 7 to remove and 0 not upgraded.
Need to get 0 B/5871 kB of archives.
After this operation, 51.5 MB disk space will be freed.
Do you want to continue? [Y/n] n
Abort.