seduction
 Language:
Welcome, Guest. Please login or register.
Did you miss your activation email?
2020/04/04, 18:28:15


Help

Author [EN] [PL] [ES] [PT] [IT] [DE] [FR] [NL] [TR] [SR] [AR] [RU] Topic: CAUTION -- python3.7 will remove hplip, libreoffice, etc. etc.  (Read 5177 times)

0 Members and 1 Guest are viewing this topic.

Offline piper

  • Global Moderator
  • User
  • *****
  • Posts: 1.730
  • we are the priests ... of the temples of syrinx
Quote from: bad_aptitude
When I run apt dist-upgrade I get the following  removals
Code: [Select]
The following packages will be REMOVED:
  kde-plasma-desktop kde-standard kinfocenter libclass-xsaccessor-perl libqalculate5v5 plasma-desktop
  plasma-mediacenter plasma-widgets-addons plasma-workspace
Seems kind of drastic if I want to continue using KDE.
Should I continue to wait?

Have you actually read this page?, especially page 2

Can you post the whole output of

Code: [Select]
apt -s install libqalculate20
I either give too many fucks or no fucks at all, it's like I cannot find a middle ground for a moderate fuck distribution, it's like what the fuck

Free speech isn't just fucking saying what you want to say, it's also hearing what you don't want to fucking hear

Offline bad_aptitude

  • User
  • Posts: 67
@Piper: Yes, had already read pages on this thread.
Context was lost amongst the rants about holding back packages.


Code: [Select]
apt -s install libqalculate20
Reading package lists... Done
Building dependency tree       
Reading state information... Done
The following packages were automatically installed and are no longer required:
  freetype2-doc g++-7 gcc-6-base:i386 gir1.2-gtk-2.0 gir1.2-harfbuzz-0.0 gnome-themes-standard icu-devtools
  kdesignerplugin-data kdoctools-dev kgendesignerplugin kgendesignerplugin-bin kinit-dev kio-dev libargon2-0
  libarmadillo7 libarmadillo8 libbind9-141 libbind9-160 libboost-atomic1.62.0 libboost-chrono1.62.0
  libboost-date-time1.62.0 libboost-dev libboost-locale1.62.0 libboost-program-options1.62.0 libboost-random1.62.0
  libboost-serialization1.62.0 libboost1.67-dev libcairo-script-interpreter2 libcdio16 libcdio17 libcfitsio5
  libclang1-6.0 libcodec2-0.8 libcrypto++6 libdb5.3++ libdns-export1100 libdns-export169 libdns-export190 libdns1102
  libdns169 libdns190 libegl-mesa0:i386 libegl1:i386 libevent-core-2.0-5 libevent-pthreads-2.0-5 libexpat1-dev
  libflann1.9 libfontconfig1-dev libfreetype6-dev libgbm1:i386 libgdbm5 libgegl-0.3-0 libgeos-3.5.1 libgeos-3.6.2
  libgfortran4 libgit2-26 libgltf-0.0-0v5 libgltf-0.1-1 libgraphite2-3:i386 libgraphite2-dev libgtkglext1
  libharfbuzz-dev libharfbuzz-gobject0 libharfbuzz0b:i386 libhttp-parser2.7.1 libical2-dev libice-dev libicu-dev
  libicu-le-hb-dev libicu-le-hb0:i386 libicu57:i386 libicu60:i386 libiculx63 libidn11:i386 libipt1 libirs160
  libisc-export166 libisc-export189 libisc166 libisc169 libisccc160 libisccfg144 libisccfg160 libiso9660-10
  libkf5akonadi-dev libkf5akonadinotes-dev libkf5akonadiprivate5abi1 libkf5akonadiserver-dev libkf5archive-dev
  libkf5calendarcore-dev libkf5calendarcore5abi1 libkf5calendarutils-dev libkf5cddb-data libkf5contacts-dev
  libkf5crash-dev libkf5dnssd-dev libkf5doctools-dev libkf5emoticons-dev libkf5idletime-dev libkf5itemmodels-dev
  libkf5kcmutils-dev libkf5khtml-dev libkf5kjs-dev libkf5mediaplayer-data libkf5mediaplayer-dev libkf5mediaplayer5
  libkf5mime-dev libkf5mimetreeparser5 libkf5newstuff-dev libkf5notifyconfig-dev libkf5plotting-dev libkf5pty-dev
  libkf5style-dev libkf5su-dev libkf5threadweaver-dev libkf5unitconversion-dev libkf5wallet-dev libkf5webkit-dev
  libkvazaar3 libleveldb1v5 liblivemedia58 liblivemedia61 liblivemedia62 libllvm4.0 libllvm5.0 libllvm5.0:i386
  libllvm6.0 libllvm6.0:i386 liblwres160 libmagickcore-6.q16-5 libmagickcore-6.q16-5-extra libmagickwand-6.q16-5
  libmbedcrypto1 libminiupnpc10 libncurses5:i386 libntfs-3g872 libokular5core7 libomp5 libomp5-7 libopenshot-audio6
  libopenshot14 libopenshot15 libopenshot16 liborcus-0.11-0 liborcus-0.12-0 libperl5.26 libpixman-1-dev libplacebo3
  libpng-dev libpoppler68 libpoppler73 libpoppler74 libproj12 libprotobuf-lite10 libqpdf18 libqt5webkit5-dev
  libraw16 libsbsms10 libsm-dev libsndio6.1:i386 libstd-rust-1.16 libstd-rust-1.18 libstd-rust-1.21 libstd-rust-1.22
  libstd-rust-1.23 libstd-rust-1.24 libstd-rust-1.26 libstd-rust-1.28 libstd-rust-1.30 libstd-rust-dev
  libstdc++-7-dev libsuitesparseconfig4 libtesseract-data libtesseract3 libtinfo5:i386 libtinyxml2-5 libupnp10
  libva-glx1 libwayland-egl1-mesa:i386 libwayland-server0:i386 libx264-152 libx265-130 libx265-146 libx265-160
  libxcb-shm0-dev libxcomposite-dev libxcursor-dev libxerces-c-dev libxft-dev libxi-dev libxinerama-dev
  libxrandr-dev libxrender-dev linux-headers-4.15.10-towo.2-siduction-amd64
  linux-headers-4.16.0-towo.1-siduction-amd64 linux-headers-4.16.5-towo.1-siduction-amd64
  linux-headers-4.17.1-towo.4-siduction-amd64 linux-headers-4.17.12-towo.1-siduction-amd64
  linux-headers-4.17.2-towo.2-siduction-amd64 linux-headers-4.19.1-towo.1-siduction-amd64
  linux-headers-4.19.1-towo.2-siduction-amd64 linux-image-4.15.10-towo.2-siduction-amd64
  linux-image-4.16.0-towo.1-siduction-amd64 linux-image-4.16.5-towo.1-siduction-amd64
  linux-image-4.17.1-towo.4-siduction-amd64 linux-image-4.17.12-towo.1-siduction-amd64
  linux-image-4.17.2-towo.2-siduction-amd64 linux-image-4.19.1-towo.1-siduction-amd64
  linux-image-4.19.1-towo.2-siduction-amd64 openshot-qt perl-modules-5.26 python-attr python-automat python-certifi
  python-constantly python-dnspython python-ecdsa python-feedparser python-hyperlink python-incremental
  python-jsonrpclib python-openssl python-pbkdf2 python-protobuf python-psutil python-pyaes python-pyasn1
  python-pyasn1-modules python-qrcode python-qt4reactor python-requests python-service-identity python-slowaes
  python-socks python-twisted python-twisted-bin python-twisted-core python-urllib3 python-zope.interface
  python3-openshot python3-pbkdf2 python3-pyasn1 python3-pyqt5.qtmultimedia python3-pyqt5.qtopengl
  python3-pyqt5.qtsvg python3-pyqt5.qtwebkit python3-zmq python3.6 python3.6-minimal qml-module-org-kde-kirigami
  transcode-doc uuid-dev x11proto-composite-dev x11proto-dri2-dev x11proto-gl-dev x11proto-randr-dev
  x11proto-render-dev x11proto-xinerama-dev
Use 'apt autoremove' to remove them.
The following additional packages will be installed:
  libqalculate20-data plasma-workspace
The following packages will be REMOVED:
  libqalculate5-data libqalculate5v5
The following NEW packages will be installed:
  libqalculate20 libqalculate20-data
The following packages will be upgraded:
  plasma-workspace
1 upgraded, 2 newly installed, 2 to remove and 136 not upgraded.
Inst plasma-workspace [4:5.14.3-1] (4:5.14.3-1+b1 Debian:unstable [amd64]) []
Remv libqalculate5v5 [0.9.7-9.2+b1] []
Remv libqalculate5-data [0.9.7-9.2] []
Inst libqalculate20-data (2.8.0-2 Debian:unstable [all]) []
Inst libqalculate20 (2.8.0-2 Debian:unstable [amd64])
Conf plasma-workspace (4:5.14.3-1+b1 Debian:unstable [amd64])
Conf libqalculate20-data (2.8.0-2 Debian:unstable [all])
Conf libqalculate20 (2.8.0-2 Debian:unstable [amd64])


Offline piper

  • Global Moderator
  • User
  • *****
  • Posts: 1.730
  • we are the priests ... of the temples of syrinx
Ok, do

Code: [Select]
apt update; apt install libqalculate20
Let it remove libqalculate5-data libqalculate5v5,

plasma-workspace will be updated.

When that is done, do

Code: [Select]
apt update; apt full-upgrade
You *should be good to go, if you aren't sure about anything, post the output of any errors or removals.

I either give too many fucks or no fucks at all, it's like I cannot find a middle ground for a moderate fuck distribution, it's like what the fuck

Free speech isn't just fucking saying what you want to say, it's also hearing what you don't want to fucking hear

Offline bad_aptitude

  • User
  • Posts: 67
@piper
this worked perfectly. No errors and no removals with apt full-upgrade.
Booted into KDE - no problems


Thanks
b

Offline piper

  • Global Moderator
  • User
  • *****
  • Posts: 1.730
  • we are the priests ... of the temples of syrinx
Glad it worked :)

Don't thank me, thank finotti
I either give too many fucks or no fucks at all, it's like I cannot find a middle ground for a moderate fuck distribution, it's like what the fuck

Free speech isn't just fucking saying what you want to say, it's also hearing what you don't want to fucking hear

Offline finotti

  • User
  • Posts: 128
What was weird is that in two of my systems apt wanted to remove a lot of plasma packages (solved as above) while in a third it just replaced libqalculate5v5 with libqalculate20 and upgrade plasma without any removals (as it should).  I have no idea what the difference was...

Offline piper

  • Global Moderator
  • User
  • *****
  • Posts: 1.730
  • we are the priests ... of the temples of syrinx
It could of been just good timing of the transition at the time → auto-libqalculate (100%)
I either give too many fucks or no fucks at all, it's like I cannot find a middle ground for a moderate fuck distribution, it's like what the fuck

Free speech isn't just fucking saying what you want to say, it's also hearing what you don't want to fucking hear

Offline jyp

  • User
  • Posts: 75
Trying to get up to date after being cut from my computers for almost 2 months. But ...
Code: [Select]
The following packages will be REMOVED:
blogilo colord digikam digikam-private-libs hplip kdegraphics kipi-plugins kolourpaint kolourpaint4 libcupscgi1 libcupsmime1 libcupsppdc1 libhdf5-100 libkf5akonadicore5abi1 libkf5alarmcalendar5 libkf5eventviews5 libkf5gravatar5abi1 libkf5ldap5 libkf5mailcommon5abi1 libkf5messagecomposer5 libkf5messagecore5 libkf5messagelist5 libkf5messageviewer5 libkf5pimcommon5abi1 libkf5pimcommonakonadi5 libkf5pimtextedit5abi1 libkf5sane5 libkf5webengineviewer5 libkpimgapiblogger5 libkpimgapicore5 libkpimkdav5abi1 libkpimsmtp5 libmbedtls10 libqalculate5-data libqalculate5v5 libsane1 sane-utils skanlite xsane
Most of the libkf5 are going to be replaced but many others won't. As suggested, I tried to install libqalculate20 but ...
Code: [Select]
apt install libqalculate20
Reading package lists... Done
Building dependency tree
Reading state information... Done
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
 libkf5iconthemes5 : Breaks: libkf5wallet-bin (< 5.51) but 5.49.0-1 is to be installed
                              Recommends: libkf5iconthemes-bin (= 5.51.0-1) but 5.49.0-1 is to be installed
E: Error, pkgProblemResolver::Resolve generated breaks, this may be caused by held packages.
I didn't held packages.
So, I am looking for advices: should I do an upgrade first (a procedure that I never used before) and then a full-upgrade?
Thanks


Offline der_bud

  • User
  • Posts: 907
  • member
Here,  libkf5iconthemes-bin is installed as 5.51-0.1, perhaps your mirror was not up-to-date when you tried? Do apt update again, and then check apt-cache policy libkf5iconthemes-bin. Have you already tried apt-get install -f ?
Du lachst? Wieso lachst du? Das ist doch oft so, Leute lachen erst und dann sind sie tot.

Offline piper

  • Global Moderator
  • User
  • *****
  • Posts: 1.730
  • we are the priests ... of the temples of syrinx
Code: [Select]
libsane1 ibqalculate5v5
Is the problem

Code: [Select]
apt install libsane libqalculate20
« Last Edit: 2018/12/03, 20:22:34 by piper »
I either give too many fucks or no fucks at all, it's like I cannot find a middle ground for a moderate fuck distribution, it's like what the fuck

Free speech isn't just fucking saying what you want to say, it's also hearing what you don't want to fucking hear

Offline jyp

  • User
  • Posts: 75
@der-bud
Code: [Select]
apt policy libkf5iconthemes-bin
libkf5iconthemes-bin:
  Installed: 5.49.0-1
  Candidate: 5.51.0-1
@piperYes, but libqalculate20 would need <apt install -f> maybe.
Code: [Select]
apt policy libqalculate20
libqalculate20:
  Installed: (none)
  Candidate: 2.8.0-2
Would <apt upgrade> be a proper first step?

Offline piper

  • Global Moderator
  • User
  • *****
  • Posts: 1.730
  • we are the priests ... of the temples of syrinx
Can I see the output of


Code: [Select]
apt install -s libsane libqalculate20
I either give too many fucks or no fucks at all, it's like I cannot find a middle ground for a moderate fuck distribution, it's like what the fuck

Free speech isn't just fucking saying what you want to say, it's also hearing what you don't want to fucking hear

Offline jyp

  • User
  • Posts: 75
@piper
Code: [Select]
apt install -s libsane libqalculate20
Reading package lists... Done
Building dependency tree
Reading state information... Done
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
 libkf5iconthemes5 : Breaks: libkf5wallet-bin (< 5.51) but 5.49.0-1 is to be installed
                     Recommends: libkf5iconthemes-bin (= 5.51.0-1) but 5.49.0-1 is to be installed
E: Error, pkgProblemResolver::Resolve generated breaks, this may be caused by held packages.

Offline piper

  • Global Moderator
  • User
  • *****
  • Posts: 1.730
  • we are the priests ... of the temples of syrinx
The  libkf5wallet-bin is because of qtbase-opensource-src (auto) and more
I either give too many fucks or no fucks at all, it's like I cannot find a middle ground for a moderate fuck distribution, it's like what the fuck

Free speech isn't just fucking saying what you want to say, it's also hearing what you don't want to fucking hear

Offline jyp

  • User
  • Posts: 75
Thanks
Is there a way out besides "patience" ?