seduction
 Language:
Welcome, Guest. Please login or register.
Did you miss your activation email?
2019/02/18, 10:52:47


Help

Author [EN] [PL] [ES] [PT] [IT] [DE] [FR] [NL] [TR] [SR] [AR] [RU] Topic: Cannot remove OpenMPI, Need to for update  (Read 214 times)

0 Members and 1 Guest are viewing this topic.

Offline geklmintendont

  • User
  • Posts: 39
  • Banned User
Cannot remove OpenMPI, Need to for update
« on: 2019/02/05, 00:40:54 »
I cannot remove OpenMPI and I supposedly need to for the full-upgrade.


Here's the error message that Synaptic gives back (I tried through apt also):
Code: [Select]
E: libopenmpi-dev: 25.0000:installed libopenmpi-dev:amd64 package post-removal script subprocess returned error exit status 1
E: libopenmpi3: 50.0000:installed libopenmpi3:amd64 package post-removal script subprocess returned error exit status 1
E: openmpi-common: installed openmpi-common package post-removal script subprocess returned error exit status 1




I'm very worried. What are my options? My oldest backup makes this error, so I can't load a backup.
I'm banned forever - the Mods had good reasons to do so.

Offline dibl

  • siduction community member
  • Global Moderator
  • User
  • *****
  • Posts: 1.838
    • Land of the Buckeye
Re: Cannot remove OpenMPI, Need to for update
« Reply #1 on: 2019/02/05, 12:21:25 »
As root at tty1, X server closed:

Code: [Select]
apt purge libopenmpi-dev
Code: [Select]
apt purge libopenmpi3
Code: [Select]
apt purge openmpi-common
Code: [Select]
dpkg --configure -a
Code: [Select]
apt update && apt full-upgrade
Asus ROG STRIX X299-E, Core i7-7740X, Nvidia GTX-1060, dual monitors, SSD 860 EVO, 2@WD1003FZEX in BTRFS

Offline piper

  • Global Moderator
  • User
  • *****
  • Posts: 1.556
  • we are the priests ... of the temples of syrinx
Re: Cannot remove OpenMPI, Need to for update
« Reply #2 on: 2019/02/05, 13:45:47 »
if the above don't work, try

Code: [Select]
apt purge libopenmpi.
Don't forget the period !!!

Then do

Code: [Select]
apt autoremove
and

Code: [Select]
apt update; apt install -fy
Any errors post them, if it's like your other post, I for one won't respond

Why you are still getting this error means you don't do a full-upgrade often enough.

If you want to continue using siduction (sid), you must full-upgrade often, at least once a week, 2 weeks tops, your errors are old and have been fixed awhile ago.

Hint: Stop using synaptic in sid, it will break your system sooner or later.
« Last Edit: 2019/02/06, 00:04:36 by piper »
"We're all grown up and don't freak out when a piece of text contains the word 'fuck'. I still don't understand why people think that the word 'fuck' is what would keep certain groups from contributing to the Linux kernel. In all seriousness, it doesn't."

John Paul Adrian Glaubitz

Offline David

  • Gamer Aristocrat
  • User
  • Posts: 14
  • unstable is the most stable #gamersriseup
Re: Cannot remove OpenMPI, Need to for update
« Reply #3 on: Yesterday at 21:11:39 »
I'm having the same problem. How do I close the X server, and is it really necessary to remove OpenMPI? Sorry, I'm sort of new to this.
we gamers have fought a thousand battles and defeated millions of aliens, monsters, and demons. We have played the call of dutys and are knowledgeable in firearms. No longer will the gamer be oppressed by the chad.

gamers, it is time to rise up

Offline David

  • Gamer Aristocrat
  • User
  • Posts: 14
  • unstable is the most stable #gamersriseup
Re: Cannot remove OpenMPI, Need to for update
« Reply #4 on: Yesterday at 21:17:24 »

if the above don't work, try

Code: [Select]
apt purge libopenmpi.
Don't forget the period !!!

Then do

Code: [Select]
apt autoremove
and

Code: [Select]
apt update; apt install -fy
Any errors post them, if it's like your other post, I for one won't respond

Why you are still getting this error means you don't do a full-upgrade often enough.

If you want to continue using siduction (sid), you must full-upgrade often, at least once a week, 2 weeks tops, your errors are old and have been fixed awhile ago.

Hint: Stop using synaptic in sid, it will break your system sooner or later.


I tried your solution piper and this is what it did:


Code: [Select]

root@gek-pc:/home/gek# apt update
Ign:1 http://dl.google.com/linux/earth/deb stable InRelease
Hit:2 http://dl.google.com/linux/earth/deb stable Release     
Hit:3 http://deb.debian.org/debian unstable InRelease                         
Hit:5 http://ftp.spline.de/pub/siduction/extra unstable InRelease             
Hit:6 https://packages.siduction.org/fixes unstable InRelease                 
Reading package lists... Done                                                 
Building dependency tree       
Reading state information... Done
1232 packages can be upgraded. Run 'apt list --upgradable' to see them.
N: Skipping acquire of configured file 'main/binary-i386/Packages' as repository 'http://dl.google.com/linux/earth/deb stable InRelease' doesn't support architecture 'i386'
root@gek-pc:/home/gek# apt purge libopenmpi.
Reading package lists... Done
Building dependency tree       
Reading state information... Done
Note, selecting 'libopenmpi3' for regex 'libopenmpi.'
Note, selecting 'libopenmpi-dev' for regex 'libopenmpi.'
The following packages were automatically installed and are no longer required:
  ibverbs-providers libevent-core-2.1-6 libevent-pthreads-2.1-6 libfabric1
  libhwloc-dev libhwloc-plugins libhwloc5 libibverbs-dev libibverbs1
  libnl-3-dev libnl-route-3-200 libnl-route-3-dev libnuma-dev libpmix2
  libpsm-infinipath1 libpsm2-2 librdmacm1
Use 'apt autoremove' to remove them.
The following packages will be REMOVED:
  libopenmpi-dev* libopenmpi3 openmpi-common
0 upgraded, 0 newly installed, 3 to remove and 1230 not upgraded.
2 not fully installed or removed.
After this operation, 9,231 kB disk space will be freed.
Do you want to continue? [Y/n] y
(Reading database ... 296053 files and directories currently installed.)
Removing libopenmpi3:amd64 (3.1.3-5) ...
rm: cannot remove '/usr/lib/x86_64-linux-gnu/fortran/gfortran-8#': No such file or directory
rm: cannot remove 'End': No such file or directory
rm: cannot remove 'automatically': No such file or directory
rm: cannot remove 'added': No such file or directory
rm: cannot remove 'section': No such file or directory
dpkg: error processing package libopenmpi3:amd64 (--remove):
 installed libopenmpi3:amd64 package post-removal script subprocess returned error exit status 1
Removing openmpi-common (3.1.3-5) ...
rm: cannot remove '/usr/lib/x86_64-linux-gnu/fortran/gfortran-8#': No such file or directory
rm: cannot remove 'End': No such file or directory
rm: cannot remove 'automatically': No such file or directory
rm: cannot remove 'added': No such file or directory
rm: cannot remove 'section': No such file or directory
dpkg: error processing package openmpi-common (--remove):
 installed openmpi-common package post-removal script subprocess returned error exit status 1
dpkg: warning: ignoring request to remove libopenmpi-dev:amd64, only the config
 files of which are on the system; use --purge to remove them too
Errors were encountered while processing:
 libopenmpi3:amd64
 openmpi-common
W: Can not find PkgVer for 'libopenmpi-dev'
E: Sub-process /usr/bin/dpkg returned an error code (1)
root@gek-pc:/home/gek# apt autoremove
Reading package lists... Done
Building dependency tree       
Reading state information... Done
The following packages will be REMOVED:
  ibverbs-providers libevent-core-2.1-6 libevent-pthreads-2.1-6 libfabric1
  libhwloc-dev libhwloc-plugins libhwloc5 libibverbs-dev libibverbs1
  libnl-3-dev libnl-route-3-200 libnl-route-3-dev libnuma-dev libopenmpi3
  libpmix2 libpsm-infinipath1 libpsm2-2 librdmacm1 openmpi-common
0 upgraded, 0 newly installed, 19 to remove and 1229 not upgraded.
2 not fully installed or removed.
After this operation, 19.8 MB disk space will be freed.
Do you want to continue? [Y/n] y
(Reading database ... 296053 files and directories currently installed.)
Removing libopenmpi3:amd64 (3.1.3-5) ...
rm: cannot remove '/usr/lib/x86_64-linux-gnu/fortran/gfortran-8#': No such file or directory
rm: cannot remove 'End': No such file or directory
rm: cannot remove 'automatically': No such file or directory
rm: cannot remove 'added': No such file or directory
rm: cannot remove 'section': No such file or directory
dpkg: error processing package libopenmpi3:amd64 (--remove):
 installed libopenmpi3:amd64 package post-removal script subprocess returned error exit status 1
Removing openmpi-common (3.1.3-5) ...
rm: cannot remove '/usr/lib/x86_64-linux-gnu/fortran/gfortran-8#': No such file or directory
rm: cannot remove 'End': No such file or directory
rm: cannot remove 'automatically': No such file or directory
rm: cannot remove 'added': No such file or directory
rm: cannot remove 'section': No such file or directory
dpkg: error processing package openmpi-common (--remove):
 installed openmpi-common package post-removal script subprocess returned error exit status 1
Removing libibverbs-dev:amd64 (22.1-1) ...
Removing ibverbs-providers:amd64 (22.1-1) ...
Removing libpmix2:amd64 (3.1.2-2) ...
Removing libevent-pthreads-2.1-6:amd64 (2.1.8-stable-4) ...
Removing libevent-core-2.1-6:amd64 (2.1.8-stable-4) ...
Removing libfabric1 (1.6.2-3) ...
Removing libhwloc-dev:amd64 (1.11.12-3) ...
Removing libhwloc-plugins:amd64 (1.11.12-3) ...
Removing libhwloc5:amd64 (1.11.12-3) ...
Removing librdmacm1:amd64 (22.0-1) ...
Removing libibverbs1:amd64 (22.1-1) ...
Removing libnl-route-3-dev:amd64 (3.4.0-1) ...
Removing libnl-3-dev:amd64 (3.4.0-1) ...
Removing libnl-route-3-200:amd64 (3.4.0-1) ...
Removing libnuma-dev:amd64 (2.0.12-1) ...
Removing libpsm-infinipath1 (3.3+20.604758e7-6) ...
update-alternatives: warning: alternative /usr/lib/libpsm1/libpsm_infinipath.so.1.16 (part of link group libpsm_infinipath.so.1) doesn't exist; removing from list of alternatives
update-alternatives: warning: /etc/alternatives/libpsm_infinipath.so.1 is dangling; it will be updated with best choice
Removing libpsm2-2 (11.2.78-1) ...
Errors were encountered while processing:
 libopenmpi3:amd64
 openmpi-common
E: Sub-process /usr/bin/dpkg returned an error code (1)
root@gek-pc:/home/gek# apt update; apt install -fy
Ign:1 http://dl.google.com/linux/earth/deb stable InRelease
Hit:2 http://dl.google.com/linux/earth/deb stable Release                     
Hit:3 http://deb.debian.org/debian unstable InRelease                         
Hit:4 http://ftp.spline.de/pub/siduction/extra unstable InRelease             
Hit:6 https://packages.siduction.org/fixes unstable InRelease                 
Reading package lists... Done                     
Building dependency tree       
Reading state information... Done
1231 packages can be upgraded. Run 'apt list --upgradable' to see them.
N: Skipping acquire of configured file 'main/binary-i386/Packages' as repository 'http://dl.google.com/linux/earth/deb stable InRelease' doesn't support architecture 'i386'
Reading package lists... Done
Building dependency tree       
Reading state information... Done
The following packages will be REMOVED:
  libopenmpi3 openmpi-common
0 upgraded, 0 newly installed, 2 to remove and 1229 not upgraded.
2 not fully installed or removed.
After this operation, 9,231 kB disk space will be freed.
(Reading database ... 295515 files and directories currently installed.)
Removing libopenmpi3:amd64 (3.1.3-5) ...
rm: cannot remove '/usr/lib/x86_64-linux-gnu/fortran/gfortran-8#': No such file or directory
rm: cannot remove 'End': No such file or directory
rm: cannot remove 'automatically': No such file or directory
rm: cannot remove 'added': No such file or directory
rm: cannot remove 'section': No such file or directory
dpkg: error processing package libopenmpi3:amd64 (--remove):
 installed libopenmpi3:amd64 package post-removal script subprocess returned error exit status 1
Removing openmpi-common (3.1.3-5) ...
rm: cannot remove '/usr/lib/x86_64-linux-gnu/fortran/gfortran-8#': No such file or directory
rm: cannot remove 'End': No such file or directory
rm: cannot remove 'automatically': No such file or directory
rm: cannot remove 'added': No such file or directory
rm: cannot remove 'section': No such file or directory
dpkg: error processing package openmpi-common (--remove):
 installed openmpi-common package post-removal script subprocess returned error exit status 1
Errors were encountered while processing:
 libopenmpi3:amd64
 openmpi-common
E: Sub-process /usr/bin/dpkg returned an error code (1)



we gamers have fought a thousand battles and defeated millions of aliens, monsters, and demons. We have played the call of dutys and are knowledgeable in firearms. No longer will the gamer be oppressed by the chad.

gamers, it is time to rise up

Offline piper

  • Global Moderator
  • User
  • *****
  • Posts: 1.556
  • we are the priests ... of the temples of syrinx
Re: Cannot remove OpenMPI, Need to for update
« Reply #5 on: Yesterday at 21:37:17 »
Your only allowed to login not because you changed your ip address (that means nothing, you can change that all day) its because who owns your internet (windstream.net/TierPoint) that you can't change, this is a last  "warning"

https://bugs.debian.org/cgi-bin/bugreport.cgi?bug=917133

https://bugs.debian.org/cgi-bin/bugreport.cgi?bug=918000
« Last Edit: Yesterday at 21:41:03 by piper »
"We're all grown up and don't freak out when a piece of text contains the word 'fuck'. I still don't understand why people think that the word 'fuck' is what would keep certain groups from contributing to the Linux kernel. In all seriousness, it doesn't."

John Paul Adrian Glaubitz

Offline David

  • Gamer Aristocrat
  • User
  • Posts: 14
  • unstable is the most stable #gamersriseup
Re: Cannot remove OpenMPI, Need to for update
« Reply #6 on: Today at 07:39:00 »
Your only allowed to login not because you changed your ip address (that means nothing, you can change that all day) its because who owns your internet (windstream.net/TierPoint) that you can't change, this is a last  "warning"

https://bugs.debian.org/cgi-bin/bugreport.cgi?bug=917133

https://bugs.debian.org/cgi-bin/bugreport.cgi?bug=918000


are you talking to me? Because I have windstream. What am I being warned for? Whatever it is, I'm sorry, i'm new to this forum. I'm sorry, forgive me.


thanks for the help btw, I did eventually figure out what to do. there was a faulty line in the postrm script for openmpi-common and libopenmpi3. If you want to fix it, I have a solution posted in my thread under upgrade warnings. You'll have to get dirty with vim but you guys look like you know everything.


Thanks for the help though
we gamers have fought a thousand battles and defeated millions of aliens, monsters, and demons. We have played the call of dutys and are knowledgeable in firearms. No longer will the gamer be oppressed by the chad.

gamers, it is time to rise up

Offline der_bud

  • User
  • Posts: 863
  • member
Re: Cannot remove OpenMPI, Need to for update
« Reply #7 on: Today at 08:49:53 »
Just please don't take the readers/users in this forum for complete idiots. Better keep the past behind without further arguing, really. Use the chance, move forward.
Du lachst? Wieso lachst du? Das ist doch oft so, Leute lachen erst und dann sind sie tot.