seduction
 Language:
Welcome, Guest. Please login or register.
Did you miss your activation email?
2019/10/21, 08:09:50


Help

Author [EN] [PL] [ES] [PT] [IT] [DE] [FR] [NL] [TR] [SR] [AR] [RU] Topic: kde-runtime removal in upgrade  (Read 1051 times)

0 Members and 1 Guest are viewing this topic.

Offline Pip

  • User
  • Posts: 55
kde-runtime removal in upgrade
« on: 2019/09/24, 10:19:05 »
Probably not something wanted, and doubtless will pass soon.
The following packages were automatically installed and are no longer required:
  kate-data katepart kde-runtime-data kdelibs-bin kdelibs5-data kdelibs5-plugins kdoctools libattica0.4 libbctoolbox1 libbzrtp0 libdbusmenu-qt2  libdlrestrictions1 libgadu3 libgpgme++2v5 libilmbase23 libkabc4 libkactivities6
libkatepartinterfaces4 libkcmutils4 libkde3support4 libkdeclarative5  libkdecore5 libkdesu5 libkdeui5 libkdewebkit5
libkdnssd4 libkemoticons4 libkfile4 libkhtml5 libkio5 libkjsapi4 libkjsembed4 libkldap4  libkmediaplayer4 libkmime4
libknewstuff2-4 libknewstuff3-4 libknotifyconfig4 libkntlm4 libkopete4 libkparts4 libkpimidentities4 libkpimtextedit4 
libkpimutils4 libkpty4 libkresources4 libkrosscore4 libktexteditor4 liblouis17 libmeanwhile1 libmediastreamer-base10
libmediastreamer-voip10  libntrack-qt4-1 libntrack0 libopenexr23 libortp13 libotr5 libphonon4 libplasma3 libpolkit-qt-1-1
libqca2 libqca2-plugins libqimageblitz4 libqjson0  libqt4-declarative libqt4-designer libqt4-network libqt4-opengl
libqt4-qt3support libqt4-script libqt4-sql libqt4-sql-mysql libqt4-sql-sqlite  libqt4-xmlpatterns libqtwebkit4 libsolid4
libthreadweaver4 libturbojpeg0 libxxhash0 ntrack-module-libnl-0 oxygen-icon-theme  plasma-scriptengine-javascript
Use 'sudo apt autoremove' to remove them.
The following packages will be REMOVED:
  kde-runtime kopete phonon phonon-backend-gstreamer
The following NEW packages will be installed:
  liblouis19


Offline jure

  • User
  • Posts: 520
Re: kde-runtime removal in upgrade
« Reply #1 on: 2019/09/24, 10:52:44 »
here my kde system

Code: [Select]
LANG=C apt dist-upgrade
Reading package lists... Done
Building dependency tree       
Reading state information... Done
Calculating upgrade... Done
The following packages have been kept back:
  phonon-backend-gstreamer-common
0 upgraded, 0 newly installed, 0 to remove and 1 not upgraded.
Gruss Juergen

Offline dibl

  • siduction community member
  • Global Moderator
  • User
  • *****
  • Posts: 1.922
    • Land of the Buckeye
Re: kde-runtime removal in upgrade
« Reply #2 on: 2019/09/24, 23:28:09 »
@jure:

Code: [Select]
root@dibl-patience:/# apt policy phonon-backend-gstreamer-common
phonon-backend-gstreamer-common:
  Installed: 4:4.9.1-2
  Candidate: 4:4.9.1-2
  Version table:
 *** 4:4.9.1-2 500
        500 http://httpredir.debian.org/debian unstable/main amd64 Packages

Try

Code: [Select]
apt -s install phonon-backend-gstreamer-common
I think you will find that it will install and remove an older version with a slightly different package name.
Asus ROG STRIX X299-E, Core i7-7740X, Nvidia GTX-1060, dual monitors, SSD 860 EVO, 2@WD1003FZEX in BTRFS

Offline Pip

  • User
  • Posts: 55
Re: kde-runtime removal in upgrade
« Reply #3 on: 2019/09/25, 07:43:32 »
The kde-runtime removal has gone away after an update this morning. Thanks for the phonon suggestion, Dibl.

Offline jure

  • User
  • Posts: 520
Re: kde-runtime removal in upgrade
« Reply #4 on: 2019/09/25, 09:16:05 »
thx dibl that works for me too

Code: [Select]
apt -s install phonon-backend-gstreamer-common
Gruss Juergen

Offline mash

  • User
  • Posts: 29
Re: kde-runtime removal in upgrade
« Reply #5 on: 2019/10/09, 14:00:53 »
When I enter
Code: [Select]
apt -s install phonon-backend-gstreamer-common
I get:
Code: [Select]
The following additional packages will be installed:
  phonon4qt5-backend-gstreamer
Suggested packages:
  phonon-backend-gstreamer
The following packages will be REMOVED:
  kaccessible kde-runtime kopete phonon phonon-backend-gstreamer
The following packages will be upgraded:
  phonon-backend-gstreamer-common phonon4qt5-backend-gstreamer
2 upgraded, 0 newly installed, 5 to remove and 332 not upgraded.
Remv kaccessible [4:17.08.3-1]
Remv kopete [4:17.08.3-2.1]
Remv kde-runtime [4:17.08.3-2.1]
Remv phonon [4:4.10.3-2]
Remv phonon-backend-gstreamer [4:4.9.1-1]
Inst phonon4qt5-backend-gstreamer [4:4.9.1-1] (4:4.9.1-2 Debian:unstable [amd64]) []
Inst phonon-backend-gstreamer-common [4:4.9.1-1] (4:4.9.1-2 Debian:unstable [amd64])
Conf phonon4qt5-backend-gstreamer (4:4.9.1-2 Debian:unstable [amd64])
Conf phonon-backend-gstreamer-common (4:4.9.1-2 Debian:unstable [amd64])

when it was hard to write it should be hard to read

Offline melmarker

  • Global Moderator
  • User
  • *****
  • Posts: 2.756
    • g-com.eu
Re: kde-runtime removal in upgrade
« Reply #6 on: 2019/10/09, 19:46:56 »
And where is the problem in removing the old and no longer maintained Qt4-Stuff?
Those who would give up essential Liberty, to purchase a little temporary Safety, deserve neither Liberty nor Safety. (Benjamin Franklin, November 11, 1755)
Never attribute to malice that which can be adequately explained by stupidity. (Hanlons razor)

Offline jure

  • User
  • Posts: 520
Gruss Juergen

Offline tubabaeda

  • Newbie
  • Posts: 2
Re: kde-runtime removal in upgrade
« Reply #8 on: 2019/10/10, 10:04:07 »
Ohne "kde-runtime" funktioniert mein treuer und langjähriger Begleiter, das "armor-Kätzchen", nicht mehr. :(

Gruß, Bäda

Offline melmarker

  • Global Moderator
  • User
  • *****
  • Posts: 2.756
    • g-com.eu
Re: kde-runtime removal in upgrade
« Reply #9 on: 2019/10/10, 11:10:06 »
Das Leben ist hart und auch armor-Kätzchen haben eine begrenzte Lebensdauer
Those who would give up essential Liberty, to purchase a little temporary Safety, deserve neither Liberty nor Safety. (Benjamin Franklin, November 11, 1755)
Never attribute to malice that which can be adequately explained by stupidity. (Hanlons razor)