seduction
 Language:
Welcome, Guest. Please login or register.
Did you miss your activation email?
2020/10/20, 02:09:22


Help

Author [EN] [PL] [ES] [PT] [IT] [DE] [FR] [NL] [TR] [SR] [AR] [RU] Topic: KDE-Systemsettings ends up in crash, kcmshell5 kcm_kscreen too  (Read 1603 times)

0 Members and 1 Guest are viewing this topic.

Offline tomsiduction

  • User
  • Posts: 140
Hello
My KDE-Systemsettings end up in crash.

Code: [Select]
systemsettings5
file:///usr/lib/x86_64-linux-gnu/qt5/qml/org/kde/kirigami.2/SearchField.qml:47:9: QML Action: LayoutDirection attached property only works with Items and Windows
kf5.kactivity.stat: [Error at ResultSetPrivate::initQuery]:  QSqlError("1", "Unable to execute statement", "no such column: rl.initiatingAgent")
kf5.kactivity.stat: [Error at ResultSetPrivate::initQuery]:  QSqlError("1", "Unable to execute statement", "no such column: rl.initiatingAgent")
KCrash: crashing... crashRecursionCounter = 2
KCrash: Application Name = systemsettings5 path = /usr/bin pid = 2776
KCrash: Arguments: /usr/bin/systemsettings5
KCrash: Attempting to start /usr/lib/x86_64-linux-gnu/libexec/drkonqi from kdeinit
sock_file=/run/user/1000/kdeinit5__0

[1]+  Angehalten              systemsettings5

A


kcmshell5 kcm_kscreen
ends up in crash too.


Code: [Select]
kcmshell5 kcm_kscreen

org.kde.kcoreaddons: Error loading plugin "kcm_kscreen" "The shared library was not found."
Plugin search paths are ("/usr/lib/x86_64-linux-gnu/qt5/plugins", "/usr/bin")
The environment variable QT_PLUGIN_PATH might be not correctly set
file:///usr/lib/x86_64-linux-gnu/qt5/qml/org/kde/kirigami.2/templates/InlineMessage.qml:136: TypeError: Value is undefined and could not be converted to an object
file:///usr/lib/x86_64-linux-gnu/qt5/qml/org/kde/kirigami.2/templates/InlineMessage.qml:136: TypeError: Value is undefined and could not be converted to an object
file:///usr/lib/x86_64-linux-gnu/qt5/qml/org/kde/kirigami.2/templates/InlineMessage.qml:136: TypeError: Value is undefined and could not be converted to an object
file:///usr/lib/x86_64-linux-gnu/qt5/qml/org/kde/kirigami.2/templates/InlineMessage.qml:136: TypeError: Value is undefined and could not be converted to an object
file:///usr/lib/x86_64-linux-gnu/qt5/qml/org/kde/kirigami.2/templates/InlineMessage.qml:136: TypeError: Value is undefined and could not be converted to an object
KCrash: crashing... crashRecursionCounter = 2
KCrash: Application Name = kcmshell5 path = /usr/bin pid = 3566
KCrash: Arguments: /usr/bin/kcmshell5 kcm_kscreen
KCrash: Attempting to start /usr/lib/x86_64-linux-gnu/libexec/drkonqi from kdeinit
sock_file=/run/user/1000/kdeinit5__0

Is there any kind of workaround ?

Regards
« Last Edit: 2020/05/02, 05:26:08 by tomsiduction »

Offline piper

  • Global Moderator
  • User
  • *****
  • Posts: 1.787
  • we are the priests ... of the temples of syrinx
Your problem is kirigami, it was removed from debian 2 years ago, purge it and you should be fine
Free speech isn't just fucking saying what you want to say, it's also hearing what you don't want to fucking hear

I either give too many fucks or no fucks at all, it's like I cannot find a middle ground for a moderate fuck distribution, it's like what the fuck

Offline tomsiduction

  • User
  • Posts: 140
Hello and thank you

Removing kirigami will remove other packages too.

Code: [Select]
apt remove qml-module-org-kde-kirigami2
Paketlisten werden gelesen... Fertig
Abhängigkeitsbaum wird aufgebaut.
Statusinformationen werden eingelesen.... Fertig
Die folgenden Pakete wurden automatisch installiert und werden nicht mehr benötigt:
  libcolorcorrect5 libgps26 libibus-1.0-5 libkf5kirigami2-5
  libnotificationmanager1 libqalculate20 libqalculate20-data
  libtaskmanager6abi1 plasma-workspace-data qml-module-qtwebengine
Verwenden Sie »apt autoremove«, um sie zu entfernen.
Die folgenden Pakete werden ENTFERNT:
  kde-plasma-desktop kinfocenter plasma-desktop plasma-integration
  plasma-mediacenter plasma-widgets-addons plasma-workspace
  qml-module-org-kde-kcm qml-module-org-kde-kirigami2
  qml-module-org-kde-qqc2desktopstyle sddm-theme-breeze systemsettings

a lot of kde-plasma stuff.

Can I remove it without taking a risk to loose kde-plasma?

Regards


(just to explain: I removed "kirigami" and reinstalled
kde-plasma-desktop
 kinfocenter
 plasma-desktop
 plasma-integration
  qml-module-org-kde-kcm
  qml-module-org-kde-qqc2desktopstyle
sddm-theme-breeze
systemsettings

but after starting I get only a (single) mouse-cursor on a black screen.)
« Last Edit: 2020/05/01, 16:47:21 by tomsiduction »

Offline hendrikL

  • User
  • Posts: 438
The best way to shot yourself in the foot!

So what you can try first, before reinstalling,

Code: [Select]
apt update; apt install --install-recommends plasma-workspace
good luck

Offline piper

  • Global Moderator
  • User
  • *****
  • Posts: 1.787
  • we are the priests ... of the temples of syrinx
Can I ask what your using kirigami2 for?
I build a lot of roms in android and other things, I have never used this, just curious.

danke hendrikL
Free speech isn't just fucking saying what you want to say, it's also hearing what you don't want to fucking hear

I either give too many fucks or no fucks at all, it's like I cannot find a middle ground for a moderate fuck distribution, it's like what the fuck

Offline piper

  • Global Moderator
  • User
  • *****
  • Posts: 1.787
  • we are the priests ... of the temples of syrinx
Free speech isn't just fucking saying what you want to say, it's also hearing what you don't want to fucking hear

I either give too many fucks or no fucks at all, it's like I cannot find a middle ground for a moderate fuck distribution, it's like what the fuck

Offline tomsiduction

  • User
  • Posts: 140
Hello
and thank you to all of you for your help

Before doing the advised steps please allow me to answer the asked question.

I think I did never use kirigami2.

I am using siduction since several years and obviously kirigami was a part of my first installation - and I did update it until today.


May I mention that I managed the last update only by :
Code: [Select]
ln -s /usr/bin/startplasma-x11 /usr/bin/startkde

(Before that linking I had the same problem with the mouse-cursor in front of a black screen.)


Regards

Offline der_bud

  • User
  • Posts: 948
  • member
Hi piper, FYI, never used kirigami or installed  it on purpose, but it's part of my system and I cannot remove without badly hurting plasma  ;)
Code: [Select]
ii  libkf5kirigami2-5                             5.62.0-2+b2                          amd64        set of QtQuick components targeted for mobile use
ii  qml-module-org-kde-kirigami2                  5.62.0-2+b2                          amd64        set of QtQuick components targeted for mobile use

 
Code: [Select]
$ LANG=C aptitude why qml-module-org-kde-kirigami2
i   systemsettings Depends qml-module-org-kde-kirigami2[code]
Du lachst? Wieso lachst du? Das ist doch oft so, Leute lachen erst und dann sind sie tot.

Offline tomsiduction

  • User
  • Posts: 140
Hello

I tried with
Code: [Select]
apt update; apt install --install-recommends plasma-workspace

but it ended in the same way as before.
After rebooting I get only a (single) mouse-cursor on a black screen.)


I am wondering if the  behavior of KDE that I described does appear on other computers too?


Thank you

Offline piper

  • Global Moderator
  • User
  • *****
  • Posts: 1.787
  • we are the priests ... of the temples of syrinx
Were going to install this and try to destroy this install by removing it, and then install my latest build, just because.

Free speech isn't just fucking saying what you want to say, it's also hearing what you don't want to fucking hear

I either give too many fucks or no fucks at all, it's like I cannot find a middle ground for a moderate fuck distribution, it's like what the fuck

Offline hendrikL

  • User
  • Posts: 438
Hello

I tried with
Code: [Select]
apt update; apt install --install-recommends plasma-workspace

but it ended in the same way as before.
After rebooting I get only a (single) mouse-cursor on a black screen.)


I am wondering if the  behavior of KDE that I described does appear on other computers too?


So, you killed your kde/kf5/plasma installation.
This is not a behaviour of KDE!

Something is missing to bring up the xserver.
Read the log files, like xorg log, journalctl, dmesg....

Maybe kwin-x11 is missing?

Do you have a backup of your data’s?

What about an inxi -GSMx, please provid it.

My two cents, save your data's, get a new iso (https://isobuilds.siduction.org/) start a fresh installation.

This might be much faster, 10 min, then let us digging in the mud of your scrambled system.

Offline tomsiduction

  • User
  • Posts: 140
Hello and thank you


Here comes the system-Info:
Code: [Select]
System:
  Host: siduction Kernel: 5.6.7-towo.1-siduction-amd64 x86_64 bits: 64
  compiler: gcc v: 9.3.0 Desktop: KDE Plasma 5.17.5
  Distro: siduction 17.1.0 Patience - kde - (201703051755)
  base: Debian GNU/Linux bullseye/sid
Machine:
  Type: Laptop System: FUJITSU product: LIFEBOOK
 
  UEFI [Legacy]: FUJITSU // Insyde v: Version 1.19 date: 05/09/2017
Graphics:
  Device-1: Intel Skylake GT2 [HD Graphics 520] vendor: Fujitsu Limited.
  driver: i915 v: kernel bus ID: 00:02.0
  Device-2: Chicony Integrated Camera type: USB driver: uvcvideo
  bus ID: 1-10:5
  Display: x11 server: X.Org 1.20.8 driver: intel resolution: 1600x900~60Hz
  OpenGL: renderer: Mesa Intel HD Graphics 520 (SKL GT2) v: 4.6 Mesa 20.0.4
  direct render: Yes


Kwin-X11 is installed.

I am testing only with a 1:1 copy of my (still) running system.

Just to explain: I have installed siduction several years ago - the only thing I did was a weekly/monthly upgrade resp. dirt-upgrade.



As it is a encrypted system I would like to avoid a reinstall.

The only error that I can seen in xorg.log
Code: [Select]
15.041] (EE) Failed to open authorization file "/var/run/sddm/{e7321542-832e-4463-8b92-4544509ef81c}": No such file or directory

journalctl gives me (looking not so good)
Code: [Select]
Logs begin at Sat 2020-05-02 06:04:47 CEST, end at Sat 2020-05-02 19:54:24 >
Mai 02 06:04:47 siduction org.kde.KScreen[1610]: kscreen.xcb.helper: RRNotify_>
Mai 02 06:04:47 siduction org.kde.KScreen[1610]: kscreen.xcb.helper:         O>
Mai 02 06:04:47 siduction org.kde.KScreen[1610]: kscreen.xcb.helper:         P>
Mai 02 06:04:47 siduction org.kde.KScreen[1610]: kscreen.xcb.helper:         S>

and

Code: [Select]
Mai 02 06:04:47 siduction org.kde.KScreen[1610]: kscreen.xcb.helper: RRNotify_OutputProperty (ignored)
Mai 02 06:04:47 siduction org.kde.KScreen[1610]: kscreen.xcb.helper:         Output:  67
Mai 02 06:04:47 siduction org.kde.KScreen[1610]: kscreen.xcb.helper:         Property:  Backlight
Mai 02 06:04:47 siduction org.kde.KScreen[1610]: kscreen.xcb.helper:         State (newValue, Deleted):  0

dmesg shows (looking not so good)
Code: [Select]
[25785.778982] QSGRenderThread[113873]: segfault at a0 ip 00007effa4e749d8 sp 00007eff92427d40 error 4 in iris_dri.so[7effa445b000+d2f000]
[25785.778988] Code: 44 24 18 48 c7 44 24 10 00 00 00 00 48 c7 44 24 18 00 00 00 00 50 4c 8d 4c 24 18 e8 32 a1 b6 ff 48 8b 44 24 18 31 d2 48 89 ef <4c> 8b b0 a0 00 00 00 4c 89 f6 e8 f9 93 fd ff 48 8b bd 28 01 00 00
[27247.494241] QSGRenderThread[120005]: segfault at 24 ip 00007f0db329e336 sp 00007f0da5059d30 error 6 in iris_dri.so[7f0db2884000+d2f000]
[27247.494248] Code: 7e 30 44 01 ff 81 ff ff ff 00 00 0f 87 ab 17 00 00 49 01 c7 4c 89 7e 38 48 85 c0 0f 84 2c 02 00 00 83 ea 01 81 ca 00 00 09 78 <89> 10 48 8d 50 04 45 85 ed 74 74 41 8d 75 ff 48 8d 74 f0 0c 66 0f
[28062.146861] QSGRenderThread[123442]: segfault at 24 ip 00007fc751641336 sp 00007fc73ebfed30 error 6 in iris_dri.so[7fc750c27000+d2f000]



Thank you very much

Regards

Offline piper

  • Global Moderator
  • User
  • *****
  • Posts: 1.787
  • we are the priests ... of the temples of syrinx
Ok, this cannot be removed, that I know of at the moment, you can however purge

kirigami2-dev and libkf5kirigami2-doc if installed.

Kirigami in a QML based UI framework at the core of some KDE applications, which will become more and more central as more and more QML based applications are made.


Plasma 5.8 will depend from Kirigami 1.1, so if you are planning to write a Kirigami-based application, it will work by default and nicely integrate in the Plasma 5.8 desktop.


Plasma 5.8 also has a new big user for Kirigami 1.1, that is Discover: the application to search and install for new software, has a brand new user interface, based upon Kirigami.


But next time you have a problem with your system, please mention right away that you are using a encrypted system
Free speech isn't just fucking saying what you want to say, it's also hearing what you don't want to fucking hear

I either give too many fucks or no fucks at all, it's like I cannot find a middle ground for a moderate fuck distribution, it's like what the fuck

Offline tomsiduction

  • User
  • Posts: 140
Hello and thank you

Do you think it is helpful to downgrade (for a while) to a earlier version of

qml-module-org-kde-kirigami

Or better wait for Plasma 5.18?



Regards

Offline piper

  • Global Moderator
  • User
  • *****
  • Posts: 1.787
  • we are the priests ... of the temples of syrinx
There is only qml-module-org-kde-kirigami in   stretch (oldstable)
I don't recommend it




Free speech isn't just fucking saying what you want to say, it's also hearing what you don't want to fucking hear

I either give too many fucks or no fucks at all, it's like I cannot find a middle ground for a moderate fuck distribution, it's like what the fuck