seduction
 Language:
Welcome, Guest. Please login or register.
Did you miss your activation email?
2020/05/31, 01:04:19


Help

Author [EN] [PL] [ES] [PT] [IT] [DE] [FR] [NL] [TR] [SR] [AR] [RU] Topic: Realtek not loaded  (Read 945 times)

0 Members and 1 Guest are viewing this topic.

Offline bevo

  • User
  • Posts: 256
Realtek not loaded
« on: 2020/05/03, 11:14:40 »
Mit dem Kernel 5.6.* wird der Realtek Treiber nicht mehr gefunden.
Mit Kernel 5.5.* alle ok.
Auf anderen System bei gleicher Hardware habe ich das Problem nicht.
Bevo

Offline towo

  • Global Moderator
  • User
  • *****
  • Posts: 2.352
Re: Realtek not loaded
« Reply #1 on: 2020/05/03, 13:28:10 »
Gehts noch ungenauer?
Es gibt nämlich keinen Realtek-Treiber, es gibt viele davon!
Ich gehe nicht zum Karneval, ich verleihe nur manchmal mein Gesicht.

Offline bevo

  • User
  • Posts: 256
Re: Realtek not loaded
« Reply #2 on: 2020/05/03, 13:42:57 »
ungenauer geht immer  ;)
Code: [Select]
Network:   Device-1: Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet driver: r8169

Offline Camelot

  • User
  • Posts: 45
Re: Realtek not loaded
« Reply #3 on: 2020/05/03, 19:35:51 »
Nur zur Info, bei mir keine Probleme. Genaue Fehlermeldungen könnten für andere hilfreich sein.

Code: [Select]
inxi -SN
System:
  Host: sidzeug Kernel: 5.6.9-towo.1-siduction-amd64 x86_64 bits: 64
  Desktop: Xfce 4.14.2
  Distro: siduction 18.3.0 Patience - xfce - (201805132203)
Network:
  Device-1: Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet
  driver: r8169
Code: [Select]
$ lspci -nnk | grep -i net -A4
02:00.0 Ethernet controller [0200]: Realtek Semiconductor Co., Ltd. RTL8111/8168/8411 PCI Express Gigabit Ethernet Controller [10ec:8168] (rev 15)
Subsystem: Micro-Star International Co., Ltd. [MSI] RTL8111/8168/8411 PCI Express Gigabit Ethernet Controller [1462:7b29]
Kernel driver in use: r8169
Kernel modules: r8169
Code: [Select]
$ ip a
2: enp2s0: <BROADCAST,MULTICAST,UP,LOWER_UP>
Code: [Select]
$ /sbin/ethtool -i enp2s0
driver: r8169
version: 5.6.9-towo.1-siduction-amd64
firmware-version: rtl8168h-2_0.0.2 02/26/15

Offline bevo

  • User
  • Posts: 256
Re: Realtek not loaded
« Reply #4 on: 2020/05/04, 07:51:43 »
Siehe erstem Post: Kein Problem mit Kernel 5.5.* etc.

Boot-Log Meldung :
Code: [Select]
Mai 04 07:38:13 patience2 kernel: r8169 0000:03:00.0: realtek.ko not loaded, maybe it needs to be added to initramfs?bevo

Offline absolut

  • User
  • Posts: 430
Re: Realtek not loaded
« Reply #5 on: 2020/05/04, 23:35:15 »
bevo,

es gibt viele Bug Reports hinsichtlich realtek.ko not loaded... Beispiele:
https://bugs.launchpad.net/ubuntu/+source/linux-signed/+bug/1876593
https://forum.manjaro.org/t/ethernet-not-working-after-stable-update-on-2020-04-08/134500

beachte, dass meistens die Betroffenen irgendwelche Details und Infos eingereicht hatten, um die Analyse/Nachforschung zu unterstützen. ich würde daher towo's und Camelot's Antworten unter diesem Gesichtspunkt betrachten und empfehle da nachzureichen...

inxi -v3
dmesg / systemctl -b (for previous boots)
lsmod
lspci

Offline towo

  • Global Moderator
  • User
  • *****
  • Posts: 2.352
Re: Realtek not loaded
« Reply #6 on: 2020/05/05, 07:19:20 »
Code: [Select]
~
towo:OMPC-AV2> uname -a
Linux OMPC-AV2 5.6.7-towo.1-siduction-amd64 #1 SMP PREEMPT siduction 5.6-7 (2020-04-23) x86_64 GNU/Linux

~
towo:OMPC-AV2> inxi -N
Network:   Device-1: Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet driver: r8169

~
towo:OMPC-AV2> lsmod | grep real
snd_hda_codec_realtek   122880  1
snd_hda_codec_generic    90112  1 snd_hda_codec_realtek
ledtrig_audio          16384  2 snd_hda_codec_generic,snd_hda_codec_realtek
snd_hda_codec         163840  4 snd_hda_codec_generic,snd_hda_codec_hdmi,snd_hda_intel,snd_hda_codec_realtek
snd_hda_core          106496  5 snd_hda_codec_generic,snd_hda_codec_hdmi,snd_hda_intel,snd_hda_codec,snd_hda_codec_realtek
snd                   102400  17 snd_hda_codec_generic,snd_hda_codec_hdmi,snd_hwdep,snd_hda_intel,snd_hda_codec,snd_hda_codec_realtek,snd_timer,snd_pcm
realtek                20480  1
libphy                135168  2 r8169,realtek

Ich kann das weder hier, noch zu Hause nachvollziehen.
Ich gehe nicht zum Karneval, ich verleihe nur manchmal mein Gesicht.

Offline bevo

  • User
  • Posts: 256
Re: Realtek not loaded
« Reply #7 on: 2020/05/05, 08:55:12 »
Code: [Select]
root@patience2:/home/bevo# uname -a
Linux patience2 5.6.8-towo.2-siduction-amd64 #1 SMP PREEMPT siduction 5.6-8.1 (2020-05-01) x86_64 GNU/Linux
root@patience2:/home/bevo# inxi -N
Network:   Device-1: Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet driver: N/A
root@patience2:/home/bevo# lsmod | grep real
snd_hda_codec_realtek   122880  1
snd_hda_codec_generic    90112  1 snd_hda_codec_realtek
ledtrig_audio          16384  2 snd_hda_codec_generic,snd_hda_codec_realtek
snd_hda_codec         163840  4 snd_hda_codec_generic,snd_hda_codec_hdmi,snd_hda_intel,snd_hda_codec_realtek
snd_hda_core          106496  5 snd_hda_codec_generic,snd_hda_codec_hdmi,snd_hda_intel,snd_hda_codec,snd_hda_codec_realtek
snd                   102400  16 snd_hda_codec_generic,snd_hda_codec_hdmi,snd_hwdep,snd_hda_intel,snd_hda_codec,snd_hda_codec_realtek,snd_timer,snd_pcm
realtek                20480  0
libphy                135168  2 r8169,realtek
Sieht bei mir,bis auf den nicht geladenen Treiber, genauso aus.
« Last Edit: 2020/05/05, 09:10:25 by bevo »

Offline whistler_mb

  • User
  • Posts: 148
Re: Realtek not loaded
« Reply #8 on: 2020/05/05, 09:37:35 »
Ist bei dir das Paket r8168-dkms installiert?

Falls ja, bitte mal deinstallieren und sehen, ob es dann funktioniert.

Dieses Paket ersetzt den Kernel-Treiber für r8169 und hat anscheinend mit Kernel 5.6 Probleme.

Offline bevo

  • User
  • Posts: 256
Re: Realtek not loaded
« Reply #9 on: 2020/05/05, 12:13:05 »
Ist nicht installiert !

Offline piper

  • Global Moderator
  • User
  • *****
  • Posts: 1.771
  • we are the priests ... of the temples of syrinx
Re: Realtek not loaded
« Reply #10 on: 2020/05/05, 17:52:55 »
inxi -F

Code: [Select]
System:    Host: x1 Kernel: 5.6.10-towo.1-siduction-amd64 x86_64 bits: 64 Desktop: KDE Plasma 5.18.4
           Distro: siduction 18.3.0 Paint It Black - kde - (201908251849)
Machine:   Type: Desktop System: Gigabyte product: GA-970A-UD3 v: N/A serial: <superuser/root required>
           Mobo: Gigabyte model: GA-970A-UD3 v: x.x serial: <superuser/root required> BIOS: Award v: F7 date: 10/22/2012
CPU:       Topology: 6-Core model: AMD FX-6300 bits: 64 type: MCP L2 cache: 2048 KiB
           Speed: 1409 MHz min/max: 1400/3500 MHz Core speeds (MHz): 1: 1401 2: 1406 3: 1402 4: 1409 5: 1412 6: 1408
Graphics:  Device-1: NVIDIA GM204 [GeForce GTX 970] driver: nvidia v: 440.82
           Display: x11 server: X.Org 1.20.8 driver: nvidia unloaded: fbdev,modesetting,nouveau,vesa
           resolution: 1920x1080~60Hz
           OpenGL: renderer: GeForce GTX 970/PCIe/SSE2 v: 4.6.0 NVIDIA 440.82
Audio:     Device-1: Advanced Micro Devices [AMD/ATI] SBx00 Azalia driver: snd_hda_intel
           Device-2: NVIDIA GM204 High Definition Audio driver: snd_hda_intel
           Device-3: Philips s SAA7164 driver: saa7164
           Sound Server: ALSA v: k5.6.10-towo.1-siduction-amd64
Network:   Device-1: Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet driver: r8169
           IF: enp4s0 state: up speed: 1000 Mbps duplex: full mac: 90:2b:34:a5:99:2d
Drives:    Local Storage: total: 7.28 TiB used: 3.30 TiB (45.3%)
           ID-1: /dev/sda vendor: Hitachi model: HDS722020ALA330 size: 1.82 TiB
           ID-2: /dev/sdb vendor: Seagate model: ST3000DM001-1CH166 size: 2.73 TiB
           ID-3: /dev/sdc vendor: Seagate model: ST3000DM001-1CH166 size: 2.73 TiB
Partition: ID-1: / size: 250.01 GiB used: 55.55 GiB (22.2%) fs: ext4 dev: /dev/sda10
Swap:      ID-1: swap-1 type: partition size: 4.00 GiB used: 0 KiB (0.0%) dev: /dev/sda1
Sensors:   System Temperatures: cpu: 14.1 C mobo: N/A gpu: nvidia temp: 30 C
           Fan Speeds (RPM): N/A gpu: nvidia fan: 0%
Info:      Processes: 227 Uptime: 1d 1h 16m Memory: 15.62 GiB used: 2.89 GiB (18.5%) Shell: bash inxi: 3.1.00

/sbin/ethtool -i enp4s0

Code: [Select]
driver: r8169
version: 5.6.10-towo.1-siduction-amd64
firmware-version: rtl8168e-3_0.0.4 03/27/12
expansion-rom-version:
bus-info: 0000:04:00.0
supports-statistics: yes
supports-test: no
supports-eeprom-access: no
supports-register-dump: yes

lsmod | grep real

Code: [Select]
realtek                20480  1
libphy                135168  2 r8169,realtek

I either give too many fucks or no fucks at all, it's like I cannot find a middle ground for a moderate fuck distribution, it's like what the fuck

Free speech isn't just fucking saying what you want to say, it's also hearing what you don't want to fucking hear

Offline bevo

  • User
  • Posts: 256
Re: Realtek not loaded
« Reply #11 on: 2020/05/06, 08:24:20 »
Code: [Select]
root@patience2:/home/bevo# inxi -F
System:    Host: patience2 Kernel: 5.6.8-towo.2-siduction-amd64 x86_64 bits: 64 Desktop: KDE Plasma 5.17.5
           Distro: siduction 18.3.0 Patience - kde - (201805132121)
Machine:   Type: Desktop Mobo: Gigabyte model: GA-880GMA-UD2H v: x.x serial: N/A BIOS: Award v: F2 date: 05/14/2010
CPU:       Topology: Dual Core model: AMD Athlon II X2 250 bits: 64 type: MCP L2 cache: 2048 KiB
           Speed: 800 MHz min/max: 800/3000 MHz Core speeds (MHz): 1: 800 2: 800
Graphics:  Device-1: Advanced Micro Devices [AMD/ATI] RS880 [Radeon HD 4250] driver: radeon v: kernel
           Display: x11 server: X.Org 1.20.8 driver: radeon FAILED: ati unloaded: fbdev,modesetting,vesa
           resolution: 1920x1200~60Hz
           OpenGL: renderer: AMD RS880 (DRM 2.50.0 / 5.6.8-towo.2-siduction-amd64 LLVM 10.0.0) v: 3.3 Mesa 20.0.4
Audio:     Device-1: Advanced Micro Devices [AMD/ATI] SBx00 Azalia driver: snd_hda_intel
           Device-2: Advanced Micro Devices [AMD/ATI] RS880 HDMI Audio [Radeon HD 4200 Series] driver: snd_hda_intel
           Sound Server: ALSA v: k5.6.8-towo.2-siduction-amd64
Network:   Device-1: Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet driver: N/A
Drives:    Local Storage: total: 585.00 GiB used: 166.61 GiB (28.5%)
           ID-1: /dev/sda vendor: OCZ model: VERTEX4 size: 119.24 GiB
           ID-2: /dev/sdb vendor: Western Digital model: WD5000AAKX-001CA0 size: 465.76 GiB
Partition: ID-1: / size: 19.83 GiB used: 14.90 GiB (75.2%) fs: ext4 dev: /dev/sda1
           ID-2: /home size: 96.92 GiB used: 85.22 GiB (87.9%) fs: ext4 dev: /dev/sda2
Swap:      ID-1: swap-1 type: partition size: 1.95 GiB used: 0 KiB (0.0%) dev: /dev/sdb7
Sensors:   System Temperatures: cpu: 18.4 C mobo: N/A
           Fan Speeds (RPM): N/A
Info:      Processes: 199 Uptime: 4m Memory: 7.28 GiB used: 859.0 MiB (11.5%) Shell: bash inxi: 3.1.00

Code: [Select]
root@patience2:/sbin# /sbin/ethtool -i enp5s0
Cannot get driver information: No such device
root@patience2:/sbin# /sbin/ethtool -i enp4s0
Cannot get driver information: No such device


Code: [Select]
root@patience2:/home/bevo# lsmod | grep real
snd_hda_codec_realtek   122880  1
snd_hda_codec_generic    90112  1 snd_hda_codec_realtek
ledtrig_audio          16384  2 snd_hda_codec_generic,snd_hda_codec_realtek
snd_hda_codec         163840  4 snd_hda_codec_generic,snd_hda_codec_hdmi,snd_hda_intel,snd_hda_codec_realtek
snd_hda_core          106496  5 snd_hda_codec_generic,snd_hda_codec_hdmi,snd_hda_intel,snd_hda_codec,snd_hda_codec_realtek
snd                   102400  16 snd_hda_codec_generic,snd_hda_codec_hdmi,snd_hwdep,snd_hda_intel,snd_hda_codec,snd_hda_codec_realtek,snd_timer,snd_pcm
realtek                20480  0
libphy                135168  2 r8169,realtek

bevo  :(


« Last Edit: 2020/05/06, 08:50:50 by bevo »

Offline towo

  • Global Moderator
  • User
  • *****
  • Posts: 2.352
Re: Realtek not loaded
« Reply #12 on: 2020/05/06, 11:55:57 »
journalctl -b  | egrep -i "realtek|r8169"
Ich gehe nicht zum Karneval, ich verleihe nur manchmal mein Gesicht.

Offline bevo

  • User
  • Posts: 256
Re: Realtek not loaded
« Reply #13 on: 2020/05/06, 14:38:46 »
Code: [Select]
root@patience2:/home/bevo# journalctl -b | egrep -i "realtek|r8169"
Mai 06 14:24:43 patience2 kernel: r8169 0000:03:00.0: can't disable ASPM; OS doesn't have ASPM control
Mai 06 14:24:43 patience2 kernel: libphy: r8169: probed
Mai 06 14:24:43 patience2 kernel: r8169 0000:03:00.0: realtek.ko not loaded, maybe it needs to be added to initramfs?
Mai 06 14:24:43 patience2 kernel: r8169: probe of 0000:03:00.0 failed with error -49
Mai 06 14:24:44 patience2 kernel: snd_hda_codec_realtek hdaudioC0D0: autoconfig for ALC892: line_outs=4 (0x14/0x15/0x16/0x17/0x0) type:line
Mai 06 14:24:44 patience2 kernel: snd_hda_codec_realtek hdaudioC0D0:    speaker_outs=0 (0x0/0x0/0x0/0x0/0x0)
Mai 06 14:24:44 patience2 kernel: snd_hda_codec_realtek hdaudioC0D0:    hp_outs=1 (0x1b/0x0/0x0/0x0/0x0)
Mai 06 14:24:44 patience2 kernel: snd_hda_codec_realtek hdaudioC0D0:    mono: mono_out=0x0
Mai 06 14:24:44 patience2 kernel: snd_hda_codec_realtek hdaudioC0D0:    dig-out=0x11/0x1e
Mai 06 14:24:44 patience2 kernel: snd_hda_codec_realtek hdaudioC0D0:    inputs:
Mai 06 14:24:44 patience2 kernel: snd_hda_codec_realtek hdaudioC0D0:      Front Mic=0x19
Mai 06 14:24:44 patience2 kernel: snd_hda_codec_realtek hdaudioC0D0:      Rear Mic=0x18
Mai 06 14:24:44 patience2 kernel: snd_hda_codec_realtek hdaudioC0D0:      Line=0x1a
Mai 06 14:24:44 patience2 kernel: snd_hda_codec_realtek hdaudioC0D0:    dig-in=0x1f

Offline towo

  • Global Moderator
  • User
  • *****
  • Posts: 2.352
Re: Realtek not loaded
« Reply #14 on: 2020/05/06, 14:46:29 »
Ich gehe nicht zum Karneval, ich verleihe nur manchmal mein Gesicht.