seduction
 Language:
Welcome, Guest. Please login or register.
Did you miss your activation email?
2020/09/19, 20:58:00


Help

Author [EN] [PL] [ES] [PT] [IT] [DE] [FR] [NL] [TR] [SR] [AR] [RU] Topic: [solved] du fails - qml-module-org-kde-extensionplugin_5.16.0-1  (Read 9204 times)

0 Members and 1 Guest are viewing this topic.

Offline dibl

  • siduction community member
  • Global Moderator
  • User
  • *****
  • Posts: 2.033
    • Land of the Buckeye
Re: du fails - qml-module-org-kde-extensionplugin_5.16.0-1
« Reply #15 on: 2015/12/03, 14:15:45 »

@dibl - are you still using kdenext after these actions?


Yes.

Quote
My current (kdenext) remove list is :

Code: [Select]
The following packages will be REMOVED:
   kde-full (92+siduction1.7)
   kde-plasma-desktop (92+siduction1.7)
   kde-plasma-netbook (92+siduction1.7)
   kde-standard (92+siduction1.7)
   kde-workspace (5.4.2-siduction2)
   kde-workspace-bin (5.4.2-siduction1)                                                                                                                                                       
   kde-workspace-data (5.4.2-siduction2)                                                                                                                                                     
   kdebase-workspace-bin (4.11.22-3)                                                                                                                                                         
   klipper (5.4.2-siduction2)                                                                                                                                                                 
   libkactivities-bin (5.15.0-siduction1)                                                                                                                                                     
   libkf5baloo1 (5.9.2-siduction1)                                                                                                                                                           
   libkf5balooxapian1 (5.9.2-siduction1)                                                                                                                                                     
   plasma-desktopthemes-artwork (15.04.0-siduction0.4)     


There is quite a KDE transition in progress, apparently.  You may need to let the removals go, complete the d-u, then reinstall what is needed.  But check it after the d-u before you assume you need to reinstall things that were removed -- you may be surprised.
Asus ROG STRIX X299-E, Core i7-7740X, Nvidia GTX-1060, dual monitors, SSD 860 EVO, 2@WD1003FZEX in BTRFS

Offline jure

  • User
  • Posts: 528
Re: du fails - qml-module-org-kde-extensionplugin_5.16.0-1
« Reply #16 on: 2015/12/03, 15:16:42 »
@ the experts

while Santa did not solve the problem so far - do you think that this will work (for me with kdenext)

apt-get dist-upgrade does not work:
Quote
LANG=C apt-get dist-upgrade
Reading package lists... Done
Building dependency tree       
Reading state information... Done
You might want to run 'apt-get -f install' to correct these.
The following packages have unmet dependencies:
 kactivities : Depends: libkf5activities5 (>= 5.16.0) but 5.15.0-siduction1 is installed
E: Unmet dependencies. Try using -f.

apt-get install -f does not solve the problem
Quote
LANG=C apt-get install -f
Reading package lists... Done
Building dependency tree       
Reading state information... Done
Correcting dependencies... Done
The following additional packages will be installed:
  libkf5activities5 qml-module-org-kde-extensionplugin
The following packages will be REMOVED:
  qml-module-org-kde-activities
The following packages will be upgraded:
  libkf5activities5 qml-module-org-kde-extensionplugin
2 upgraded, 0 newly installed, 1 to remove and 355 not upgraded.
1 not fully installed or removed.
Need to get 0 B/119 kB of archives.
After this operation, 3072 B disk space will be freed.
Do you want to continue? [Y/n] y
Lese Changelogs... Fertig
apt-extracttemplates: relocation error: apt-extracttemplates: symbol _Z16ParseCommandLineR11CommandLine7APT_CMDPK P13ConfigurationPP9pkgSystemiPPKc, version APTPRIVATE_0.0 not defined in file libapt-private.so.0.0 with link time reference
debconf: apt-extracttemplates failed: No such file or directory
(Reading database ... 275631 files and directories currently installed.)
Preparing to unpack .../qml-module-org-kde-extensionplugin_5.16.0-1_amd64.deb ...
Unpacking qml-module-org-kde-extensionplugin:amd64 (5.16.0-1) over (5.15.0-siduction1) ...
dpkg: error processing archive /var/cache/apt/archives/qml-module-org-kde-extensionplugin_5.16.0-1_amd64.deb (--unpack):
 trying to overwrite '/usr/lib/x86_64-linux-gnu/qt5/qml/org/kde/activities/libkactivitiesextensionplugin.so', which is also in package qml-module-org-kde-activities:amd64 5.15.0-siduction1
Errors were encountered while processing:
 /var/cache/apt/archives/qml-module-org-kde-extensionplugin_5.16.0-1_amd64.deb
E: Sub-process /usr/bin/dpkg returned an error code (1

so is this a solution, and reinstalling the removed kde-stuff ?
Quote
root@siductionbox:/home/juergen# LANG=C apt-get dist-upgrade -f
Reading package lists... Done
Building dependency tree       
Reading state information... Done
Correcting dependencies... Done
Calculating upgrade... Done
The following packages will be REMOVED:
  kde-full kde-plasma-desktop kde-plasma-netbook kde-standard kde-workspace kde-workspace-bin kde-workspace-data kdebase-workspace-bin klipper  plasma-desktopthemes-artwork qml-module-org-kde-activities siduction-art-kde-ridersonthestorm siduction-art-ksplash-ridersonthestorm siduction-settings-kde
The following NEW packages will be installed:
  catdoc fonts-noto-hinted ieee-data libc-l10n libkf5gpgmepp5 qml-module-qt-labs-folderlistmodel qml-module-qt-labs-settings
The following packages have been kept back:
  libgnutls-deb0-28:i386 libgraphicsmagick3
The following packages will be upgraded:
  apt-utils baloo baloo-kf5...............
355 upgraded, 7 newly installed, 14 to remove and 2 not upgraded.
1 not fully installed or removed ?? !!!.
Gruss Juergen

Offline dibl

  • siduction community member
  • Global Moderator
  • User
  • *****
  • Posts: 2.033
    • Land of the Buckeye
Re: du fails - qml-module-org-kde-extensionplugin_5.16.0-1
« Reply #17 on: 2015/12/03, 16:17:07 »
@ the experts


OK that is not me.   :D


However, I can show the configuration of my Kf5 desktop which is working and stable, and you may see why I wrote "you might be surprised":


Code: [Select]
root@Hibiscus:/# apt-cache policy kde-standard kde-plasma-desktop kde-plasma-netbook kde-workspace kdebase-workspace-bin libkactivities-bin
kde-standard:
  Installed: (none)
  Candidate: 5:92+siduction1.7
  Version table:
     5:92+siduction1.7 500
        500 http://packages.siduction.org/kdenext unstable/main amd64 Packages
     5:90 500
        500 http://httpredir.debian.org/debian unstable/main amd64 Packages
kde-plasma-desktop:
  Installed: (none)
  Candidate: 5:92+siduction1.7
  Version table:
     5:92+siduction1.7 500
        500 http://packages.siduction.org/kdenext unstable/main amd64 Packages
     5:90 500
        500 http://httpredir.debian.org/debian unstable/main amd64 Packages
kde-plasma-netbook:
  Installed: (none)
  Candidate: 5:92+siduction1.7
  Version table:
     5:92+siduction1.7 500
        500 http://packages.siduction.org/kdenext unstable/main amd64 Packages
kde-workspace:
  Installed: (none)
  Candidate: 4:5.4.2-siduction2
  Version table:
     4:5.4.2-siduction2 500
        500 http://packages.siduction.org/kdenext unstable/main amd64 Packages
kdebase-workspace-bin:
  Installed: (none)
  Candidate: 4:4.11.13-90r2
  Version table:
     4:4.11.13-90r2 500
        500 http://packages.siduction.org/kdenext unstable/main amd64 Packages
libkactivities-bin:
  Installed: (none)
  Candidate: 4:5.15.0-siduction1
  Version table:
     4:5.15.0-siduction1 500
        500 http://packages.siduction.org/kdenext unstable/main amd64 Packages
     4:4.13.3-1 500
        500 http://httpredir.debian.org/debian unstable/main amd64 Packages


root@Hibiscus:/# apt-cache policy plasma-desktop plasma-workspace plasma-pa kinfocenter
plasma-desktop:
  Installed: 4:5.4.3-1
  Candidate: 4:5.4.3-1
  Version table:
 *** 4:5.4.3-1 500
        500 http://httpredir.debian.org/debian unstable/main amd64 Packages
        100 /var/lib/dpkg/status
     4:5.4.2-siduction1 500
        500 http://packages.siduction.org/kdenext unstable/main amd64 Packages
plasma-workspace:
  Installed: 4:5.4.3-1
  Candidate: 4:5.4.3-1
  Version table:
 *** 4:5.4.3-1 500
        500 http://httpredir.debian.org/debian unstable/main amd64 Packages
        100 /var/lib/dpkg/status
     4:5.4.2-siduction2 500
        500 http://packages.siduction.org/kdenext unstable/main amd64 Packages
plasma-pa:
  Installed: 4:5.4.2-siduction1
  Candidate: 4:5.4.2-siduction1
  Version table:
 *** 4:5.4.2-siduction1 500
        500 http://packages.siduction.org/kdenext unstable/main amd64 Packages
        100 /var/lib/dpkg/status
     5.4.3-1 500
        500 http://httpredir.debian.org/debian unstable/main amd64 Packages
kinfocenter:
  Installed: 4:5.4.3-1
  Candidate: 4:5.4.3-1
  Version table:
 *** 4:5.4.3-1 500
        500 http://httpredir.debian.org/debian unstable/main amd64 Packages
        100 /var/lib/dpkg/status
     4:5.4.2-siduction1 500
        500 http://packages.siduction.org/kdenext unstable/main amd64 Packages


So I think "yes", your last idea might work, even though that is not exactly how I did it.  I read the apt dependency errors and removed the offending packages one at a time until apt was happy, then I ran the d-u, then I reinstalled plasma-desktop, kinfocenter, and a couple others, but as you see not the kde-specific ones.  BTW I do not use kdeactivities so if you need that you might better wait.  Otherwise everything including systemsettings and dolphin seem to work as expected.

Asus ROG STRIX X299-E, Core i7-7740X, Nvidia GTX-1060, dual monitors, SSD 860 EVO, 2@WD1003FZEX in BTRFS

Offline clubex

  • User
  • Posts: 265
Re: du fails - qml-module-org-kde-extensionplugin_5.16.0-1
« Reply #18 on: 2015/12/04, 00:34:27 »
I have kactivities installed and working.As far as I can remember (and looking over my bash history) this is what I did:
Code: [Select]
aptitude -f install
told me that kactivities was only partially configured. So after
Code: [Select]
dpk-reconfigure kactivities
a du removed the packages dibl quoted earlier (plus sddm-theme-breeze) and upgraded the system.
The only packages I reinstalled were plasma-workspace, plasma-desktop and sddm-theme-breeze.
Hope this helps.

Offline sunrat

  • User
  • Posts: 351
Re: du fails - qml-module-org-kde-extensionplugin_5.16.0-1
« Reply #19 on: 2015/12/04, 01:05:32 »
If I can wait many weeks to d-u for GCC5, I can wait for Plasma 5.5 to be finished. 5.4 is working fairly well for me now.

Offline horo

  • User
  • Posts: 199
Re: du fails - qml-module-org-kde-extensionplugin_5.16.0-1
« Reply #20 on: 2015/12/04, 10:36:16 »
dibl,

Your cooking recipe above worked well for me, some courageous "dpkg -r xxx" paved the way to a successful d-u
I felt quite uncomfortable with a lot of new packages piled up in front of me ;)

Thx a lot

Ciao, Martin
omnia vincit pecunia :(

Offline jure

  • User
  • Posts: 528
Re: du fails - qml-module-org-kde-extensionplugin_5.16.0-1
« Reply #21 on: 2015/12/04, 13:57:49 »
- if the the problem with the unsolved dependencies is solved, will apt-get .... be able to work again, or will it stuck further on  in the situation shown 5 posts above ?

- Is there any way to repair "it" and then do not du at the moment ??

- or I am forced to use the rough way like dibl mentioned

Quote
apt-get install -f
Reading package lists... Done
Building dependency tree       
Reading state information... Done
Correcting dependencies... Done
The following additional packages will be installed:
  libkf5activities5 qml-module-org-kde-extensionplugin
The following packages will be REMOVED:
  qml-module-org-kde-activities
The following packages will be upgraded:
  libkf5activities5 qml-module-org-kde-extensionplugin
2 upgraded, 0 newly installed, 1 to remove and 400 not upgraded.
1 not fully installed or removed.
Need to get 0 B/119 kB of archives.
After this operation, 3072 B disk space will be freed.
Do you want to continue? [Y/n] y
Lese Changelogs... Fertig
apt-extracttemplates: relocation error: apt-extracttemplates: symbol _Z16ParseCommandLineR11CommandLine7APT_CMDPK P13ConfigurationPP9pkgSystemiPPKc, version APTPRIVATE_0.0 not defined in file libapt-private.so.0.0 with link time reference
debconf: apt-extracttemplates failed: No such file or directory
(Reading database ... 275631 files and directories currently installed.)
Preparing to unpack .../qml-module-org-kde-extensionplugin_5.16.0-1_amd64.deb ...
Unpacking qml-module-org-kde-extensionplugin:amd64 (5.16.0-1) over (5.15.0-siduction1) ...
dpkg: error processing archive /var/cache/apt/archives/qml-module-org-kde-extensionplugin_5.16.0-1_amd64.deb (--unpack):
 trying to overwrite '/usr/lib/x86_64-linux-gnu/qt5/qml/org/kde/activities/libkactivitiesextensionplugin.so', which is also in package qml-module-org-kde-activities:amd64 5.15.0-siduction1
Errors were encountered while processing:
 /var/cache/apt/archives/qml-module-org-kde-extensionplugin_5.16.0-1_amd64.deb

E: Sub-process /usr/bin/dpkg returned an error code (1)
Gruss Juergen

Offline melmarker

  • Global Moderator
  • User
  • *****
  • Posts: 2.800
    • g-com.eu
Re: du fails - qml-module-org-kde-extensionplugin_5.16.0-1
« Reply #22 on: 2015/12/04, 23:44:17 »
@jure - you should make a clean cut - that means in simple words: use debian- or kdenext-packages, but don't mix the packages.
Those who would give up essential Liberty, to purchase a little temporary Safety, deserve neither Liberty nor Safety. (Benjamin Franklin, November 11, 1755)
Never attribute to malice that which can be adequately explained by stupidity. (Hanlons razor)

Offline mylo

  • User
  • Posts: 922
Re: du fails - qml-module-org-kde-extensionplugin_5.16.0-1
« Reply #23 on: 2015/12/05, 09:28:10 »
I have the same questions as above. Seems I got pushed the same toxic mix.
I never conirmed such a mix of packs.
So how to convert to the one or the other from this situation? How to get out safely?

So +1:
Code: [Select]
- Is there any way to repair "it" and then do not du at the moment ??

- or I am forced to use the rough way like dibl mentioned
Regards mylo
____________________________________________ ____
"Die gefährlichste aller Weltanschauungen ist die Weltanschauung der Leute,
welche die Welt nicht angeschaut haben."               Alexander von Humboldt

Offline jure

  • User
  • Posts: 528
Re: du fails - qml-module-org-kde-extensionplugin_5.16.0-1
« Reply #24 on: 2015/12/05, 10:36:05 »
@jure - you should make a clean cut - that means in simple words: use debian- or kdenext-packages, but don't mix the packages.

good advise, but not solving the (my and others) problem or answering my questions above. And yes I know the problem is caused by using the kdenext repo. And it is the first "serious" problem for me, while using it.
As far as I can see, work is in progress (by Santa ?!) "transforming" kdenext packages back to debian, but some packages are missing, what may cause the problem...

still missing is a solution for > qml-module-org-kde-activities/unbekannt,now 5.15.0-siduction1 amd64  [installiert] < witch is not in the debian repos, but I think, it is causing the dependences problem

Code: [Select]
LANG=C apt list --upgradeable | grep 5.15.0-siduction1
frameworkintegration/unstable 5.16.0-1 amd64 [upgradable from: 5.15.0-siduction1.1]
kded5/unstable 5.16.0-1 amd64 [upgradable from: 5.15.0-siduction1]
kdoctools5/unstable 5.16.0-1 amd64 [upgradable from: 5.15.0-siduction1]
kinit/unstable 5.16.0-1 amd64 [upgradable from: 5.15.0-siduction1]
kio/unstable 5.16.0-1 amd64 [upgradable from: 5.15.0-siduction1.1]
kpackagetool5/unstable 5.16.0-1 amd64 [upgradable from: 5.15.0-siduction1]
kross/unstable 5.16.0-1 amd64 [upgradable from: 5.15.0-siduction1]
ktexteditor-data/unstable,unstable 5.16.0-1 all [upgradable from: 5.15.0-siduction1]
ktexteditor-katepart/unstable 5.16.0-1 amd64 [upgradable from: 5.15.0-siduction1]
libkf5activities5/unstable 5.16.0-1 amd64 [upgradable from: 5.15.0-siduction1]
libkf5archive5/unstable 5.16.0-1 amd64 [upgradable from: 5.15.0-siduction1]
libkf5attica5/unstable 5.16.0-1 amd64 [upgradable from: 5.15.0-siduction1]
libkf5auth-data/unstable,unstable 5.16.0-1 all [upgradable from: 5.15.0-siduction1]
libkf5auth5/unstable 5.16.0-1 amd64 [upgradable from: 5.15.0-siduction1]
libkf5bookmarks-data/unstable,unstable 5.16.0-1 all [upgradable from: 5.15.0-siduction1]
libkf5bookmarks5/unstable 5.16.0-1 amd64 [upgradable from: 5.15.0-siduction1]
libkf5codecs-data/unstable,unstable 5.16.0-1 all [upgradable from: 5.15.0-siduction1]
libkf5codecs5/unstable 5.16.0-1 amd64 [upgradable from: 5.15.0-siduction1]
libkf5completion-data/unstable,unstable 5.16.0-1 all [upgradable from: 5.15.0-siduction1]
libkf5completion5/unstable 5.16.0-1 amd64 [upgradable from: 5.15.0-siduction1]
libkf5config-bin/unstable 5.16.0-1 amd64 [upgradable from: 5.15.0-siduction1]
libkf5config-data/unstable,unstable 5.16.0-1 all [upgradable from: 5.15.0-siduction1]
libkf5configcore5/unstable 5.16.0-1 amd64 [upgradable from: 5.15.0-siduction1]
libkf5configgui5/unstable 5.16.0-1 amd64 [upgradable from: 5.15.0-siduction1]
libkf5configwidgets-data/unstable,unstable 5.16.0-1 all [upgradable from: 5.15.0-siduction1]
libkf5configwidgets5/unstable 5.16.0-1 amd64 [upgradable from: 5.15.0-siduction1]
libkf5coreaddons-bin-dev/unstable 5.16.0-1 amd64 [upgradable from: 5.15.0-siduction1]
libkf5coreaddons-data/unstable,unstable 5.16.0-1 all [upgradable from: 5.15.0-siduction1]
libkf5coreaddons5/unstable 5.16.0-1 amd64 [upgradable from: 5.15.0-siduction1]
libkf5crash5/unstable 5.16.0-1 amd64 [upgradable from: 5.15.0-siduction1]
libkf5dbusaddons-bin/unstable 5.16.0-1 amd64 [upgradable from: 5.15.0-siduction1]
libkf5dbusaddons-data/unstable,unstable 5.16.0-1 all [upgradable from: 5.15.0-siduction1]
libkf5dbusaddons5/unstable 5.16.0-1 amd64 [upgradable from: 5.15.0-siduction1]
libkf5declarative-data/unstable,unstable 5.16.0-1 all [upgradable from: 5.15.0-siduction1]
libkf5declarative5/unstable 5.16.0-1 amd64 [upgradable from: 5.15.0-siduction1]
libkf5dnssd-data/unstable,unstable 5.16.0-1 all [upgradable from: 5.15.0-siduction1]
libkf5dnssd5/unstable 5.16.0-1 amd64 [upgradable from: 5.15.0-siduction1]
libkf5emoticons-bin/unstable 5.16.0-1 amd64 [upgradable from: 5.15.0-siduction1]
libkf5emoticons-data/unstable,unstable 5.16.0-1 all [upgradable from: 5.15.0-siduction1]
libkf5emoticons5/unstable 5.16.0-1 amd64 [upgradable from: 5.15.0-siduction1]
libkf5filemetadata-bin/unstable 5.16.0-1 amd64 [upgradable from: 5.15.0-siduction1]
libkf5filemetadata-data/unstable,unstable 5.16.0-1 all [upgradable from: 5.15.0-siduction1]
libkf5filemetadata3/unstable 5.16.0-1 amd64 [upgradable from: 5.15.0-siduction1]
libkf5globalaccel-bin/unstable 5.16.0-1 amd64 [upgradable from: 5.15.0-siduction1]
libkf5globalaccel-data/unstable,unstable 5.16.0-1 all [upgradable from: 5.15.0-siduction1]
libkf5globalaccel5/unstable 5.16.0-1 amd64 [upgradable from: 5.15.0-siduction1]
libkf5globalaccelprivate5/unstable 5.16.0-1 amd64 [upgradable from: 5.15.0-siduction1]
libkf5guiaddons5/unstable 5.16.0-1 amd64 [upgradable from: 5.15.0-siduction1]
libkf5i18n-data/unstable,unstable 5.16.0-1 all [upgradable from: 5.15.0-siduction1]
libkf5i18n5/unstable 5.16.0-1 amd64 [upgradable from: 5.15.0-siduction1]
libkf5iconthemes-bin/unstable 5.16.0-1 amd64 [upgradable from: 5.15.0-siduction1]
libkf5iconthemes-data/unstable,unstable 5.16.0-1 all [upgradable from: 5.15.0-siduction1]
libkf5iconthemes5/unstable 5.16.0-1 amd64 [upgradable from: 5.15.0-siduction1]
libkf5idletime5/unstable 5.16.0-1 amd64 [upgradable from: 5.15.0-siduction1]
libkf5itemmodels5/unstable 5.16.0-1 amd64 [upgradable from: 5.15.0-siduction1]
libkf5itemviews-data/unstable,unstable 5.16.0-1 all [upgradable from: 5.15.0-siduction1]
libkf5itemviews5/unstable 5.16.0-1 amd64 [upgradable from: 5.15.0-siduction1]
libkf5jobwidgets-data/unstable,unstable 5.16.0-1 all [upgradable from: 5.15.0-siduction1]
libkf5jobwidgets5/unstable 5.16.0-1 amd64 [upgradable from: 5.15.0-siduction1]
libkf5js5/unstable 5.16.0-1 amd64 [upgradable from: 5.15.0-siduction1]
libkf5jsembed-data/unstable,unstable 5.16.0-1 all [upgradable from: 5.15.0-siduction1]
libkf5jsembed5/unstable 5.16.0-1 amd64 [upgradable from: 5.15.0-siduction1]
libkf5kcmutils-data/unstable,unstable 5.16.0-1 all [upgradable from: 5.15.0-siduction1]
libkf5kcmutils5/unstable 5.16.0-1 amd64 [upgradable from: 5.15.0-siduction1]
libkf5kdelibs4support-data/unstable,unstable 5.16.0-1 all [upgradable from: 5.15.0-siduction1]
libkf5kdelibs4support5/unstable 5.16.0-1 amd64 [upgradable from: 5.15.0-siduction1]
libkf5kdelibs4support5-bin/unstable 5.16.0-1 amd64 [upgradable from: 5.15.0-siduction1]
libkf5khtml-bin/unstable 5.16.0-1 amd64 [upgradable from: 5.15.0-siduction1]
libkf5khtml-data/unstable,unstable 5.16.0-1 all [upgradable from: 5.15.0-siduction1]
libkf5khtml5/unstable 5.16.0-1 amd64 [upgradable from: 5.15.0-siduction1]
libkf5kiocore5/unstable 5.16.0-1 amd64 [upgradable from: 5.15.0-siduction1.1]
libkf5kiofilewidgets5/unstable 5.16.0-1 amd64 [upgradable from: 5.15.0-siduction1.1]
libkf5kiontlm5/unstable 5.16.0-1 amd64 [upgradable from: 5.15.0-siduction1.1]
libkf5kiowidgets5/unstable 5.16.0-1 amd64 [upgradable from: 5.15.0-siduction1.1]
libkf5krosscore5/unstable 5.16.0-1 amd64 [upgradable from: 5.15.0-siduction1]
libkf5krossui5/unstable 5.16.0-1 amd64 [upgradable from: 5.15.0-siduction1]
libkf5modemmanagerqt6/unstable 5.16.0-1 amd64 [upgradable from: 5.15.0-siduction1]
libkf5networkmanagerqt6/unstable 5.16.0-1 amd64 [upgradable from: 5.15.0-siduction1]
libkf5newstuff-data/unstable,unstable 5.16.0-1 all [upgradable from: 5.15.0-siduction1]
libkf5newstuff5/unstable 5.16.0-1 amd64 [upgradable from: 5.15.0-siduction1]
libkf5notifications-data/unstable,unstable 5.16.0-1 all [upgradable from: 5.15.0-siduction1]
libkf5notifications5/unstable 5.16.0-1 amd64 [upgradable from: 5.15.0-siduction1]
libkf5notifyconfig-data/unstable,unstable 5.16.0-1 all [upgradable from: 5.15.0-siduction1]
libkf5notifyconfig5/unstable 5.16.0-1 amd64 [upgradable from: 5.15.0-siduction1]
libkf5package-data/unstable,unstable 5.16.0-1 all [upgradable from: 5.15.0-siduction1]
libkf5package5/unstable 5.16.0-1 amd64 [upgradable from: 5.15.0-siduction1]
libkf5parts-data/unstable,unstable 5.16.0-1 all [upgradable from: 5.15.0-siduction1]
libkf5parts5/unstable 5.16.0-1 amd64 [upgradable from: 5.15.0-siduction1]
libkf5people-data/unstable,unstable 5.16.0-1 all [upgradable from: 5.15.0-siduction1]
libkf5people5/unstable 5.16.0-1 amd64 [upgradable from: 5.15.0-siduction1]
libkf5peoplebackend5/unstable 5.16.0-1 amd64 [upgradable from: 5.15.0-siduction1]
libkf5peoplewidgets5/unstable 5.16.0-1 amd64 [upgradable from: 5.15.0-siduction1]
libkf5plasma5/unstable 5.16.0-1 amd64 [upgradable from: 5.15.0-siduction1]
libkf5plasmaquick5/unstable 5.16.0-1 amd64 [upgradable from: 5.15.0-siduction1]
libkf5plotting5/unstable 5.16.0-1 amd64 [upgradable from: 5.15.0-siduction1]
libkf5pty-data/unstable,unstable 5.16.0-1 all [upgradable from: 5.15.0-siduction1]
libkf5pty5/unstable 5.16.0-1 amd64 [upgradable from: 5.15.0-siduction1]
libkf5quickaddons5/unstable 5.16.0-1 amd64 [upgradable from: 5.15.0-siduction1]
libkf5runner5/unstable 5.16.0-1 amd64 [upgradable from: 5.15.0-siduction1]
libkf5solid-bin/unstable 5.16.0-1 amd64 [upgradable from: 5.15.0-siduction1]
libkf5solid5/unstable 5.16.0-1 amd64 [upgradable from: 5.15.0-siduction1]
libkf5solid5-data/unstable,unstable 5.16.0-1 all [upgradable from: 5.15.0-siduction1]
libkf5sonnet5-data/unstable,unstable 5.16.0-1 all [upgradable from: 5.15.0-siduction1]
libkf5sonnetcore5/unstable 5.16.0-1 amd64 [upgradable from: 5.15.0-siduction1]
libkf5sonnetui5/unstable 5.16.0-1 amd64 [upgradable from: 5.15.0-siduction1]
libkf5style5/unstable 5.16.0-1 amd64 [upgradable from: 5.15.0-siduction1.1]
libkf5su-bin/unstable 5.16.0-1 amd64 [upgradable from: 5.15.0-siduction1]
libkf5su-data/unstable,unstable 5.16.0-1 all [upgradable from: 5.15.0-siduction1]
libkf5su5/unstable 5.16.0-1 amd64 [upgradable from: 5.15.0-siduction1]
libkf5texteditor5/unstable 5.16.0-1 amd64 [upgradable from: 5.15.0-siduction1]
libkf5textwidgets-data/unstable,unstable 5.16.0-1 all [upgradable from: 5.15.0-siduction1]
libkf5textwidgets5/unstable 5.16.0-1 amd64 [upgradable from: 5.15.0-siduction1]
libkf5threadweaver5/unstable 5.16.0-1 amd64 [upgradable from: 5.15.0-siduction1]
libkf5unitconversion-data/unstable,unstable 5.16.0-1 all [upgradable from: 5.15.0-siduction1]
libkf5unitconversion5/unstable 5.16.0-1 amd64 [upgradable from: 5.15.0-siduction1]
libkf5wallet-bin/unstable 5.16.0-1 amd64 [upgradable from: 5.15.0-siduction1]
libkf5wallet-data/unstable,unstable 5.16.0-1 all [upgradable from: 5.15.0-siduction1]
libkf5wallet5/unstable 5.16.0-1 amd64 [upgradable from: 5.15.0-siduction1]
libkf5webkit5/unstable 5.16.0-1 amd64 [upgradable from: 5.15.0-siduction1]
libkf5widgetsaddons-data/unstable,unstable 5.16.0-1 all [upgradable from: 5.15.0-siduction1]
libkf5widgetsaddons5/unstable 5.16.0-1 amd64 [upgradable from: 5.15.0-siduction1]
libkf5windowsystem-data/unstable,unstable 5.16.0-1 all [upgradable from: 5.15.0-siduction1]
libkf5windowsystem5/unstable 5.16.0-1 amd64 [upgradable from: 5.15.0-siduction1]
libkf5xmlgui-bin/unstable 5.16.0-1 amd64 [upgradable from: 5.15.0-siduction1]
libkf5xmlgui-data/unstable,unstable 5.16.0-1 all [upgradable from: 5.15.0-siduction1]
libkf5xmlgui5/unstable 5.16.0-1 amd64 [upgradable from: 5.15.0-siduction1]
libkf5xmlrpcclient-data/unstable,unstable 5.16.0-1 all [upgradable from: 5.15.0-siduction1]
libkf5xmlrpcclient5/unstable 5.16.0-1 amd64 [upgradable from: 5.15.0-siduction1]
libkwalletbackend5-5/unstable 5.16.0-1 amd64 [upgradable from: 5.15.0-siduction1]
plasma-framework/unstable 5.16.0-1 amd64 [upgradable from: 5.15.0-siduction1]
qml-module-org-kde-draganddrop/unstable 5.16.0-1 amd64 [upgradable from: 5.15.0-siduction1]
qml-module-org-kde-extensionplugin/unstable 5.16.0-1 all [upgradable from: 5.15.0-siduction1]
qml-module-org-kde-kcoreaddons/unstable 5.16.0-1 amd64 [upgradable from: 5.15.0-siduction1]
qml-module-org-kde-kio/unstable 5.16.0-1 amd64 [upgradable from: 5.15.0-siduction1]
qml-module-org-kde-kquickcontrols/unstable 5.16.0-1 amd64 [upgradable from: 5.15.0-siduction1]
qml-module-org-kde-kquickcontrolsaddons/unstable 5.16.0-1 amd64 [upgradable from: 5.15.0-siduction1]
qml-module-org-kde-kwindowsystem/unstable 5.16.0-1 amd64 [upgradable from: 5.15.0-siduction1]
qml-module-org-kde-solid/unstable 5.16.0-1 amd64 [upgradable from: 5.15.0-siduction1]
qtdeclarative5-kf5declarative/unstable,unstable 5.16.0-1 all [upgradable from: 5.15.0-siduction1]
qtdeclarative5-kf5solid/unstable,unstable 5.16.0-1 all [upgradable from: 5.15.0-siduction1]
« Last Edit: 2015/12/05, 10:54:15 by jure »
Gruss Juergen

holgerw

  • Guest
Re: du fails - qml-module-org-kde-extensionplugin_5.16.0-1
« Reply #25 on: 2015/12/05, 11:57:13 »
Hello Jürgen,

what I would do in such a situation:

1. Backup of /etc and /home
2. Download last inofficial image of siduction lxqt
3. New installation of that image
4a) adding kdenext and trying to get a kde plasma environement
or
4b) trying to get a kde plasma environement without kdenext

Kind regards,
  Holger

Offline samoht

  • User
  • Posts: 366
KDE successfully dist-upgraded, following dibl
« Reply #26 on: 2015/12/06, 12:37:19 »
Warning:
My approach worked on my kdenext enabled installation but it is not a thoroughly tested recipe, only a success report.
There is no guarantee (in German: ohne Gewähr).

OK, here are my steps (in runlevel 3, of course):

After
Code: [Select]
apt-get dist-upgradea lot of packages should be updated/installed but only a handful packages were to be removed.
Trying to run:
Code: [Select]
apt-get remove kde-plasma-desktop kde-workspace libkactivities-bin okular plasma-desktopthemes-artwork qml-module-org-kde-activities siduction-settings-kdeStopped with an error: unresolvable dependency problem.
Bravely running:
Code: [Select]
dpkg -i --force-overwrite /var/cache/apt/archives/qml-module-org-kde-extensionplugin_5.16.0-1_amd64.deb
It worked and the subsequent d-u was successful (requiring only one additional apt -f install).

Unfortunately, the okular package can not be reinstalled at this moment.

Greetings

Tom
« Last Edit: 2015/12/06, 13:49:55 by samoht »

Offline mylo

  • User
  • Posts: 922
Re: du fails - qml-module-org-kde-extensionplugin_5.16.0-1
« Reply #27 on: 2015/12/06, 13:37:39 »
Hi samoht,

your procedure worked fine for me, although I had an error at the end of the last step. A
Code: [Select]
apt-get -f and a
Code: [Select]
d-u after worked fine.

Thanks a lot.

Okular seems  to be a remaining problem:

Code: [Select]
ins okular
Paketlisten werden gelesen... Fertig
Abhängigkeitsbaum wird aufgebaut.       
Statusinformationen werden eingelesen.... Fertig
Einige Pakete konnten nicht installiert werden. Das kann bedeuten, dass
Sie eine unmögliche Situation angefordert haben oder, wenn Sie die
Unstable-Distribution verwenden, dass einige erforderliche Pakete noch
nicht erstellt wurden oder Incoming noch nicht verlassen haben.
Die folgenden Informationen helfen Ihnen vielleicht, die Situation zu lösen:

Die folgenden Pakete haben unerfüllte Abhängigkeiten:
 okular : Hängt ab von: libkexiv2-11 (>= 4:4.5.90) soll aber nicht installiert werden                                                                                                                     
E: Probleme können nicht korrigiert werden, Sie haben zurückgehaltene defekte Pakete.
Regards mylo
____________________________________________ ____
"Die gefährlichste aller Weltanschauungen ist die Weltanschauung der Leute,
welche die Welt nicht angeschaut haben."               Alexander von Humboldt

Offline jure

  • User
  • Posts: 528
Re: du fails - qml-module-org-kde-extensionplugin_5.16.0-1
« Reply #28 on: 2015/12/06, 13:59:49 »
here are two packages in /var/cache/apt/archives

Quote
ls -l /var/cache/apt/archives/
insgesamt 124
-rw-r--r-- 1 root root 56916 Dez  1 00:46 libkf5activities5_5.16.0-1_amd64.deb
-rw-r----- 1 root root     0 Dez  9  2012 lock
drwx------ 2 _apt root  4096 Dez  4 14:32 partial
-rw-r--r-- 1 root root 62212 Dez  1 00:46 qml-module-org-kde-extensionplugin_5.16.0-1_amd64.deb

do I have to overwrite both or only the qml-module-org-kde-extensionplugin_5.16.0-1_amd64.deb .

And to learn something, what does it mean to overwrite a file in /var/cache/apt/archives/ - the file is "overwritten" by what/whom ?

Gruss Juergen

Offline samoht

  • User
  • Posts: 366
Re: du fails - qml-module-org-kde-extensionplugin_5.16.0-1
« Reply #29 on: 2015/12/06, 14:53:55 »
Hi Juergen,

here is the issue - in my understanding  ;) -  in other, more words:

Package qml-module-org-kde-activities could not be removed because of an unmet dependency problem.
Dependency reasons required at the same time installing the other package qml-module-org-kde-extensionplugin. This was not possible because a remaining file of the still not removed package qml-module-org-kde-activities could not be overwritten by the regular apt command.

Installing the required package and overwriting this remaining file could be accomplished by the dpkg --force-overwrite option:
Code: [Select]
dpkg -i --force-overwrite /var/cache/apt/archives/qml-module-org-kde-extensionplugin_5.16.0-1_amd64.debNo deb/install packages have to be overwritten.

Look at your own posting http://forum.siduction.org/index.php?topic=5920.msg48785#msg48785:
Quote
...
dpkg: error processing archive /var/cache/apt/archives/qml-module-org-kde-extensionplugin_5.16.0-1_amd64.deb (--unpack):
 trying to overwrite '/usr/lib/x86_64-linux-gnu/qt5/qml/org/kde/activities/libkactivitiesextensionplugin.so', which is also in package qml-module-org-kde-activities:amd64 5.15.0-siduction1
...

Greetings

Tom
« Last Edit: 2015/12/06, 15:17:12 by samoht »