seduction
 Language:
Welcome, Guest. Please login or register.
Did you miss your activation email?
2020/11/26, 05:27:08


Help

Author [EN] [PL] [ES] [PT] [IT] [DE] [FR] [NL] [TR] [SR] [AR] [RU] Topic: [solved] du fails - qml-module-org-kde-extensionplugin_5.16.0-1  (Read 9530 times)

0 Members and 1 Guest are viewing this topic.

Offline mylo

  • User
  • Posts: 922
Re: du fails - qml-module-org-kde-extensionplugin_5.16.0-1
« Reply #30 on: 2015/12/06, 16:03:44 »
Here I have:

Code: [Select]
root@tuap:~# ls -l /var/cache/apt/archives | grep 5.15
...
-rw-rw---- 1 root root    54132 Okt  8 03:31 libkf5activities5_5.15.0-siduction1_amd64.deb
-rw-rw---- 1 root root     4490 Okt  8 03:31 qml-module-org-kde-extensionplugin_5.15.0-siduction1_all.deb


root@tuap:~# ls -l /var/cache/apt/archives | grep 5.16
...
-rw-r--r-- 1 root root    56916 Dez  1 00:46 libkf5activities5_5.16.0-1_amd64.deb
-rw-r--r-- 1 root root    62212 Dez  1 00:46 qml-module-org-kde-extensionplugin_5.16.0-1_amd64.deb

Is it ok, that both versions are there? How can I verify whether the 5.16 is in charge to work?
Regards mylo
____________________________________________ ____
"Die gefährlichste aller Weltanschauungen ist die Weltanschauung der Leute,
welche die Welt nicht angeschaut haben."               Alexander von Humboldt

Offline dibl

  • siduction community member
  • Global Moderator
  • User
  • *****
  • Posts: 2.056
    • Land of the Buckeye
Re: du fails - qml-module-org-kde-extensionplugin_5.16.0-1
« Reply #31 on: 2015/12/06, 16:36:08 »
I cleaned out /var/cache/apt/archives.


Regarding the qml-module-org-kde packages, since I don't use kactivities I did not worry about losing qml-module-org-kde-activities.  As a result I have


Code: [Select]
root@Hibiscus:/# apt-cache policy qml-module-org-kde-activities
qml-module-org-kde-activities:
  Installed: (none)
  Candidate: 5.15.0-siduction1
  Version table:
     5.15.0-siduction1 500
        500 http://packages.siduction.org/kdenext unstable/main amd64 Packages
root@Hibiscus:/# apt-cache policy qml-module-org-kde-extensionplugin
qml-module-org-kde-extensionplugin:
  Installed: 5.16.0-1
  Candidate: 5.16.0-1
  Version table:
 *** 5.16.0-1 500
        500 http://httpredir.debian.org/debian unstable/main amd64 Packages
        100 /var/lib/dpkg/status
     5.15.0-siduction1 500
        500 http://packages.siduction.org/kdenext unstable/main amd64 Packages


In this morning's d-u, okular was removed, but there were no other issues.  The system was running stable since Friday night.  Today I rebooted because of the new kernel.


Code: [Select]
root@Hibiscus:/# uptime
 10:34:40 up  1:50,  1 user,  load average: 0.09, 0.16, 0.22
Asus ROG STRIX X299-E, Core i7-7740X, Nvidia GTX-1060, dual monitors, SSD 860 EVO, 2@WD1003FZEX in BTRFS

Offline jure

  • User
  • Posts: 536
Re: du fails - qml-module-org-kde-extensionplugin_5.16.0-1
« Reply #32 on: 2015/12/06, 16:54:24 »
@ samoht - thank you for your hint with --force-overwrite and for the explanation !!

at first I have to --force-overwrite  libkf5activities5_5.16.0-1_amd64.deb
after that I could  --force-overwrite qml-module-org-kde-extensionplugin_5.16.0-1_amd64.deb

both with no errors.

Now I am running apt-get dist-upgrade - (with okular set an hold)
these packages will be removed
Quote

kde-standard
kde-full
kde-plasma-desktop
kde-plasma-netbook
kde-workspace
kde-workspace-bin
kde-workspace-data
kdebase-workspace-bin
plasma-desktopthemes-artwork
siduction-art-kde-ridersonthestorm
siduction-art-ksplash-ridersonthestorm
siduction-settings-kde
Gruss Juergen

Offline mylo

  • User
  • Posts: 922
Re: du fails - qml-module-org-kde-extensionplugin_5.16.0-1
« Reply #33 on: 2015/12/06, 16:58:03 »
jure,

I experienced the same announcement of removals, was no problem after.
Regards mylo
____________________________________________ ____
"Die gefährlichste aller Weltanschauungen ist die Weltanschauung der Leute,
welche die Welt nicht angeschaut haben."               Alexander von Humboldt

Offline mylo

  • User
  • Posts: 922
Re: du fails - qml-module-org-kde-extensionplugin_5.16.0-1
« Reply #34 on: 2015/12/06, 17:00:52 »
Hi dibl,

Code: [Select]
I cleaned out /var/cache/apt/archives.
How to know, whether older packages are required by older kernel? Ist there a way to clean out  the archives dir consistently automatically?
Regards mylo
____________________________________________ ____
"Die gefährlichste aller Weltanschauungen ist die Weltanschauung der Leute,
welche die Welt nicht angeschaut haben."               Alexander von Humboldt

Offline dibl

  • siduction community member
  • Global Moderator
  • User
  • *****
  • Posts: 2.056
    • Land of the Buckeye
Re: du fails - qml-module-org-kde-extensionplugin_5.16.0-1
« Reply #35 on: 2015/12/06, 17:05:01 »
I run
Code: [Select]
apt-get clean manually fairly often -- once a week at least.  I would not advise to run it automatically.  I know from past experience there is some risk in doing this, because if you need one of the older package versions that is no longer in the repos, you might be stuck.  But ... this is a sid system ... some "unstable" behavior is expected, or else better run stable.   ;)
Asus ROG STRIX X299-E, Core i7-7740X, Nvidia GTX-1060, dual monitors, SSD 860 EVO, 2@WD1003FZEX in BTRFS

Offline mylo

  • User
  • Posts: 922
Re: du fails - qml-module-org-kde-extensionplugin_5.16.0-1
« Reply #36 on: 2015/12/06, 17:22:26 »
ok thanks, thats for it though, good.
Regards mylo
____________________________________________ ____
"Die gefährlichste aller Weltanschauungen ist die Weltanschauung der Leute,
welche die Welt nicht angeschaut haben."               Alexander von Humboldt

Offline jure

  • User
  • Posts: 536
Re: du fails - qml-module-org-kde-extensionplugin_5.16.0-1
« Reply #37 on: 2015/12/06, 17:44:01 »
the du went well, 1 error relating to "libkf5wallet-bin_5.16.0-1_amd64.deb" could be solved by one apt-get install -f

So thx to all who helped solving the problem !!
Gruss Juergen

Offline samoht

  • User
  • Posts: 376
okular installable from kdenext repo
« Reply #38 on: 2015/12/07, 00:50:09 »
Installing via
Code: [Select]
apt install okular=4:15.08.2-siduction1 libokularcore6=4:15.08.2-siduction1did the job.  :)

Greetings

Tom

Offline melmarker

  • Global Moderator
  • User
  • *****
  • Posts: 2.800
    • g-com.eu
don't forget to proper hold these packages ...

to be serious, thats a workaround, not a solution. and the next apt upgrade will break this 'solution'
Those who would give up essential Liberty, to purchase a little temporary Safety, deserve neither Liberty nor Safety. (Benjamin Franklin, November 11, 1755)
Never attribute to malice that which can be adequately explained by stupidity. (Hanlons razor)

Offline samoht

  • User
  • Posts: 376
... Agreed. Moving "on thin ice"  ;)

Greetings

Tom

Offline vayu

  • User
  • Posts: 222
I had to do this:
First I put okular on hold:
Code: [Select]
apt-mark hold okularthen:
start the du
It had an error, so then:
Code: [Select]
dpkg -i --force-overwrite /var/cache/apt/archives/qml-module-org-kde-extensionplugin_5.16.0-1_amd64.debthen after that I did the du again and it had one more error then I needed to do:
Code: [Select]
apt-get install -f
Everything seems to be working, I never reinstalled the missing packages.
Do I need kde-plasma-desktop, kde-standard or kde-workspace, or are they no longer used?
« Last Edit: 2015/12/09, 21:18:11 by vayu »

Offline CCarpenter

  • User
  • Posts: 198
    • http://www.greenvalleyranchschwand.de
Is it still unsafe to upgrade today - when are the Lights green again?

Offline vayu

  • User
  • Posts: 222
Is it still unsafe to upgrade today - when are the Lights green again?

Except that I had to intervene with the above extra steps, my system is working well.

Offline CCarpenter

  • User
  • Posts: 198
    • http://www.greenvalleyranchschwand.de
Thanks vayu, my system is working too with your workaround! But the Tray Icons are still broken!