seduction
 Language:
Welcome, Guest. Please login or register.
Did you miss your activation email?
2020/06/01, 22:32:34


Help

Author [EN] [PL] [ES] [PT] [IT] [DE] [FR] [NL] [TR] [SR] [AR] [RU] Topic: WARNING: KDEPim 16.04.2-1 Transitions started  (Read 9215 times)

0 Members and 1 Guest are viewing this topic.

Offline piper

  • Global Moderator
  • User
  • *****
  • Posts: 1.771
  • we are the priests ... of the temples of syrinx
Re: WARNING: KDEPim 16.04.2-1 Transitions started
« Reply #45 on: 2016/08/01, 11:26:48 »
comment out (#)

Code: [Select]
deb http://packages.siduction.org/base unstable main contrib non-free
deb [arch=amd64] http://dl.google.com/linux/chrome/deb/ stable main  
deb http://download.mono-project.com/repo/debian wheezy main

apt clean  (if you enabled it)

apt update && apt dist-upgrade

 
I either give too many fucks or no fucks at all, it's like I cannot find a middle ground for a moderate fuck distribution, it's like what the fuck

Free speech isn't just fucking saying what you want to say, it's also hearing what you don't want to fucking hear

Offline davidb

  • User
  • Posts: 29
    • http://brandesign.org
Re: WARNING: KDEPim 16.04.2-1 Transitions started
« Reply #46 on: 2016/08/01, 14:26:28 »
This results in the same conflict.

Offline der_bud

  • User
  • Posts: 921
  • member
Re: WARNING: KDEPim 16.04.2-1 Transitions started
« Reply #47 on: 2016/08/01, 16:34:37 »
Ok, then please output of
Code: [Select]
apt-cache policy akonadiconsole
apt-cache policy kontact

(Seems some strange dependencies to old packages, probably some of the "but $foo is to be installed" ones will have to be removed and/or then reinstalled with explicit version number...)
Du lachst? Wieso lachst du? Das ist doch oft so, Leute lachen erst und dann sind sie tot.

Offline Taliesin

  • User
  • Posts: 67
Re: WARNING: KDEPim 16.04.2-1 Transitions started
« Reply #48 on: 2016/08/02, 10:40:03 »
Hi folks, I'm getting the same dist-upgrade problems as davidb.

Code: [Select]
apt-get dist-upgrade
Reading package lists... Done
Building dependency tree       
Reading state information... Done
Calculating upgrade... Error!
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
 akonadi-server : Breaks: akonadiconsole (< 4:16.04) but 4:4.14.10-siduction1.7 is to be installed
                  Breaks: kmail (< 4:16.04) but 4:4.14.10-siduction1.7 is to be installed
                  Breaks: korganizer (< 4:16.04) but 4:4.14.10-siduction1.7 is to be installed
 libkf5calendarsupport-data : Breaks: korganizer (<= 4:16.04) but 4:4.14.10-siduction1.7 is to be installed
 libkf5libkdepim-data : Breaks: kaddressbook (< 4:16.04) but 4:4.14.10-siduction1.7 is to be installed
E: Error, pkgProblemResolver::Resolve generated breaks, this may be caused by held packages.

But...

Code: [Select]
apt-cache policy akonadi-server
akonadi-server:
  Installed: 1.13.0-8
  Candidate: 4:16.04.3-1
  Version table:
     4:16.04.3-1 500
        500 http://ftp.au.debian.org/debian unstable/main amd64 Packages
 *** 1.13.0-8 100
        100 /var/lib/dpkg/status
apt-cache policy akonadiconsole
akonadiconsole:
  Installed: 4:4.14.10-siduction1.7
  Candidate: 4:16.04.3-1
  Version table:
     4:16.04.3-1 500
        500 http://ftp.au.debian.org/debian unstable/main amd64 Packages
 *** 4:4.14.10-siduction1.7 100
        100 /var/lib/dpkg/status
root@sidvicious:/home/dave# apt-cache policy kmail
kmail:
  Installed: 4:4.14.10-siduction1.7
  Candidate: 4:16.04.3-1
  Version table:
     4:16.04.3-1 500
        500 http://ftp.au.debian.org/debian unstable/main amd64 Packages
 *** 4:4.14.10-siduction1.7 100
        100 /var/lib/dpkg/status
root@sidvicious:/home/dave# apt-cache policy korganizer
korganizer:
  Installed: 4:4.14.10-siduction1.7
  Candidate: 4:16.04.3-1
  Version table:
     4:16.04.3-1 500
        500 http://ftp.au.debian.org/debian unstable/main amd64 Packages
 *** 4:4.14.10-siduction1.7 100
        100 /var/lib/dpkg/status

So it seems while the upgradable packages are available, it wants to pull down older versions.

Oh and the following,

Code: [Select]
apt-cache policy kontact
kontact:
  Installed: 4:4.14.10-siduction1.7
  Candidate: 4:16.04.3-1
  Version table:
     4:16.04.3-1 500
        500 http://ftp.au.debian.org/debian unstable/main amd64 Packages
 *** 4:4.14.10-siduction1.7 100
        100 /var/lib/dpkg/status
« Last Edit: 2016/08/02, 10:59:20 by Taliesin »

Offline davidb

  • User
  • Posts: 29
    • http://brandesign.org
Re: WARNING: KDEPim 16.04.2-1 Transitions started
« Reply #49 on: 2016/08/02, 11:29:53 »
Yep, same as Tallesin.

Offline davidb

  • User
  • Posts: 29
    • http://brandesign.org
Re: WARNING: KDEPim 16.04.2-1 Transitions started
« Reply #50 on: 2016/08/02, 18:07:46 »
Code: [Select]
sudo apt-mark hold akonadi-server libkf5calendarsupport-data libkf5ksieve-data libkf5libkdepim-data
Makes it possible to du again, but a solution would be very nice. Maybe it will resolve automaticly after some time...

Offline der_bud

  • User
  • Posts: 921
  • member
Re: WARNING: KDEPim 16.04.2-1 Transitions started
« Reply #51 on: 2016/08/02, 21:17:28 »
Hi, sorry to say that, but it will not heal itself. You both seem to have leftovers from kdenext repo, which is no longer available. The packages are on your system now and not upgradable because of dependency issues ( /me no apt guru, perhaps someone else can can explain better).

So manual work is needed. You should delete the packages mentioned in the error messages and take note (!) of what apt does and which other packages are removed with the commands you issue (pipe output to a text file or such). Then reinstall those packages, I don't know if it is necessary to force the version in some cases. You should as well search your system for other suspect packages, meaning those with 'siduction' or 'really' in the package version string.

All this is not for granted, so have a backup. If unsure, come to IRC where might be better experts than me, prepare to work and chat in text mode and know how to use a paste service ;).
Du lachst? Wieso lachst du? Das ist doch oft so, Leute lachen erst und dann sind sie tot.

Offline Taliesin

  • User
  • Posts: 67
Re: WARNING: KDEPim 16.04.2-1 Transitions started
« Reply #52 on: 2016/08/03, 01:39:06 »
Hi der_bud.

thanks for the information.

Interesting to note that remnants of kdenext may well be the cause of the problem.

I'm more than happy to fire up a console and do things manually, in fact I prefer it that way.

Unfortunately I'm more familiar with how to 'force upgrade' and 'forcibly remove' individual packages of specific versions using RPM from my Fedora / Redhat days of long past.

Any one have any tips on how to do so using apt / apt-get.

I'll post the results of successes for the assistance of others.

Likewise the results of 'failures' for the purpose of further assistance if needed.

Cheers.
« Last Edit: 2016/08/03, 01:48:12 by Taliesin »

Offline hendrikL

  • User
  • Posts: 404
Re: WARNING: KDEPim 16.04.2-1 Transitions started
« Reply #53 on: 2016/08/03, 08:26:18 »
Maybe you are able to find some background information and a solution here:

http://forum.siduction.org/index.php?topic=5943.0
http://forum.siduction.org/index.php?topic=6072.msg50017#msg50017
http://forum.siduction.org/index.php?topic=5943.msg49417#msg49417

and please if nothing works -> irc.oftc.net #siduction
remember most members there are from Europa, okay piper not ;)

Okay, for sure, you can ask here too, if you run in trouble with removing the leftovers.

greetz. 

Offline Taliesin

  • User
  • Posts: 67
Re: WARNING: KDEPim 16.04.2-1 Transitions started
« Reply #54 on: 2016/08/03, 12:16:20 »
Hi all,

fixed and successfully dist-upgraded.

It was a 'simple' process of uninstalling the 'outdated' kdepim and associated packages, using

Code: [Select]
apt-get remove --purge "name of package"
  • akonadiconsole
  • kmail
  • korganizer
  • kaddressbook
  • kontact
Once done, then I simply did an update / dist-upgrade.

Reinstalled the kdepim packages.

All good now.

Here I was thinking I'd have to chase down individual dependencies....

My thanks to all who have offered advice.
« Last Edit: 2016/08/03, 12:24:21 by Taliesin »

Offline bluelupo

  • Global Moderator
  • User
  • *****
  • Posts: 2.066
    • BluelupoMe
Re: WARNING: KDEPim 16.04.2-1 Transitions started
« Reply #55 on: 2016/08/04, 09:19:18 »
Eine Antwort zu meinen KDE-Bugreport bzgl. dem nicht angezeigten Adressbuch (via Owncloud).

Offline davidb

  • User
  • Posts: 29
    • http://brandesign.org
Re: WARNING: KDEPim 16.04.2-1 Transitions started
« Reply #56 on: 2016/08/06, 12:56:11 »
My thanks to all who have offered advice.


Yes, that worked. Thank you!

Offline bluelupo

  • Global Moderator
  • User
  • *****
  • Posts: 2.066
    • BluelupoMe
Re: WARNING: KDEPim 16.04.2-1 Transitions started
« Reply #57 on: 2016/08/06, 13:16:06 »
Hi Taliesin,

do you have a possibility to include an addressbook of a resource ownCloud? This does not work for me.

Offline orinoco

  • User
  • Posts: 172
Re: WARNING: KDEPim 16.04.2-1 Transitions started
« Reply #58 on: 2016/08/06, 21:11:59 »
Hello,


a few days ago I installed PaintItBlack from scratch on a spare machine to follow devils recommendation. I'm sad to say, I got the same error message "Failed to fetch resource collection" after starting kmail.


Totally clueless. How did you got kontact/kmail to work properly?


Offline Pip

  • User
  • Posts: 60
Re: WARNING: KDEPim 16.04.2-1 Transitions started
« Reply #59 on: 2016/08/07, 00:13:11 »
Personally, I haven't. Tried a few things, but most clues seem to refer back to 2011 and they don't seem to apply any more.