seduction
 Language:
Welcome, Guest. Please login or register.
Did you miss your activation email?
2017/03/24, 16:58:11


Help

Author [EN] [PL] [ES] [PT] [IT] [DE] [FR] [NL] [TR] [SR] [AR] [RU] Topic: [solved] Grafikfehler: Intel HD Graphics 3000 u. Browser Tooltips  (Read 405 times)

0 Members and 1 Guest are viewing this topic.

Offline pit

  • User
  • Posts: 181
Ich weiß nicht, ob das Thema im Subforum "Hardware" richtig ist - möglicherweise ist das ein Treiberproblem?

Egal welchen Browser ich verwende (aktuell z.B. vivaldi) - immer wieder werden Tooltips fehlerhaft abgebildet. Beispiel:


Meistens wird bei einem erneuten hover das Tooltip korrekt angezeigt - ich hab's hier zur Verdeutlichung mal rot umrandet:

OS & Hardware:

Code: [Select]
System:    Host: DellVostro3450 Kernel: 4.9.0-towo.2-siduction-amd64 x86_64 (64 bit) Desktop: KDE Plasma 5.8.4
           Distro: siduction 14.1.0 Indian Summer - kde - (201411230337)


CPU:       Dual core Intel Core i3-2310M (-HT-MCP-) cache: 3072 KB
           clock speeds: max: 2100 MHz 1: 1204 MHz 2: 803 MHz 3: 1068 MHz 4: 818 MHz

Graphics:  Card: Intel 2nd Generation Core Processor Family Integrated Graphics Controller
           Intel® HD Graphics 3000
           Display Server: X.Org 1.19.0 drivers: modesetting (unloaded: fbdev,vesa)
           Resolution: 1366x768@60.00hz
           GLX Renderer: Mesa DRI Intel Sandybridge Mobile GLX Version: 3.0 Mesa 13.0.2
« Last Edit: 2017/01/07, 13:54:38 by pit »

Offline musca

  • Global Moderator
  • User
  • *****
  • Posts: 685
  • sid, fly high!
Re: Grafikfehler: Intel HD Graphics 3000 u. Browser Tooltips
« Reply #1 on: 2017/01/06, 23:49:46 »
Hallo pit,
du hast einen Prozessor der SandyBridge-Generation, also neu genug für Sandybridge New Acceleration (SNA) und alt genug, um nicht den mittlerweile mangelhaften Fortschritt beim Intel-Treiber zu vermissen.

Installiere den xserver-xorg-video-intel und konfiguriere deinen Xserver, diesen Treiber auch zu verwenden.

Code: [Select]
mkdir -p /etc/X11/xorg.conf.d/
cp /usr/share/doc/xserver-xorg-video-intel/xorg.conf  /etc/X11/xorg.conf.d/20-intel.conf

Bei auftretenden neuen Problemen kann man diese Änderungen wieder rückgängig machen.

greetings
musca
„Es irrt der Mensch, solang er strebt.“  (Goethe, Faust)

Offline pit

  • User
  • Posts: 181
@musca

Ganz herzlichen Dank! Ich bin deinem Vorschlag gefolgt - bis jetzt sind die beschriebenen Probleme nicht erneut aufgetreten. Und so sieht's jetzt aus:

Code: [Select]
$ inxi -G
Graphics:  Card: Intel 2nd Generation Core Processor Family Integrated Graphics Controller
           Display Server: X.Org 1.19.0 driver: intel Resolution: 1366x768@60.00hz
           GLX Renderer: Mesa DRI Intel Sandybridge Mobile GLX Version: 3.0 Mesa 13.0.2

Offline pit

  • User
  • Posts: 181
Möglicherweise taugt die Lösung doch nicht. Ich bin mittlerweile auch in den "Plasmashell (panel aka Kontrolleiste) freezes every few minutes" Fehler reingelaufen.

Die unveränderte Datei 20-intel.conf enthält diese auskommentierte Zeile:
 
Code: [Select]
#       Option "AccelMethod" "uxa"
Ich habe sie wie im o.g. Thread empfohlen geändert auf:

Code: [Select]
Option "DRI" "3"
Augenblicklich läuft alles wie gewünscht. Ich werde das noch eine Weile beobachten.

Offline pit

  • User
  • Posts: 181
Falls nochmal jemand über diesen Thread stolpert: Nach längerem Testen kann ich nur davor abraten, den Intel Grafik Treiber (xserver-xorg-video-intel) einzusetzen. Ich beobachte auf zwei Rechnern (s.u.) mit integrierter Intel Grafik identische Fehler. Zwar ist der eingangs beschriebene Tooltip-Fehler behoben, dafür friert aber die Plasma/KDE Kontrollleiste mit schöner Regelmäßigkeit ein.

Mein Tipp: Finger weg!

Desktop: i7 3770 (Ivy Bridge => Intel® HD Graphics 4000)
Laptop i3-2310M (SandyBridge => Intel® HD Graphics 3000)

Offline bluelupo

  • Global Moderator
  • User
  • *****
  • Posts: 1.948
    • http://bluelupo.net
@Pit: was für xserver hast du nun installiert?
Ciao bluelupo
BlueLupo's Wiki - BlueLupo's Blog
BlueLupo bei GooglePlus
Bluelupo bei Diaspora*

Offline pit

  • User
  • Posts: 181
Code: [Select]
$ inxi -G
Graphics:  Card: Intel 2nd Generation Core Processor Family Integrated Graphics Controller
           Display Server: X.Org 1.19.1 drivers: modesetting (unloaded: fbdev,vesa)
           Resolution: 1366x768@60.00hz
           GLX Renderer: Mesa DRI Intel Sandybridge Mobile GLX Version: 3.0 Mesa 13.0.3

Und keine Ahnung ob von diesen Paketen überhaupt was in Verwendung ist - kann mich nicht erinnern, diese bewusst installiert zu haben:

Code: [Select]
$ dpkg -l | grep xserver
ii  x11-xserver-utils                              7.7+7                                amd64        X server utilities
ii  xserver-common                                 2:1.19.1-1                           all          common files used by various X servers
ii  xserver-xorg                                   1:7.7+18                             amd64        X.Org X server
ii  xserver-xorg-core                              2:1.19.1-1                           amd64        Xorg X server - core server
ii  xserver-xorg-input-all                         1:7.7+18                             amd64        X.Org X server -- input driver metapackage
ii  xserver-xorg-input-evdev                       1:2.10.4-1+b1                        amd64        X.Org X server -- evdev input driver
ii  xserver-xorg-input-libinput                    0.23.0-2                             amd64        X.Org X server -- libinput input driver
ii  xserver-xorg-input-mouse                       1:1.9.2-1+b1                         amd64        X.Org X server -- mouse input driver
ii  xserver-xorg-input-synaptics                   1.9.0-1+b1                           amd64        Synaptics TouchPad driver for X.Org server
ii  xserver-xorg-input-wacom                       0.33.0-1+b1                          amd64        X.Org X server -- Wacom input driver
ii  xserver-xorg-video-ati                         1:7.8.0-1+b1                         amd64        X.Org X server -- AMD/ATI display driver wrapper
ii  xserver-xorg-video-fbdev                       1:0.4.4-1+b5                         amd64        X.Org X server -- fbdev display driver
ii  xserver-xorg-video-mach64                      6.9.5-1+b2                           amd64        X.Org X server -- ATI Mach64 display driver
ii  xserver-xorg-video-mga                         1:1.6.4-2+b1                         amd64        X.Org X server -- MGA display driver
rc  xserver-xorg-video-modesetting                 0.9.0-1+b1                           amd64        X.Org X server -- Generic modesetting driver
ii  xserver-xorg-video-nouveau                     1:1.0.13-1+b1                        amd64        X.Org X server -- Nouveau display driver
ii  xserver-xorg-video-r128                        6.10.1-2+b1                          amd64        X.Org X server -- ATI r128 display driver
ii  xserver-xorg-video-radeon                      1:7.8.0-1+b1                         amd64        X.Org X server -- AMD/ATI Radeon display driver
ii  xserver-xorg-video-vesa                        1:2.3.4-1+b2                         amd64        X.Org X server -- VESA display driver
ii  xserver-xorg-video-vmware                      1:13.2.1-1+b1                        amd64        X.Org X server -- VMware display driver