seduction
 Language:
Welcome, Guest. Please login or register.
Did you miss your activation email?
2019/11/12, 22:45:05


Help

Author [EN] [PL] [ES] [PT] [IT] [DE] [FR] [NL] [TR] [SR] [AR] [RU] Topic: Firefox slow after DU [Solved]  (Read 3345 times)

0 Members and 1 Guest are viewing this topic.

Offline finotti

  • User
  • Posts: 101
Firefox slow after DU [Solved]
« on: 2016/07/24, 11:26:10 »
Dear all,

After a recent DU, Firefox is incredibly slow, for instance, when scrolling it lags almost a second before the page actually moves.


I created a new user, using Firefox fresh with no plugins, in a plain HTML page (no scripts, flash, ads, nothing) and I still have this problem.  I tried it in Plasma and in fluxbox, with the same result.  The memory and CPU usages do not go high when using Firefox.


Chromium runs just fine.


This started happening right after a recent DU.  Here are my logs for that DU: http://paste.siduction.org/20160724090508


I suspected the new xorg-core, but I see no errors in Xorg.0.log: http://paste.siduction.org/20160724090732


Since a new kernel also came, I also tried an older kernel, but it did not help.  (I see no kernel.log in /var/log/.  Is that normal?)


I have no idea where else to look for problems.


Here is some info on the laptop:


Code: [Select]
e7440[~]$ inxi -v 3
System:    Host: e7440 Kernel: 4.6.2-towo.2-siduction-amd64 x86_64 (64 bit gcc: 6.1.1)
           Desktop: KDE Plasma 5.6.5 (Qt 5.6.1)
           Distro: siduction 15.1.0 Paint It Black - kde - (201601162135)
Machine:   System: Dell (portable) product: Latitude E7440 v: 00
           Mobo: Dell model: 07F3F4 v: A00 Bios: Dell v: A17 date: 12/01/2015
Battery    BAT0: charge: 64.4 Wh 128.0% condition: 50.3/64.4 Wh (78%)
           model: SMP DELL 909H538 status: Full
CPU:       Dual core Intel Core i7-4600U (-HT-MCP-) cache: 4096 KB
           flags: (lm nx sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx) bmips: 10778
           clock speeds: max: 3300 MHz 1: 1245 MHz 2: 2099 MHz 3: 1338 MHz 4: 2083 MHz
Graphics:  Card: Intel Haswell-ULT Integrated Graphics Controller bus-ID: 00:02.0
           Display Server: X.Org 1.18.4 drivers: (unloaded: fbdev,vesa) Resolution: 1920x1080@60.02hz
           GLX Renderer: Mesa DRI Intel Haswell Mobile
           GLX Version: 3.0 Mesa 11.2.2 Direct Rendering: Yes
Network:   Card-1: Intel Ethernet Connection I218-LM
           driver: e1000e v: 3.2.6-k port: f080 bus-ID: 00:19.0
           IF: eno1 state: down mac: 34:e6:d7:19:d5:4d
           Card-2: Intel Wireless 7260 driver: iwlwifi bus-ID: 02:00.0
           IF: wlp2s0 state: up mac: 48:51:b7:67:5b:a1
Drives:    HDD Total Size: 256.1GB (44.3% used) ID-1: model: SAMSUNG_SSD_PM85
Info:      Processes: 231 Uptime: 6:30 Memory: 2989.7/7895.6MB
           Init: systemd runlevel: 5 Gcc sys: 5.4.0 Client: Shell (bash 4.3.461) inxi: 2.3.0


Any help would be greatly appreciated.


Best to all,


Luis


P.S.: I thought of putting this on Upgrade Warnings, but since I am the only one who seems to be having this problem, I thought maybe Software would be better.  Mods, feel free to move this if it seems appropriate.
« Last Edit: 2016/07/28, 14:53:06 by finotti »

Offline musca

  • Global Moderator
  • User
  • *****
  • Posts: 725
  • sid, fly high!
Re: Firefox slow after DU
« Reply #1 on: 2016/07/24, 12:06:05 »
Hello finotti,

kernel 4.6 enabled Frame-Buffer Compression (FBC) in the intel driver again by default on Haswell and Broadwell GPUs.

You can try to boot with disabled FBC by adding the cheat code "i915.enable_fbc=0" to the linux cmdline (Press "e" in grub menu). If it works you can permanently add it to your modules options.

greetings
musca
« Last Edit: 2016/07/24, 12:10:57 by musca »
„Es irrt der Mensch, solang er strebt.“  (Goethe, Faust)

Offline finotti

  • User
  • Posts: 101
Re: Firefox slow after DU
« Reply #2 on: 2016/07/24, 12:34:04 »
Thanks, Musca, for the very quick reply!


Is there a place where to put the code in grub screen (after "e")?  Make a new line with it?


Also, to make it permanent (if it works), is it in /etc/default/grub in GRUB_CMDLINE_LINUX_DEFAULT?


Thanks again,


Luis

Offline devil

  • Administrator
  • User
  • *****
  • Posts: 4.373
Re: Firefox slow after DU
« Reply #3 on: 2016/07/24, 12:50:49 »
I cannot confirm this behaviour on two machines. Firefox and Okular are as fast as usual.


greetz
devil


Offline finotti

  • User
  • Posts: 101
Re: Firefox slow after DU
« Reply #4 on: 2016/07/24, 13:16:19 »
Thanks, Musca, for the very quick reply!


Is there a place where to put the code in grub screen (after "e")?  Make a new line with it?


Also, to make it permanent (if it works), is it in /etc/default/grub in GRUB_CMDLINE_LINUX_DEFAULT?


Thanks again,


Luis


OK, tried both with no result.  Also, an old 4.4 kernel (original from the last release) did not help.


I cannot confirm this behaviour on two machines. Firefox and Okular are as fast as usual.


greetz
devil




Thanks, devil.  I was pretty sure it was not a common issue as it is not subtle at all.  It makes Firefox unusable.


If anyone has any ideas or suggestions, it would be really appreciated...


Best to all,


Luis

Offline devil

  • Administrator
  • User
  • *****
  • Posts: 4.373
Re: Firefox slow after DU
« Reply #5 on: 2016/07/24, 14:22:44 »
Try with a new empty profile. If that works fine, you have cruft in your profile.


greetz
devil

Offline finotti

  • User
  • Posts: 101
Re: Firefox slow after DU
« Reply #6 on: 2016/07/24, 14:30:40 »
Try with a new empty profile. If that works fine, you have cruft in your profile.


greetz
devil


Thanks again, devil.  I tried a new user with a new default profile (even under fluxbox) and had the same problem.  But thanks for the suggestion!

Offline piper

  • Global Moderator
  • User
  • *****
  • Posts: 1.719
  • we are the priests ... of the temples of syrinx
Re: Firefox slow after DU
« Reply #7 on: 2016/07/24, 16:08:16 »
See if this helps

Code: [Select]
apt install sqlite3
close firefox, as user

Code: [Select]
find ~/.mozilla/firefox/ -type f -name "*.sqlite" -exec sqlite3 {} VACUUM \;
also make sure Enable multi-process is disabled (if in your build)

Mozilla/5.0 (X11; Linux x86_64; rv:50.0) Gecko/20100101 Firefox/50.0 ID:20160722030235 CSet: e0bc88708ffed39aaab1fbc0ac461d93561195de
« Last Edit: 2016/07/24, 16:15:20 by piper »
I either give too many fucks or no fucks at all, it's like I cannot find a middle ground for a moderate fuck distribution, it's like what the fuck

Free speech isn't just fucking saying what you want to say, it's also hearing what you don't want to fucking hear

Offline finotti

  • User
  • Posts: 101
Re: Firefox slow after DU
« Reply #8 on: 2016/07/24, 18:41:29 »
See if this helps

Code: [Select]
apt install sqlite3
close firefox, as user

Code: [Select]
find ~/.mozilla/firefox/ -type f -name "*.sqlite" -exec sqlite3 {} VACUUM \;
also make sure Enable multi-process is disabled (if in your build)

Mozilla/5.0 (X11; Linux x86_64; rv:50.0) Gecko/20100101 Firefox/50.0 ID:20160722030235 CSet: e0bc88708ffed39aaab1fbc0ac461d93561195de


Thanks, Piper, but still did not work...

Offline buhtz

  • User
  • Posts: 42
Re: Firefox slow after DU
« Reply #9 on: 2016/07/24, 20:23:51 »
I have similar problems.

I installed a fresh Siduction Xfce and did a d-u. I tried scrolling in FF with mouse-wheel, dragging the scrollbar and with arrow keys. Allways the same. My old profile (with addblocker) and on a absolute fresh profile (without any addon). I tried kernel 4.4 and 4.6. Nothing changed.

Other applications scrollbehaviour is without problems and quite smooth.

I tried the "i915.enable_fbc=0" option. I check if it is correct set with "cat /proc/cmdline". Checked!
And it is on:
$ sudo cat /sys/module/i915/parameters/enable_fbc
0

But the problem is still there.
« Last Edit: 2016/07/24, 20:34:23 by buhtz »

Offline finotti

  • User
  • Posts: 101
Re: Firefox slow after DU
« Reply #10 on: 2016/07/25, 04:28:23 »
I have similar problems.

I installed a fresh Siduction Xfce and did a d-u. I tried scrolling in FF with mouse-wheel, dragging the scrollbar and with arrow keys. Allways the same. My old profile (with addblocker) and on a absolute fresh profile (without any addon). I tried kernel 4.4 and 4.6. Nothing changed.

Other applications scrollbehaviour is without problems and quite smooth.

I tried the "i915.enable_fbc=0" option. I check if it is correct set with "cat /proc/cmdline". Checked!
And it is on:
$ sudo cat /sys/module/i915/parameters/enable_fbc
0

But the problem is still there.


I am sorry to hear you are having the same problem...  Are you also having problems playing video?  For me youtube or local videos are playing a bit rough (opposite of smooth).  I am not sure if it is related...

Offline piper

  • Global Moderator
  • User
  • *****
  • Posts: 1.719
  • we are the priests ... of the temples of syrinx
Re: Firefox slow after DU
« Reply #11 on: 2016/07/25, 09:43:20 »
Curious, in

Code: [Select]
about:preferences#advanced 

are both these

Code: [Select]
Use autoscrolling
Use smooth scrolling

unchecked ?

Also, what happens if you enable/disable

Code: [Select]
Use hardware acceleration when available
I either give too many fucks or no fucks at all, it's like I cannot find a middle ground for a moderate fuck distribution, it's like what the fuck

Free speech isn't just fucking saying what you want to say, it's also hearing what you don't want to fucking hear

Offline dibl

  • siduction community member
  • Global Moderator
  • User
  • *****
  • Posts: 1.925
    • Land of the Buckeye
Re: Firefox slow after DU
« Reply #12 on: 2016/07/25, 12:00:29 »

Chromium runs just fine.



If this is true for videos and scrolling the same pages that are problematic for Firefox, then I don't see how the problem can be any deeper than Firefox and its configurations.  Do VLC or other video players work correctly?
Asus ROG STRIX X299-E, Core i7-7740X, Nvidia GTX-1060, dual monitors, SSD 860 EVO, 2@WD1003FZEX in BTRFS

Online towo

  • Global Moderator
  • User
  • *****
  • Posts: 2.308
Re: Firefox slow after DU
« Reply #13 on: 2016/07/25, 12:25:36 »
Maybe it's Xserver related. For now, debian is using modesetting DDX instead of intel-DDX for most intel graphics.
Please have a look in your x-log, which driver is used.
Ich gehe nicht zum Karneval, ich verleihe nur manchmal mein Gesicht.

Offline finotti

  • User
  • Posts: 101
Re: Firefox slow after DU
« Reply #14 on: 2016/07/26, 01:35:32 »

Firstly, thanks all for the support!

Curious, in

Code: [Select]
about:preferences#advanced 

are both these

Code: [Select]
Use autoscrolling
Use smooth scrolling

unchecked ?

Also, what happens if you enable/disable

Code: [Select]
Use hardware acceleration when available


I've tried them all and did not notice a difference.



Chromium runs just fine.



If this is true for videos and scrolling the same pages that are problematic for Firefox, then I don't see how the problem can be any deeper than Firefox and its configurations.  Do VLC or other video players work correctly?


So, the scrolling problem is really bad in Firefox, but not bad at all with Chromium.  The problems with video happen  in Chrome too, as well as local files with vlc, mpv, smplayer and dragon player.  So, I think it is really an Xorg problem.   Even switching virtual desktops is not very smooth anymore.

Maybe it's Xserver related. For now, debian is using modesetting DDX instead of intel-DDX for most intel graphics.
Please have a look in your x-log, which driver is used.




My Xorg.0.log is posted above (here too: http://paste.siduction.org/20160724090732).  I cannot find ddx in it at all.  Searching for "driver" I see:


Code: [Select]
[ 22276.162] (II) modeset(0): [DRI2]   DRI driver: i965
[ 22276.162] (II) modeset(0): [DRI2]   VDPAU driver: i965


Does that help?


Thanks again,


Luis