seduction
 Language:
Welcome, Guest. Please login or register.
Did you miss your activation email?
2020/11/27, 03:07:35


Help

Author [EN] [PL] [ES] [PT] [IT] [DE] [FR] [NL] [TR] [SR] [AR] [RU] Topic: [solved] Warnig: No dist-upgrade  (Read 13182 times)

0 Members and 1 Guest are viewing this topic.

Offline Taliesin

  • User
  • Posts: 67
Re: Warnig: No dist-upgrade
« Reply #45 on: 2016/11/29, 09:04:39 »
Danke schon

Offline piper

  • Global Moderator
  • User
  • *****
  • Posts: 1.787
  • we are the priests ... of the temples of syrinx
Re: Warnig: No dist-upgrade
« Reply #46 on: 2016/11/29, 10:10:54 »
On my box  (YMMV)

Code: [Select]
root /home/piper # apt update && apt full-upgrade -d
Hit:1 http://deb.debian.org/debian unstable InRelease
Hit:2 http://deb.debian.org/debian testing InRelease                                                                                       
Hit:3 http://deb.debian.org/debian experimental InRelease
Hit:4 https://liquorix.net/siduction/extra unstable InRelease
Hit:5 http://www.deb-multimedia.org sid InRelease
Hit:6 https://liquorix.net/siduction/fixes unstable InRelease
Hit:7 https://dl.winehq.org/wine-builds/debian sid InRelease
Hit:8 http://packages.siduction.org/extra experimental InRelease
Hit:9 http://packages.siduction.org/user experimental InRelease
Hit:10 http://packages.siduction.org/user unstable InRelease
Reading package lists... Done
Building dependency tree
Reading state information... Done
All packages are up to date.
Reading package lists... Done
Building dependency tree
Reading state information... Done
Calculating upgrade... Done
0 upgraded, 0 newly installed, 0 to remove and 0 not upgraded.
Free speech isn't just fucking saying what you want to say, it's also hearing what you don't want to fucking hear

I either give too many fucks or no fucks at all, it's like I cannot find a middle ground for a moderate fuck distribution, it's like what the fuck

Offline terroreek

  • User
  • Posts: 173
Re: Warnig: No dist-upgrade
« Reply #47 on: 2016/11/29, 14:41:50 »
from apt show libegl1-nvidia




Package: libegl1-nvidia
Version: 375.20-1.1
Priority: extra
Section: non-free/oldlibs
Source: nvidia-graphics-drivers
Maintainer: Debian NVIDIA Maintainers <pkg-nvidia-devel@lists.alioth.debian.org>
Installed-Size: 216 kB
Depends: nvidia-alternative (= 375.20-1.1)
Conflicts: libegl1-glvnd-nvidia
Replaces: libegl1-glvnd-nvidia



I think I am even more confused as to which package I should be installing now.

Code: [Select]
Package: libegl1-glvnd-nvidia
Version: 375.20-1.1
Priority: optional
Section: non-free/libs
Source: nvidia-graphics-drivers
Maintainer: Debian NVIDIA Maintainers <pkg-nvidia-devel@lists.alioth.debian.org>
Installed-Size: 271 kB
Depends: nvidia-alternative (= 375.20-1.1), glvnd-nvidia-abi-361.45, libc6 (>= 2.2.5), libgldispatch0 | libgldispatch0-nvidia
 (>= 375.20)
Conflicts: libegl1-nvidia
Replaces: libegl1-nvidia
Homepage: http://www.nvidia.com
Download-Size: 193 kB
APT-Manual-Installed: no
APT-Sources: http://packages.siduction.org/fixes unstable/non-free amd64 Packages
Description: NVIDIA binary EGL GLVND stub library
 EGL provides a platform-agnostic mechanism for creating rendering surfaces
 for use with other graphics libraries, such as OpenGL|ES.
 .
 This package contains the (binary) GLVND libEGL.so.1 stub library provided by
 NVIDIA which dispatches to vendor implementations (libEGL_*.so.0) via GLVND.


and

Code: [Select]
Package: libegl1-nvidia
Version: 375.20-1.1
Priority: extra
Section: non-free/oldlibs
Source: nvidia-graphics-drivers
Maintainer: Debian NVIDIA Maintainers <pkg-nvidia-devel@lists.alioth.debian.org>
Installed-Size: 216 kB
Depends: nvidia-alternative (= 375.20-1.1)
Conflicts: libegl1-glvnd-nvidia
Replaces: libegl1-glvnd-nvidia
Homepage: http://www.nvidia.com
Download-Size: 173 kB
APT-Sources: http://packages.siduction.org/fixes unstable/non-free amd64 Packages
Description: NVIDIA binary EGL library (transitional)
 EGL provides a platform-agnostic mechanism for creating rendering surfaces
 for use with other graphics libraries, such as OpenGL|ES.
 .
 This package contains the driver specific binary EGL implementation by NVIDIA
 as a non-glvnd alternative.

Both look like they are identical to each other but libegl1-glvnd-nvidia uses the Open GL Vendor Neutral driver.

I think libegl1-glvnd-nvidia is the right package, silly question anyone know why one would rather the libegl1-nvidia package??  Would it provide better performance?

Offline pjnsmb

  • User
  • Posts: 71
Re: Warnig: No dist-upgrade
« Reply #48 on: 2016/11/29, 14:54:05 »

@terroreek

Is is safe to assume the libegl1-glvnd-nvidia replaces the libegl1-nvidia package???


you have them the wrong way round !


look at my post :



from apt show libegl1-nvidia



Package: libegl1-nvidia
Version: 375.20-1.1


Conflicts: libegl1-glvnd-nvidia
Replaces: libegl1-glvnd-nvidia
regards
pjnsmb

Offline terroreek

  • User
  • Posts: 173
Re: Warnig: No dist-upgrade
« Reply #49 on: 2016/11/30, 03:13:04 »
@pjnsmb I did see your post, did you happen to look at mine??

Both packages conflict and replace the other.  I happened to look into it further and it looks like this glvnd is newer, but the option to install the legacy non-glvnd libraries are there because certain applications with incompatibilities with the glvnd binaries from Nvidia. 

Here are some resources I found.

https://devtalk.nvidia.com/default/topic/915640/unix-graphics-announcements-and-news/multiple-glx-client-libraries-in-the-nvidia-linux-driver-installer-package/

https://www.reddit.com/r/archlinux/comments/44zqau/nvidia_36128_and_glvnd_with_steam_games/

Looks like I'll fire up steam and see if my games work or not. -edit- games seem to work still.
« Last Edit: 2016/11/30, 03:44:13 by terroreek »

Offline paxmark2

  • User
  • Posts: 84
Re: Warnig: No dist-upgrade
« Reply #50 on: 2016/11/30, 03:33:11 »
After a wait my full-upgrade was dull in lxqt.  My apt full-upgrades on two testing machines with lxqt was dull also.  Intel atom - aspire one with Sparky linux and intel i3 with vanilla debian.  Really appreciate the info.  I wasn't sure if xorg 1.18 was going to go to testing.  Silly me.

Offline KrunchTime

  • User
  • Posts: 183
Re: Warnig: No dist-upgrade
« Reply #51 on: 2016/11/30, 09:55:53 »
It has been 2 or more weeks since I last updated Bunsen Labs tracking Unstable on my laptop, so this morning I opted to cherry pick...again.  After my mishap on my desktop, I did some research into apt-get and discovered a very useful option:
Code: [Select]
--no-remove
Usage example:
Code: [Select]
sudo apt-get install --no-remove pkgname
So, after over 2 hours I went from the following:
Code: [Select]
The following packages were automatically installed and are no longer required:
  gir1.2-javascriptcoregtk-4.0 gir1.2-soup-2.4 gir1.2-webkit2-4.0 libadns1
  libidl-2-0 libip6tc0 libiptc0 libllvm3.8 libllvm3.8:i386 liborbit2
  liborc-0.4-0:i386 libschroedinger-1.0-0 libschroedinger-1.0-0:i386
  libspeechd2 libssl1.0.2:i386 libudev1:i386 python-gconf python-gnome2
  python-pyorbit
Use 'sudo apt autoremove' to remove them.
The following packages will be REMOVED:
  gufw iptables ufw xserver-xorg-input-vmmouse xserver-xorg-video-sisusb
The following NEW packages will be installed:
  gir1.2-gconf-2.0 gir1.2-keybinder-3.0 gir1.2-notify-0.7 libkeybinder-3.0-0
  libldap-common libllvm3.9 libllvm3.9:i386 liblz4-1:i386 libminizip1 libre2-3
  libsensors4:i386 libssl1.1:i386 libxfont2 python-psutil
The following packages will be upgraded:
  apt apt-listchanges apt-transport-https apt-utils base-files bash binutils
  bunsen-os-release bunsen-python-apt-template chromium clamtk console-setup
  console-setup-linux cpio cpp cpp-6 dbus dbus-user-session dbus-x11
  debianutils devscripts dirmngr dpkg dpkg-dev exim4 exim4-base exim4-config
  exim4-daemon-light ffmpeg fonts-freefont-ttf fonts-lyx fonts-noto-mono
  fonts-opensymbol g++ g++-6 gcc gcc-6 gcc-6-base gcc-6-base:i386 gdebi
  gdebi-core geany geany-common geany-plugin-addons geany-plugin-autoclose
  geany-plugin-automark geany-plugin-codenav geany-plugin-commander
  geany-plugin-ctags geany-plugin-debugger geany-plugin-defineformat
  geany-plugin-devhelp geany-plugin-doc geany-plugin-extrasel
  geany-plugin-gendoc geany-plugin-geniuspaste geany-plugin-git-changebar
  geany-plugin-insertnum geany-plugin-latex geany-plugin-lineoperations
  geany-plugin-lipsum geany-plugin-lua geany-plugin-macro
  geany-plugin-markdown geany-plugin-miniscript geany-plugin-multiterm
  geany-plugin-numberedbookmarks geany-plugin-overview
  geany-plugin-pairtaghighlighter geany-plugin-pg geany-plugin-pohelper
  geany-plugin-prettyprinter geany-plugin-prj geany-plugin-projectorganizer
  geany-plugin-py geany-plugin-scope geany-plugin-sendmail
  geany-plugin-shiftcolumn geany-plugin-spellcheck geany-plugin-tableconvert
  geany-plugin-treebrowser geany-plugin-updatechecker geany-plugin-vc
  geany-plugin-webhelper geany-plugin-xmlsnippets geany-plugins
  geany-plugins-common ghostscript ghostscript-x gir1.2-gtk-3.0 gnupg
  gnupg-agent gnupg-l10n gnupg2 gpa gpgsm gpgv greybird-gtk-theme
  gstreamer1.0-libav gstreamer1.0-plugins-base gstreamer1.0-plugins-good
  gstreamer1.0-plugins-ugly gstreamer1.0-pulseaudio gstreamer1.0-x
  gtk-update-icon-cache imagemagick imagemagick-6-common imagemagick-6.q16
  imagemagick-common iso-codes jq keyboard-configuration libapt-inst2.0
  libapt-pkg5.0 libasan3 libassuan0 libatomic1 libavcodec57 libavcodec57:i386
  libavdevice57 libavfilter6 libavformat57 libavresample3 libavresample3:i386
  libavutil55 libavutil55:i386 libbasicusageenvironment1 libbluray1 libc-bin
  libc-dev-bin libc-l10n libc6 libc6:i386 libc6-dbg libc6-dev libcc1-0
  libcgi-fast-perl libcilkrts5 libconfig9 libdatetime-locale-perl
  libdatetime-perl libdatetime-timezone-perl libdbus-1-3 libdbus-1-3:i386
  libdebconfclient0 libdpkg-perl libdrm-amdgpu1 libdrm-amdgpu1:i386
  libdrm-intel1 libdrm-intel1:i386 libdrm-nouveau2 libdrm-nouveau2:i386
  libdrm-radeon1 libdrm-radeon1:i386 libdrm2 libdrm2:i386 libedit2
  libedit2:i386 libegl1-mesa libfont-afm-perl libgbm1 libgcc-6-dev libgcc1
  libgcc1:i386 libgfortran3 libgl1-mesa-dri libgl1-mesa-dri:i386
  libgl1-mesa-glx libgl1-mesa-glx:i386 libglapi-mesa libglapi-mesa:i386
  libgles1-mesa libgles2-mesa libglib2.0-0 libglib2.0-data libgnutls-openssl27
  libgnutls30 libgnutls30:i386 libgomp1 libgomp1:i386 libgpg-error0
  libgpg-error0:i386 libgpgme11 libgphoto2-6 libgphoto2-l10n libgphoto2-port12
  libgraphite2-3 libgroupsock8 libgs9 libgs9-common
  libgstreamer-plugins-base1.0-0 libgstreamer1.0-0 libgtk-3-0 libgtk-3-bin
  libgtk-3-common libhtml-parser-perl libhtml-tagset-perl libicu57
  libicu57:i386 libinput-bin libinput10 libio-socket-ssl-perl libip4tc0
  libip6tc0 libiptc0 libitm1 libjansson4 libjson-xs-perl libldap-2.4-2
  libldap-2.4-2:i386 liblivemedia57 liblockfile-bin liblockfile1 liblsan0
  liblua5.1-0 libmagickcore-6.q16-2 libmagickcore-6.q16-2-extra
  libmagickwand-6.q16-2 libmarkdown2 libmm-glib0 libmpx2 libmwaw-0.3-3
  libneon27-gnutls libnghttp2-14 libnm-glib-vpn1 libnm-glib4 libnm-util2
  libnm0 libnpth0 libosmesa6 libosmesa6:i386 libpam-systemd
  libparams-validationcompiler-perl libpath-tiny-perl libpci3 libperl5.24
  libpng16-16 libpng16-16:i386 libpostproc54 libprocps6 libprotobuf10
  libproxy-tools libproxy1v5 libpsl5 libpython2.7 libpython2.7-dev
  libpython2.7-minimal libpython2.7-stdlib libpython3.5 libpython3.5-minimal
  libpython3.5-stdlib libqt5concurrent5 libqt5core5a libqt5dbus5 libqt5gui5
  libqt5network5 libqt5opengl5 libqt5printsupport5 libqt5sql5
  libqt5sql5-sqlite libqt5test5 libqt5widgets5 libqt5xml5 libquadmath0
  libreoffice libreoffice-avmedia-backend-gstreamer libreoffice-base
  libreoffice-base-core libreoffice-base-drivers libreoffice-calc
  libreoffice-common libreoffice-core libreoffice-draw libreoffice-help-en-us
  libreoffice-impress libreoffice-java-common libreoffice-math
  libreoffice-ogltrans libreoffice-pdfimport libreoffice-report-builder-bin
  libreoffice-sdbc-hsqldb libreoffice-sdbc-postgresql libreoffice-style-galaxy
  libreoffice-style-tango libreoffice-writer libruby2.3 libsasl2-2
  libsasl2-2:i386 libsasl2-modules libsasl2-modules:i386 libsasl2-modules-db
  libsasl2-modules-db:i386 libseccomp2 libservlet3.1-java libshine3
  libshine3:i386 libsndio6.1 libsndio6.1:i386 libspecio-perl libspeechd2
  libssl1.1 libstdc++-6-dev libstdc++6 libstdc++6:i386 libswresample2
  libswresample2:i386 libswscale4 libsystemd0 libsystemd0:i386 libtiff-tools
  libtiff5 libtiff5:i386 libtsan0 libubsan0 libudev1 libudev1:i386
  libudisks2-0 libusageenvironment3 libustr-1.0-1 libva-drm1 libva-drm1:i386
  libva-wayland1 libva-x11-1 libva-x11-1:i386 libva1 libva1:i386 libvlc-bin
  libvlc5 libvlccore8 libwayland-egl1-mesa libxatracker2 libxfont1
  libxtables11 libzvbi-common libzvbi0 libzvbi0:i386 licensecheck
  lightdm-gtk-greeter linux-image-4.8.0-1-amd64 locales login lsb-base
  lsb-release man-db mesa-vdpau-drivers mesa-vdpau-drivers:i386 modemmanager
  mpv multiarch-support network-manager nitrogen ntp openssl p7zip p7zip-full
  passwd pciutils perl perl-base perl-modules-5.24 procps python-gconf
  python-gnome2 python-pyorbit python-sqlalchemy python-sqlalchemy-ext
  python-tz python2.7 python2.7-minimal python3-uno python3.5
  python3.5-minimal qt5-gtk-platformtheme rsyslog ruby-atk ruby-gdk-pixbuf2
  ruby-gio2 ruby-glib2 ruby-gobject-introspection ruby-gtk2 ruby-pango ruby2.3
  scrot systemd systemd-sysv terminator tzdata udev udisks2 uno-libs3 ure
  user-setup va-driver-all va-driver-all:i386 vlc vlc-bin vlc-data vlc-l10n
  vlc-plugin-base vlc-plugin-notify vlc-plugin-qt vlc-plugin-skins2
  vlc-plugin-video-output vlc-plugin-video-splitter vlc-plugin-visualization
  vpnc w3m x11-common xfce4-panel xfonts-utils xorg xserver-common
  xserver-xorg xserver-xorg-core xserver-xorg-input-all
  xserver-xorg-input-evdev xserver-xorg-input-libinput
  xserver-xorg-input-mouse xserver-xorg-input-synaptics
  xserver-xorg-input-void xserver-xorg-input-wacom xserver-xorg-video-all
  xserver-xorg-video-amdgpu xserver-xorg-video-ati xserver-xorg-video-cirrus
  xserver-xorg-video-dummy xserver-xorg-video-fbdev xserver-xorg-video-intel
  xserver-xorg-video-mach64 xserver-xorg-video-mga xserver-xorg-video-neomagic
  xserver-xorg-video-nouveau xserver-xorg-video-qxl xserver-xorg-video-r128
  xserver-xorg-video-radeon xserver-xorg-video-savage xserver-xorg-video-tdfx
  xserver-xorg-video-trident xserver-xorg-video-vesa xserver-xorg-video-vmware
440 upgraded, 14 newly installed, 5 to remove and 0 not upgraded.
Need to get 486 MB of archives.
After this operation, 113 MB of additional disk space will be used.
to this:
Code: [Select]
The following packages were automatically installed and are no longer required:
  libip6tc0 libiptc0
Use 'sudo apt autoremove' to remove them.
The following packages will be REMOVED:
  gufw iptables ufw xserver-xorg-input-vmmouse xserver-xorg-video-sisusb
The following packages will be upgraded:
  dpkg libip4tc0 libip6tc0 libiptc0 libxtables11 xserver-xorg-core
  xserver-xorg-input-evdev xserver-xorg-input-libinput
  xserver-xorg-input-mouse xserver-xorg-input-synaptics
  xserver-xorg-input-void xserver-xorg-input-wacom xserver-xorg-video-amdgpu
  xserver-xorg-video-ati xserver-xorg-video-cirrus xserver-xorg-video-dummy
  xserver-xorg-video-fbdev xserver-xorg-video-intel xserver-xorg-video-mach64
  xserver-xorg-video-mga xserver-xorg-video-neomagic
  xserver-xorg-video-nouveau xserver-xorg-video-qxl xserver-xorg-video-r128
  xserver-xorg-video-radeon xserver-xorg-video-savage xserver-xorg-video-tdfx
  xserver-xorg-video-trident xserver-xorg-video-vesa xserver-xorg-video-vmware
30 upgraded, 0 newly installed, 5 to remove and 0 not upgraded.
Need to get 8,130 kB/10.2 MB of archives.
After this operation, 5,714 kB disk space will be freed.
;D
« Last Edit: 2016/11/30, 10:00:59 by KrunchTime »

Offline piper

  • Global Moderator
  • User
  • *****
  • Posts: 1.787
  • we are the priests ... of the temples of syrinx
Re: Warnig: No dist-upgrade
« Reply #52 on: 2016/11/30, 10:10:12 »
Code: [Select]
apt-get install --no-remove pkgname
Sooner or later, that will bite you in the ass
« Last Edit: 2016/11/30, 10:13:39 by piper »
Free speech isn't just fucking saying what you want to say, it's also hearing what you don't want to fucking hear

I either give too many fucks or no fucks at all, it's like I cannot find a middle ground for a moderate fuck distribution, it's like what the fuck

Offline KrunchTime

  • User
  • Posts: 183
Re: Warnig: No dist-upgrade
« Reply #53 on: 2016/11/30, 10:46:06 »
In what way?  When I used it earlier today, if there were packages that were going to be removed, nothing happened, which is exactly what I wanted.  This would have saved me from having all of my xserver-xorg-video-xxx packages being removed on my desktop.
« Last Edit: 2016/11/30, 10:51:40 by KrunchTime »

Offline tmhind2

  • User
  • Posts: 60
Re: Warnig: No dist-upgrade
« Reply #54 on: 2016/11/30, 10:56:23 »
You may be right this time about not removing packages, but Piper is only giving you a warning to be careful.  :)

Offline seasons

  • User
  • Posts: 261
Re: Warnig: No dist-upgrade
« Reply #55 on: 2016/11/30, 15:12:45 »
In what way?  When I used it earlier today, if there were packages that were going to be removed, nothing happened, which is exactly what I wanted.

I think piper is referring to cherry-picking upgrades (especially using apt-get install) in general. If you want to use the '--no-remove' option with 'dist-upgrade' as extra security, I can't see how that would cause issues.

Offline blaze

  • User
  • Posts: 9
Re: Warnig: No dist-upgrade
« Reply #56 on: 2016/11/30, 15:19:51 »
After dist-upgrade, and reinstall of xorg (despite some bug warning from apt) things are working again.

This is only a  base install with Openbox though. :)

Offline KrunchTime

  • User
  • Posts: 183
Re: Warnig: No dist-upgrade
« Reply #57 on: 2016/11/30, 22:53:34 »
@seasons:  Interesting...I didn't think of using the --no-remove option with dist-upgrade.  I'll hold off trying that in the future until I get more clarification about the cons of using the option.

Edit:  dist-upgrade with the --no-remove option will not work if there are packages to be removed.

On another note, I could have saved myself a lot of time earlier this morning by just marking the packages to be removed for hold.  I did that on my desktop a few minutes ago and successfully dist-upgraded.  Of course, you have to remember to unhold the packages afterwards and if there are a number of packages to be removed, it may be better to just wait.
« Last Edit: 2016/11/30, 23:54:02 by KrunchTime »

Offline seasons

  • User
  • Posts: 261
Re: Warnig: No dist-upgrade
« Reply #58 on: 2016/12/01, 00:26:39 »
Edit:  dist-upgrade with the --no-remove option will not work if there are packages to be removed.

I thought that's what you wanted? That will prevent you from accidentally saying yes to a d-u with package removals.

Quote
On another note, I could have saved myself a lot of time earlier this morning by just marking the packages to be removed for hold.  I did that on my desktop a few minutes ago and successfully dist-upgraded.  Of course, you have to remember to unhold the packages afterwards and if there are a number of packages to be removed

I don't see how that's ultimately different than cherry-picking packages to upgrade except that it's faster (and will break your system faster if you don't know what you're doing).

Quote
it may be better to just wait
Hallelujah! Another one has seen the light!
Seriously, if you're unsure about removals, ask here. Sometimes, you can safely let things go. Sometimes, you have to let something go and reinstall it to work around a bug (like the recent iptables bug).

Offline KrunchTime

  • User
  • Posts: 183
Re: Warnig: No dist-upgrade
« Reply #59 on: 2016/12/01, 00:54:47 »
I thought that's what you wanted? That will prevent you from accidentally saying yes to a d-u with package removals.
That will prevent you from doing anything.  When performing a normal dist-upgrade, you are prompted with something like "Do you want to continue?", which is sufficient for preventing something you don't want to happen.  You just enter "n" and press the <ENTER> key.

Quote
I don't see how that's ultimately different than cherry-picking packages to upgrade except that it's faster (and will break your system faster if you don't know what you're doing).
saved myself a lot of time = faster  ;)   Also, cherry picking can break your system as well if you're not careful, as happened to me recently on my desktop; still no GUI.  :'(

Quote
Hallelujah! Another one has seen the light!
Seriously, if you're unsure about removals, ask here. Sometimes, you can safely let things go. Sometimes, you have to let something go and reinstall it to work around a bug (like the recent iptables bug).
It would be nice to learn how to determine when to let things get removed.